- Update to 0.8.0
PR: ports/89331 Submitted by: Alex Trull <freebsd.alex@trull.org> (maintainer)
This commit is contained in:
parent
c11033e057
commit
3cf025aca0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=148958
@ -6,12 +6,12 @@
|
||||
#
|
||||
|
||||
PORTNAME= scummvm-tools
|
||||
PORTVERSION= 0.7.0
|
||||
PORTVERSION= 0.8.0
|
||||
CATEGORIES= games emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= scummvm
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= freebsd.alex@trull.org
|
||||
COMMENT= Tools for use with the SCUMMVM game emulator
|
||||
|
||||
RUN_DEPENDS= scummvm:${PORTSDIR}/games/scummvm
|
||||
@ -23,15 +23,16 @@ BUILD_DEPENDS= lame:${PORTSDIR}/audio/lame \
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
WRKSRC= ${WRKDIR}/tools-${PORTVERSION}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
|
||||
USE_GCC= 3.3+
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
.for i in descumm extract md5table mm_nes_extract queenrebuild rescumm
|
||||
.for i in compress_queen compress_saga compress_san compress_scumm_bun compress_scumm_sou compress_simon compress_sword1 compress_sword2 extract_kyra extract_loom_tg16 extract_mm_c64 extract_mm_nes extract_scumm_mac extract_simon1_amiga extract_zak_c64 dekyra descumm desword2
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
|
||||
.endfor
|
||||
|
||||
@ -43,7 +44,7 @@ do-install:
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' ${WRKSRC}/Makefile
|
||||
.if ${OSVERSION} < 500000
|
||||
@${REINPLACE_CMD} -e 's/gcc/gcc32/g' ${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's/gcc/${CC}/g' ${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's/g\+\+/g\+\+32/g' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
MD5 (scummvm-tools-0.7.0.tar.bz2) = eeebbd4e309a8564dd911d5c26fed2f0
|
||||
SIZE (scummvm-tools-0.7.0.tar.bz2) = 98664
|
||||
MD5 (scummvm-tools-0.8.0.tar.bz2) = cc7e13ea10acf692c10e90b9507074ed
|
||||
SHA256 (scummvm-tools-0.8.0.tar.bz2) = b60936416e201eda18c627c85bc29ba742e1b6c98d79bc9935ed4827a2e47fa0
|
||||
SIZE (scummvm-tools-0.8.0.tar.bz2) = 92983
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- simon1decr.c.orig Mon Apr 12 00:10:19 2004
|
||||
+++ simon1decr.c Tue Jan 4 15:36:39 2005
|
||||
@@ -26,14 +26,9 @@
|
||||
|
||||
#define EndGetM32(a) ((((a)[0])<<24)|(((a)[1])<<16)|(((a)[2])<<8)|((a)[3]))
|
||||
|
||||
-#define SD_GETBIT(var) do { \
|
||||
- if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } \
|
||||
- (var) = bb & 1; bb >>= 1; \
|
||||
-} while (0)
|
||||
+#define SD_GETBIT(var) do { if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } (var) = bb & 1; bb >>= 1; } while (0)
|
||||
|
||||
-#define SD_GETBITS(var, nbits) do { \
|
||||
- bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } \
|
||||
-} while (0)
|
||||
+#define SD_GETBITS(var, nbits) do { bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } } while (0)
|
||||
|
||||
#define SD_TYPE_LITERAL (0)
|
||||
#define SD_TYPE_MATCH (1)
|
@ -1,8 +1,20 @@
|
||||
bin/compress_queen
|
||||
bin/compress_saga
|
||||
bin/compress_san
|
||||
bin/compress_scumm_bun
|
||||
bin/compress_scumm_sou
|
||||
bin/compress_simon
|
||||
bin/compress_sword1
|
||||
bin/compress_sword2
|
||||
bin/extract_kyra
|
||||
bin/extract_loom_tg16
|
||||
bin/extract_mm_c64
|
||||
bin/extract_mm_nes
|
||||
bin/extract_scumm_mac
|
||||
bin/extract_simon1_amiga
|
||||
bin/extract_zak_c64
|
||||
bin/dekyra
|
||||
bin/descumm
|
||||
bin/extract
|
||||
bin/md5table
|
||||
bin/mm_nes_extract
|
||||
bin/queenrebuild
|
||||
bin/rescumm
|
||||
bin/desword2
|
||||
%%PORTDOCS%%share/doc/scummvm-tools/README
|
||||
%%PORTDOCS%%@dirrm share/doc/scummvm-tools
|
||||
|
@ -1,12 +1,12 @@
|
||||
# New ports collection makefile for: scummvm
|
||||
# Date created: Tue Sep 2 23:34:32 BST 2003
|
||||
# Whom: Alex Trull <alexander@trull.com>
|
||||
# Whom: Alex Trull <freebsd.alex@trull.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= scummvm
|
||||
PORTVERSION= 0.7.1
|
||||
PORTVERSION= 0.8.0
|
||||
CATEGORIES= games emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -15,6 +15,7 @@ MAINTAINER= freebsd.alex@trull.org
|
||||
COMMENT= Graphical Adventure Game Virtual Machine
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GCC= 3.3+
|
||||
USE_GMAKE= yes
|
||||
HAS_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
@ -24,6 +25,7 @@ CONFIGURE_ARGS=--with-sdl-prefix=${LOCALBASE} \
|
||||
--disable-alsa \
|
||||
--with-zlib-prefix=/usr \
|
||||
--disable-debug
|
||||
CONFIGURE_ENV= CXX="${CXX}"
|
||||
|
||||
OPTIONS= VORBIS "Enable Ogg Vorbis support" off \
|
||||
MAD "Enable mad (MP3) support" on \
|
||||
@ -35,7 +37,7 @@ PORTDOCS= NEWS README TODO
|
||||
PLIST_FILES= bin/scummvm
|
||||
|
||||
.if defined(WITH_MPEG2)
|
||||
WITH_VORBIS= yes
|
||||
WITH_VORBIS= yes
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
MD5 (scummvm-0.7.1.tar.bz2) = a935499011c59441fcce8322ea1c4f1d
|
||||
SIZE (scummvm-0.7.1.tar.bz2) = 2051004
|
||||
MD5 (scummvm-0.8.0.tar.bz2) = 56bfbcfbe5adde42a2a9e3d6dc3d9068
|
||||
SHA256 (scummvm-0.8.0.tar.bz2) = ba1607691f0859974543b3d3759edf21860415f2c9d2bc4bdf1639a28f88a1a2
|
||||
SIZE (scummvm-0.8.0.tar.bz2) = 2654730
|
||||
|
Loading…
Reference in New Issue
Block a user