x11-themes/kf5-breeze-icons: help cmake find the proper python3
Reported by: VVD
This commit is contained in:
parent
3a9294916c
commit
3ced73c5a6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=552508
@ -20,7 +20,8 @@ USE_QT= buildtools_build core qmake_build testlib
|
||||
SHEBANG_FILES= svg-xml-script-template.py generate-24px-versions.py
|
||||
|
||||
NO_ARCH= yes
|
||||
CMAKE_ARGS= -DXMLLINT_EXE:PATH=''
|
||||
CMAKE_ARGS= -DXMLLINT_EXE:PATH='' \
|
||||
-DPython3_EXECUTABLE:PATH=${PYTHON_CMD}
|
||||
CMAKE_ON= WITH_ICON_GENERATION
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
17
x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
Normal file
17
x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,17 @@
|
||||
--- CMakeLists.txt.orig 2020-10-04 09:45:37 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -25,11 +25,11 @@ include(GtkUpdateIconCache)
|
||||
set(REQUIRED_QT_VERSION 5.12.0)
|
||||
|
||||
# Find Python 3
|
||||
-find_package (Python 3 COMPONENTS Interpreter)
|
||||
+find_package (Python3 COMPONENTS Interpreter)
|
||||
|
||||
-if(Python_FOUND)
|
||||
+if(Python3_FOUND)
|
||||
# Find lxml Python 3 module
|
||||
- exec_program(${Python_EXECUTABLE}
|
||||
+ exec_program(${Python3_EXECUTABLE}
|
||||
ARGS "-c \"import lxml; print(lxml.get_include())\""
|
||||
RETURN_VALUE LXML_NOT_FOUND # Returns 0 or false if successful
|
||||
)
|
Loading…
Reference in New Issue
Block a user