Submitted by: archie Cobbs (archie@whistle.com)

Apple ][ assembler and linker written by archie in the dark ages.
This commit is contained in:
Julian Elischer 1998-07-01 19:13:37 +00:00
parent 2c26d9e848
commit 3ce6522991
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11642
12 changed files with 174 additions and 0 deletions

1
devel/a2dev/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (a2dev-1.2.tgz) = 52602395508b1e2f5d7dfd7b1d22776e

View File

@ -0,0 +1,23 @@
diff -ur a2dev-1.2.orig/Make.defs a2dev-1.2/Make.defs
--- a2dev-1.2.orig/Make.defs Tue Mar 28 07:14:43 1995
+++ a2dev-1.2/Make.defs Wed Jul 1 18:22:36 1998
@@ -7,8 +7,8 @@
# Where are installation "bin" and "man" subdirectories?
-INSTBIN = /usr/local/bin
-INSTMAN = /usr/local/man
+INSTBIN = ${PREFIX}/bin
+INSTMAN = ${PREFIX}/man
# What utilities to use when making
@@ -21,7 +21,7 @@
BISON = bison
AR = ar
RM = rm -f
-INSTALL = ginstall
+INSTALL = install
# Where our utility library is

View File

@ -0,0 +1,12 @@
diff -ur a2dev-1.2.orig/Makefile a2dev-1.2/Makefile
--- a2dev-1.2.orig/Makefile Sun Mar 26 06:08:22 1995
+++ a2dev-1.2/Makefile Wed Jul 1 18:27:21 1998
@@ -13,7 +13,7 @@
include Make.defs
-GENERIC = default install clean distclean
+GENERIC = all default install clean distclean
SUBDIRS = util asm link load objx test
###

View File

@ -0,0 +1,12 @@
diff -ur a2dev-1.2.orig/asm/Makefile a2dev-1.2/asm/Makefile
--- a2dev-1.2.orig/asm/Makefile Sun Mar 26 03:52:23 1995
+++ a2dev-1.2/asm/Makefile Wed Jul 1 18:23:11 1998
@@ -25,7 +25,7 @@
### Abstract rules
###
-default: $(PROG)
+all: $(PROG)
install: installbin installman

View File

@ -0,0 +1,12 @@
diff -ur a2dev-1.2.orig/link/Makefile a2dev-1.2/link/Makefile
--- a2dev-1.2.orig/link/Makefile Sun Mar 26 03:52:45 1995
+++ a2dev-1.2/link/Makefile Wed Jul 1 18:23:18 1998
@@ -16,7 +16,7 @@
### Abstract rules
###
-default: $(PROG)
+all: $(PROG)
install: installbin installman

View File

@ -0,0 +1,12 @@
diff -ur a2dev-1.2.orig/load/Makefile a2dev-1.2/load/Makefile
--- a2dev-1.2.orig/load/Makefile Sun Mar 26 03:52:37 1995
+++ a2dev-1.2/load/Makefile Wed Jul 1 18:23:25 1998
@@ -16,7 +16,7 @@
### Abstract rules
###
-default: $(PROG)
+all: $(PROG)
install: installbin installman

View File

@ -0,0 +1,12 @@
diff -ur a2dev-1.2.orig/objx/Makefile a2dev-1.2/objx/Makefile
--- a2dev-1.2.orig/objx/Makefile Sun Mar 26 03:52:54 1995
+++ a2dev-1.2/objx/Makefile Wed Jul 1 18:23:27 1998
@@ -16,7 +16,7 @@
### Abstract rules
###
-default: $(PROG)
+all: $(PROG)
install: installbin installman

View File

@ -0,0 +1,39 @@
diff -ur a2dev-1.2.orig/test/Makefile a2dev-1.2/test/Makefile
--- a2dev-1.2.orig/test/Makefile Mon Mar 27 22:16:25 1995
+++ a2dev-1.2/test/Makefile Wed Jul 1 18:34:39 1998
@@ -11,11 +11,12 @@
### Default is to do nothing -- "make verify" runs the test.
###
-default:
+all: verify
+ @echo
install:
-verify: clean all.exec *.CHECK
+verify: all.exec *.CHECK
@echo
%.CHECK: %
@@ -25,16 +26,16 @@
@echo '***' $< is 'OK!'
all.o: foo.o bar.o new.o
- a2link -o $@ $^
+ ../link/a2link -o $@ $^
%.lst %.o: %.s
- a2asm -l $< > $*.lst
+ ../asm/a2asm -l $< > $*.lst
%.obj: %.o
- a2load $< > $@
+ ../load/a2load $< > $@
%.exec: %.o
- a2load -e $< > $@
+ ../load/a2load -e $< > $@
clean:
rm -f *.o *.obj *.lst *.exec

View File

@ -0,0 +1,30 @@
diff -ur a2dev-1.2.orig/util/Makefile a2dev-1.2/util/Makefile
--- a2dev-1.2.orig/util/Makefile Wed Mar 22 19:05:32 1995
+++ a2dev-1.2/util/Makefile Wed Jul 1 18:41:55 1998
@@ -9,14 +9,15 @@
UTIL := util.a
-SRCS := $(shell ls *.c)
+SRCS := error.c misc.c names.c sym.c hash.c
+
OBJS := $(SRCS:.c=.o)
###
### Abstract rules
###
-default: $(UTIL)
+all: $(UTIL)
install: default
@@ -32,7 +33,7 @@
$(UTIL): $(OBJS)
$(RM) $(UTIL)
- $(AR) rcs $(UTIL) $(OBJS)
+ $(AR) -rc $(UTIL) $(OBJS)
###
### Additional dependencies

1
devel/a2dev/pkg-comment Normal file
View File

@ -0,0 +1 @@
Apple II 6502 assembler, linker, loader, and object file viewer

12
devel/a2dev/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
This is a suite of programs for developing software
targeted for 65c02 machines, like the Apple 2 series.
These programs are included:
a2asm -- Assembler
a2link -- Linker
a2load -- Loader
a2objx -- Object file viewer
Archie L. Cobbs <archie@whistle.com>

8
devel/a2dev/pkg-plist Normal file
View File

@ -0,0 +1,8 @@
bin/a2asm
bin/a2link
bin/a2load
bin/a2objx
man/man1/a2asm.1.gz
man/man1/a2link.1.gz
man/man1/a2load.1.gz
man/man1/a2objx.1.gz