Add xmms-cdread 0.14a, a XMMS input plugin for read AudioCD

via IDE bus.

PR:		ports/49972
Submitted by:	Sergey V. Belov <argail@csite.ru>
This commit is contained in:
Norikatsu Shigemura 2003-03-23 07:51:47 +00:00
parent 52bd9c4f01
commit 3cdfc2ce15
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77227
7 changed files with 77 additions and 0 deletions

View File

@ -307,6 +307,7 @@
SUBDIR += xmms-a52dec
SUBDIR += xmms-audiofile
SUBDIR += xmms-bonk
SUBDIR += xmms-cdread
SUBDIR += xmms-crossfade
SUBDIR += xmms-crystality
SUBDIR += xmms-faad

View File

@ -0,0 +1,28 @@
# New ports collection makefile for: xmms-cdread
# Date created: 12 May 2003
# Whom: Sergey V. Belov <argail@csite.ru>
#
# $FreeBSD$
#
PORTNAME= xmms-cdread
PORTVERSION= 0.14a
CATEGORIES= audio
MASTER_SITES= ftp://ftp.stack.nl/pub/users/willem/
MAINTAINER= argail@csite.ru
COMMENT= A XMMS input plugin for read AudioCD via IDE bus
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
USE_X_PREFIX= yes
USE_GNOMENG= yes
USE_GNOME= gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (xmms-cdread-0.14a.tar.gz) = 1328b75ef91d73690b3b43d74401754a

View File

@ -0,0 +1,18 @@
--- cdrombsd.h.orig Sat Aug 18 19:09:10 2001
+++ cdrombsd.h Sun Mar 23 16:35:33 2003
@@ -9,12 +9,9 @@
|*| FreeBSD (?) specific code
\*/
-#define GET_LBA(entry) ((entry.addr_type == CD_LBA_FORMAT) ? \
- ntohl(entry.addr.lba) : \
- ((entry.addr.msf.minute * 60 + \
- entry.addr.msf.second) * 75 + \
- entry.addr.msf.frame))
-
+#define GET_LBA(entry) ((entry.addr.msf.minute * 60 \
+ + entry.addr.msf.second) * 75 \
+ + entry.addr.msf.frame)
/*\
|*| Open cdrom device

View File

@ -0,0 +1,20 @@
--- server.c.orig Fri Jul 20 00:26:42 2001
+++ server.c Sun Mar 23 16:35:33 2003
@@ -282,7 +282,7 @@
if (r < 0) {
req->rest[0] = 0;
if (errno == EAGAIN) {
- errno = ETIME;
+ errno = ETIMEDOUT;
if (++rtr < READ_TIMEOUT) {
xmms_usleep(READ_USEC);
continue;
@@ -312,7 +312,7 @@
gint w = write(sock, p, strlen(p));
if (w < 0) {
if (errno == EAGAIN) {
- errno = ETIME;
+ errno = ETIMEDOUT;
if (++rtr < READ_TIMEOUT) {
xmms_usleep(READ_USEC);
continue;

View File

@ -0,0 +1,7 @@
Xmms-CdRead is a input plugin for XMMS (www.xmms.org) that
read the CDDA (audio) discs as data via IDE bus, provides
more quality sound and allowing XMMS to use that for
visualization.
- Sergey V. Belov (aka Argail)
argail@visit.ru

View File

@ -0,0 +1,2 @@
lib/xmms/Input/libcdread.so
lib/xmms/Input/libcdread.la