net-mgmt/kismet: 2013-03-R1b -> 2016-07-R1, take maintainer
- Turn on FCS validation by default for all sources - support for recent autotools - fixes for crashes when alert backlog was set to zero - fixes for failures in some VIF situations - fixes to resizing windows - fixes to GPS averaging - add WPS state parsing - handle BSSTimestamp parsing - other assorted bug fixes and behavior improvements. - nl8011 support is fixed so finding the vif device works again - full 5GHz channel discovery works now - memory leaks in the drone are fixed - some ncurses compile bugs are resolved.
This commit is contained in:
parent
b0339417b3
commit
3cbaf768d1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=417965
@ -2,17 +2,12 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= kismet
|
||||
DISTVERSION= 2013-03-R1b
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 2016-07-R1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= http://www.kismetwireless.net/code/:1 \
|
||||
http://anonsvn.wireshark.org/wireshark/trunk/:2
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:1
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
MASTER_SITES= http://www.kismetwireless.net/code/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= pi@FreeBSD.org
|
||||
COMMENT= 802.11 layer2 wireless network detector, sniffer, and IDS
|
||||
|
||||
LICENSE= GPLv2
|
||||
@ -31,8 +26,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/a$$//}
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
PORTDOCS= README manuf
|
||||
DISTFILES+= manuf:2
|
||||
PORTDOCS= README
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@ -62,7 +56,7 @@ PLIST_SUB+= SUID="@comment " SUIDGROUP=""
|
||||
.if ${PORT_OPTIONS:MPLUGINS}
|
||||
ALL_TARGET= depend all all-plugins
|
||||
INSTALL_TARGET+= all-plugins-install
|
||||
USE_OPENSSL= yes
|
||||
USES+= ssl
|
||||
PLIST_SUB+= PLUGINS=""
|
||||
.else
|
||||
PLIST_SUB+= PLUGINS="@comment "
|
||||
@ -88,21 +82,20 @@ post-patch:
|
||||
-e 's,-o $$(INSTUSR) -g $$(SUIDGROUP) -m 4550,,'
|
||||
|
||||
post-build:
|
||||
@cd ${WRKSRC}; ${STRIP_CMD} kismet_client kismet_drone kismet_server */*.so
|
||||
cd ${WRKSRC}; ${STRIP_CMD} kismet_client kismet_drone kismet_server */*.so
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manuf ${STAGEDIR}${DOCSDIR}
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/ruby/* ${STAGEDIR}${EXAMPLESDIR}
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/ruby/* ${STAGEDIR}${EXAMPLESDIR}
|
||||
.endif
|
||||
@${MV} ${STAGEDIR}${PREFIX}/etc/kismet.conf \
|
||||
${MV} ${STAGEDIR}${PREFIX}/etc/kismet.conf \
|
||||
${STAGEDIR}${PREFIX}/etc/kismet.conf.sample
|
||||
@${MV} ${STAGEDIR}${PREFIX}/etc/kismet_drone.conf \
|
||||
${MV} ${STAGEDIR}${PREFIX}/etc/kismet_drone.conf \
|
||||
${STAGEDIR}${PREFIX}/etc/kismet_drone.conf.sample
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,4 +1,3 @@
|
||||
SHA256 (kismet/kismet-2013-03-R1b.tar.xz) = 636d4d7ef8c67ae6ee8d8e1635f5115700eecb9fa4c208afaee30238db527c2c
|
||||
SIZE (kismet/kismet-2013-03-R1b.tar.xz) = 699968
|
||||
SHA256 (kismet/manuf) = 42dcb7c3a677cfd23d0c08d30b9cd8abc8a57237ea2f7b90014eb4ea98446140
|
||||
SIZE (kismet/manuf) = 1393916
|
||||
TIMESTAMP = 1467539059
|
||||
SHA256 (kismet-2016-07-R1.tar.xz) = bdb21f153311f1ff3b16621bf0d6740f66369bf0982b0a289c9a12af8847e237
|
||||
SIZE (kismet-2016-07-R1.tar.xz) = 709364
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- alertracker.cc.orig 2010-09-03 10:57:56.000000000 -0400
|
||||
+++ alertracker.cc 2010-09-03 11:36:42.000000000 -0400
|
||||
@@ -397,6 +397,7 @@
|
||||
--- alertracker.cc.orig 2016-07-02 18:06:10 UTC
|
||||
+++ alertracker.cc
|
||||
@@ -405,6 +405,7 @@ int Alertracker::ParseAlertConfig(Config
|
||||
&(rec->limit_burst)) < 0) {
|
||||
_MSG("Invalid alert line in config file: " + clines[x], MSGFLAG_FATAL);
|
||||
globalreg->fatal_condition = 1;
|
||||
|
10
net-mgmt/kismet/files/patch-packetsource__pcap.cc
Normal file
10
net-mgmt/kismet/files/patch-packetsource__pcap.cc
Normal file
@ -0,0 +1,10 @@
|
||||
--- packetsource_pcap.cc.orig 2016-07-02 18:06:10 UTC
|
||||
+++ packetsource_pcap.cc
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <time.h>
|
||||
+#include <net/bpf.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
@ -1,11 +0,0 @@
|
||||
--- restricted-plugin-autowep/Makefile.orig 2013-03-25 13:29:11.000000000 -0400
|
||||
+++ restricted-plugin-autowep/Makefile 2013-04-04 15:37:44.000000000 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
install: $(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)/$(plugindir)
|
||||
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)/$(plugindir)/$^
|
||||
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $(PLUGOUT) $(DESTDIR)/$(plugindir)/$(PLUGOUT)
|
||||
|
||||
userinstall: $(PLUGOUT)
|
||||
mkdir -p ${HOME}/.kismet/plugins/
|
@ -1,11 +0,0 @@
|
||||
--- restricted-plugin-ptw/Makefile.orig 2013-04-04 15:43:05.000000000 -0400
|
||||
+++ restricted-plugin-ptw/Makefile 2013-04-04 15:44:50.000000000 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
install: $(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)/$(plugindir)
|
||||
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)/$(plugindir)/$^
|
||||
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $(PLUGOUT) $(DESTDIR)/$(plugindir)/$(PLUGOUT)
|
||||
|
||||
userinstall: $(PLUGOUT)
|
||||
mkdir -p ${HOME}/.kismet/plugins/
|
@ -0,0 +1,22 @@
|
||||
--- restricted-plugin-autowep/Makefile.orig 2016-07-02 18:06:10 UTC
|
||||
+++ restricted-plugin-autowep/Makefile
|
||||
@@ -9,8 +9,8 @@ top_builddir = $(BLDHOME)
|
||||
|
||||
PLUGINLDFLAGS += -shared -rdynamic
|
||||
LIBS += -lstdc++
|
||||
-CFLAGS += -I$(KIS_INC_DIR) -g -fPIC
|
||||
-CXXFLAGS += -I$(KIS_INC_DIR) -g -fPIC
|
||||
+CFLAGS += -I$(KIS_INC_DIR) -fPIC
|
||||
+CXXFLAGS += -I$(KIS_INC_DIR) -fPIC
|
||||
|
||||
PLUGOBJS = autowep-kismet.o
|
||||
PLUGOUT = autowep-kismet.so
|
||||
@@ -22,7 +22,7 @@ $(PLUGOUT): $(PLUGOBJS)
|
||||
|
||||
install: $(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)/$(plugindir)
|
||||
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)/$(plugindir)/$^
|
||||
+ $(INSTALL) -m 644 $(PLUGOUT) $(DESTDIR)/$(plugindir)/$(PLUGOUT)
|
||||
|
||||
userinstall: $(PLUGOUT)
|
||||
mkdir -p ${HOME}/.kismet/plugins/
|
22
net-mgmt/kismet/files/patch-restricted-plugin-ptw_Makefile
Normal file
22
net-mgmt/kismet/files/patch-restricted-plugin-ptw_Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
--- restricted-plugin-ptw/Makefile.orig 2016-07-02 18:06:10 UTC
|
||||
+++ restricted-plugin-ptw/Makefile
|
||||
@@ -9,8 +9,8 @@ top_builddir = $(BLDHOME)
|
||||
|
||||
PLUGINLDFLAGS += -shared -rdynamic
|
||||
LIBS += -lstdc++ -lssl -lpthread -lcrypto
|
||||
-CFLAGS += -I$(KIS_INC_DIR) -g -fPIC
|
||||
-CXXFLAGS += -I$(KIS_INC_DIR) -g -fPIC
|
||||
+CFLAGS += -I$(KIS_INC_DIR) -fPIC
|
||||
+CXXFLAGS += -I$(KIS_INC_DIR) -fPIC
|
||||
|
||||
PLUGOBJS = aircrack-crypto.o aircrack-ptw2-lib.o aircrack-kismet.o
|
||||
PLUGOUT = aircrack-kismet.so
|
||||
@@ -22,7 +22,7 @@ $(PLUGOUT): $(PLUGOBJS)
|
||||
|
||||
install: $(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)/$(plugindir)
|
||||
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)/$(plugindir)/$^
|
||||
+ $(INSTALL) -m 644 $(PLUGOUT) $(DESTDIR)/$(plugindir)/$(PLUGOUT)
|
||||
|
||||
userinstall: $(PLUGOUT)
|
||||
mkdir -p ${HOME}/.kismet/plugins/
|
@ -1,5 +1,5 @@
|
||||
--- restricted-plugin-ptw/aircrack-crypto.cc.orig 2010-05-24 11:40:15.000000000 +0200
|
||||
+++ restricted-plugin-ptw/aircrack-crypto.cc 2010-05-24 11:39:34.000000000 +0200
|
||||
--- restricted-plugin-ptw/aircrack-crypto.cc.orig 2016-07-02 18:06:10 UTC
|
||||
+++ restricted-plugin-ptw/aircrack-crypto.cc
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <string.h>
|
||||
#include <arpa/inet.h>
|
Loading…
Reference in New Issue
Block a user