- Update to 4.18
- Take over maintainership Approved by: old maintainer (takeover)
This commit is contained in:
parent
4acd18d12d
commit
3cb77fc103
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=157228
@ -6,87 +6,63 @@
|
||||
#
|
||||
|
||||
PORTNAME= boinc-setiathome
|
||||
PORTVERSION= 4.07.20050601
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 4.18
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= http://setiweb.ssl.berkeley.edu/sah/seti_source/nightly/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= pav
|
||||
DISTNAME= seti_boinc-client-cvs-2005-06-01
|
||||
DISTNAME= seti_boinc-${PORTVERSION}
|
||||
|
||||
MAINTAINER= fbsd@opal.com
|
||||
MAINTAINER= pav@FreeBSD.org
|
||||
COMMENT= Setiathome for boinc
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
BUILD_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
|
||||
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
|
||||
|
||||
# Disable GUI on FreeBSD 4.x due to problems with wxgtk lib
|
||||
.if ${OSVERSION} < 500000
|
||||
WITHOUT_X11= yes
|
||||
.endif
|
||||
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/lib/boinc/boinc-client:${PORTSDIR}/net/boinc-client
|
||||
RUN_DEPENDS+= boinc:${PORTSDIR}/net/boinc-client
|
||||
.if !defined(WITHOUT_FFTW)
|
||||
LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
|
||||
.if !defined(WITHOUT_X11)
|
||||
LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
|
||||
glut:${PORTSDIR}/graphics/libglut
|
||||
.endif
|
||||
|
||||
USE_AUTOTOOLS= automake:19 autoheader:259 autoconf:259 libtool:15
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
.if !defined(WITHOUT_X11)
|
||||
USE_XLIB= yes
|
||||
.endif
|
||||
|
||||
WRKSRC= ${WRKDIR}/seti_boinc
|
||||
|
||||
CONFIGURE_ARGS= --disable-server
|
||||
.if !defined(WITHOUT_X11)
|
||||
CONFIGURE_ARGS+= --disable-dynamic-graphics
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-gui
|
||||
.endif
|
||||
CONFIGURE_ENV= LANG=C BOINCDIR=${LOCALBASE} CPPFLAGS=-I${X11BASE}/include CXXFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
|
||||
CONFLICTS= boinc-setiathome-naparst-[0-9]*
|
||||
|
||||
# disable gui, it's broken anyway
|
||||
CONFIGURE_ARGS= --disable-server --disable-gui
|
||||
CONFIGURE_ENV= LANG=C BOINCDIR=${LOCALBASE} CXXFLAGS="-I${LOCALBASE}/include ${CFLAGS} -O3" LDFLAGS=-L${LOCALBASE}/lib CFLAGS="${CFLAGS} -O3"
|
||||
MAKE_ENV= LANG=C
|
||||
|
||||
# these must match settings in ../../net/boinc-client/Makefile
|
||||
BOINC_USER= boinc
|
||||
BOINC_GROUP= nobody
|
||||
BOINC_HOME= /var/db/boinc
|
||||
BOINC_USER?= boinc
|
||||
BOINC_GROUP?= nobody
|
||||
BOINC_HOME?= /var/db/boinc
|
||||
|
||||
SETI_SITE= setiathome.berkeley.edu
|
||||
SETI_BINARY= setiathome
|
||||
|
||||
PLIST_SUB= SETI_BINARY="${SETI_BINARY}" SETI_SITE=${SETI_SITE} \
|
||||
BOINC_HOME=${BOINC_HOME}
|
||||
.if !defined(WITHOUT_X11)
|
||||
PLIST_SUB+= BOINC_GUI=""
|
||||
.else
|
||||
PLIST_SUB+= BOINC_GUI="@comment "
|
||||
|
||||
SUB_FILES= app_info.xml
|
||||
SUB_LIST= SETI_BINARY="${SETI_BINARY}" SETI_NODOTVER="${PORTVERSION:S/.//}"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Disable on FreeBSD 4.x; boinc-client is BROKEN too
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= Does not compile. Consider upgrading your FreeBSD to at least 5.X
|
||||
.endif
|
||||
|
||||
SUB_FILES= app_info.xml pkg-install
|
||||
SUB_LIST= SETI_BINARY="${SETI_BINARY}" SETI_SITE="${SETI_SITE}" \
|
||||
BOINC_HOME="${BOINC_HOME}" BOINC_USER="${BOINC_USER}" \
|
||||
BOINC_GROUP="${BOINC_GROUP}"
|
||||
|
||||
FIND_SETI_BINARY=(cd ${WRKSRC}/client; make -V CLIENT_PROG)
|
||||
|
||||
pre-configure:
|
||||
${TOUCH} ${WRKSRC}/missing
|
||||
cd ${WRKSRC}; ${ACLOCAL} -I ${LIBTOOL_SHAREDIR}/libltdl -I m4
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${BOINC_HOME}/projects/${SETI_SITE}
|
||||
${INSTALL_DATA} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/client/`${FIND_SETI_BINARY}` ${PREFIX}/lib/boinc/${SETI_BINARY}
|
||||
.if !defined(WITHOUT_X11)
|
||||
#${INSTALL_PROGRAM} ${WRKSRC}/client/`${FIND_SETI_BINARY}`.so ${PREFIX}/lib/boinc/${SETI_BINARY}.so
|
||||
.endif
|
||||
${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
|
||||
${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${SETI_SITE}
|
||||
${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}
|
||||
${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKSRC}/client/setiathome-${PORTVERSION}.${CONFIGURE_TARGET} ${BOINC_HOME}/projects/${SETI_SITE}/${SETI_BINARY}
|
||||
|
||||
post-install:
|
||||
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (seti_boinc-client-cvs-2005-06-01.tar.gz) = e18263dfed195e193fd76fd6f6cdbd01
|
||||
SHA256 (seti_boinc-client-cvs-2005-06-01.tar.gz) = 0ef1d2ac7b14687d974bb1d689b5dfa6bb81a997faace7764070c539face015c
|
||||
SIZE (seti_boinc-client-cvs-2005-06-01.tar.gz) = 1858898
|
||||
MD5 (seti_boinc-4.18.tar.bz2) = b487cee357fb448537a17b8ed74f21e2
|
||||
SHA256 (seti_boinc-4.18.tar.bz2) = 4ac3d415c88563a282d3e92bfb832bd2d4eac01e29934d2be20e1a9e6eca93bb
|
||||
SIZE (seti_boinc-4.18.tar.bz2) = 963020
|
||||
|
@ -8,7 +8,7 @@
|
||||
</file_info>
|
||||
<app_version>
|
||||
<app_name>setiathome</app_name>
|
||||
<version_num>407</version_num>
|
||||
<version_num>%%SETI_NODOTVER%%</version_num>
|
||||
<file_ref>
|
||||
<file_name>%%SETI_BINARY%%</file_name>
|
||||
<main_program/>
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- Makefile.incl.orig Wed Feb 9 12:03:32 2005
|
||||
+++ Makefile.incl Tue Mar 1 10:15:48 2005
|
||||
@@ -37,7 +37,7 @@
|
||||
VERSION_MAJOR = @MAJOR_VERSION@
|
||||
VERSION_MINOR = @MINOR_VERSION@
|
||||
|
||||
-BOINC_CFLAGS= -I$(BOINCDIR)/api -I$(BOINCDIR)/lib
|
||||
+BOINC_CFLAGS= -I$(BOINCDIR)/include/BOINC
|
||||
|
||||
|
||||
DEBUG_PROG = setiathome-$(VERSION_MAJOR).$(VERSION_MINOR).@host@.debug$(DOTEXEEXT)
|
11
astro/boinc-setiathome/files/patch-client-Makefile.in
Normal file
11
astro/boinc-setiathome/files/patch-client-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- client/Makefile.in.orig Sat Feb 4 09:02:39 2006
|
||||
+++ client/Makefile.in Sat Mar 11 19:58:41 2006
|
||||
@@ -154,7 +154,7 @@
|
||||
AUTOMAKE = @AUTOMAKE@
|
||||
AWK = @AWK@
|
||||
BOINCDIR = @BOINCDIR@
|
||||
-BOINC_CFLAGS = -I$(BOINCDIR)/api -I$(BOINCDIR)/lib
|
||||
+BOINC_CFLAGS = @BOINC_CFLAGS@
|
||||
CAT = @CAT@
|
||||
CC = @CC@
|
||||
CCDEPMODE = @CCDEPMODE@
|
41
astro/boinc-setiathome/files/patch-configure
Normal file
41
astro/boinc-setiathome/files/patch-configure
Normal file
@ -0,0 +1,41 @@
|
||||
--- configure.orig Sat Feb 4 09:02:49 2006
|
||||
+++ configure Sat Mar 11 19:51:05 2006
|
||||
@@ -22492,29 +22492,6 @@
|
||||
thisdir=`pwd`
|
||||
echo "$as_me:$LINENO: checking for BOINC" >&5
|
||||
echo $ECHO_N "checking for BOINC... $ECHO_C" >&6
|
||||
- boinc_search_path="$BOINCDIR boinc ../boinc $HOME/boinc /usr/local/boinc /usr/local/lib/boinc /opt/misc/boinc /opt/misc/lib/boinc "
|
||||
- for boinc_dir in $boinc_search_path
|
||||
- do
|
||||
- if test -d $boinc_dir
|
||||
- then
|
||||
- if test -f $boinc_dir/Makefile.am
|
||||
- then
|
||||
- cd $boinc_dir
|
||||
- BOINCDIR=`pwd`
|
||||
- cd $thisdir
|
||||
- break
|
||||
- else
|
||||
- if $FIND $boinc_dir -name "Makefile.am" >& /dev/null
|
||||
- then
|
||||
- BOINCDIR=`$FIND $boinc_dir -name "Makefile.am" -print | $HEAD -1 | sed 's/\/Makefile.am//'`
|
||||
- cd $BOINCDIR
|
||||
- BOINCDIR=`pwd`
|
||||
- cd $thisdir
|
||||
- break
|
||||
- fi
|
||||
- fi
|
||||
- fi
|
||||
- done
|
||||
if test -n "$BOINCDIR"
|
||||
then
|
||||
echo "$as_me:$LINENO: result: $BOINCDIR" >&5
|
||||
@@ -22607,7 +22584,7 @@
|
||||
fi
|
||||
|
||||
LIBS="$save_libs"
|
||||
- BOINC_CFLAGS="-I$BOINCDIR/api -I$BOINCDIR/lib"
|
||||
+ BOINC_CFLAGS="-I$BOINCDIR/include/BOINC"
|
||||
|
||||
RSA_CFLAGS="-I$RSADIR/source"
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- configure.ac.orig Thu Apr 28 03:01:09 2005
|
||||
+++ configure.ac Tue May 3 16:07:32 2005
|
||||
@@ -154,7 +154,7 @@
|
||||
AC_CHECK_LIB([jpeg], [jpeg_start_decompress])
|
||||
SAH_CHECK_SETILIB
|
||||
|
||||
-AM_CONDITIONAL(USE_MY_LIBJPEG, [test "${ac_cv_lib_jpeg_jpeg_start_decompress}" != yes])
|
||||
+AM_CONDITIONAL(USE_MY_LIBJPEG, [test "${enable_gui}" = yes -a "${ac_cv_lib_jpeg_jpeg_start_decompress}" != yes])
|
||||
dnl AC_CHECK_LIB([stdc++], [main])
|
||||
|
||||
SAH_REQUIRES([boinc],[SAH_CHECK_BOINC],["${no_boinc}" = yes],
|
||||
@@ -231,7 +231,7 @@
|
||||
AC_FUNC_STAT
|
||||
AC_FUNC_STRFTIME
|
||||
AC_CHECK_FUNCS([atexit exit _exit floor getcwd memset munmap putenv sqrt \
|
||||
-strchr strstr atoll dlopen sincosf sincos sinf cosf atanf])
|
||||
+strchr strstr atoll dlopen])
|
||||
|
||||
if test "${enable_dynamic_graphics}" = yes; then
|
||||
if test "${ac_cv_func_dlopen}" = yes; then
|
@ -1,51 +0,0 @@
|
||||
--- m4/sah_check_boinc.m4.orig Fri Dec 24 17:40:58 2004
|
||||
+++ m4/sah_check_boinc.m4 Tue Mar 1 11:27:23 2005
|
||||
@@ -18,29 +18,6 @@
|
||||
fi
|
||||
thisdir=`pwd`
|
||||
AC_MSG_CHECKING([for BOINC])
|
||||
- boinc_search_path="$BOINCDIR boinc ../boinc $HOME/boinc /usr/local/boinc /usr/local/lib/boinc /opt/misc/boinc /opt/misc/lib/boinc $2"
|
||||
- for boinc_dir in $boinc_search_path
|
||||
- do
|
||||
- if test -d $boinc_dir
|
||||
- then
|
||||
- if test -f $boinc_dir/Makefile.am
|
||||
- then
|
||||
- cd $boinc_dir
|
||||
- BOINCDIR=`pwd`
|
||||
- cd $thisdir
|
||||
- break
|
||||
- else
|
||||
- if $FIND $boinc_dir -name "Makefile.am" >& /dev/null
|
||||
- then
|
||||
- BOINCDIR=`$FIND $boinc_dir -name "Makefile.am" -print | $HEAD -1 | sed 's/\/Makefile.am//'`
|
||||
- cd $BOINCDIR
|
||||
- BOINCDIR=`pwd`
|
||||
- cd $thisdir
|
||||
- break
|
||||
- fi
|
||||
- fi
|
||||
- fi
|
||||
- done
|
||||
if test -n "$BOINCDIR"
|
||||
then
|
||||
AC_MSG_RESULT($BOINCDIR)
|
||||
@@ -56,13 +33,13 @@
|
||||
AC_SUBST([PROJECTDIR])
|
||||
AC_SUBST([BOINCDIR])
|
||||
save_libs="$LIBS"
|
||||
- RSADIR="$BOINCDIR/RSAEuro"
|
||||
- LIBS="$LIBS -L$RSADIR/source"
|
||||
- AC_CHECK_LIB([rsaeuro],[RSAPublicEncrypt],[RSALIBS="-L$RSADIR/source -lrsaeuro"])
|
||||
+ RSADIR="$BOINCDIR"
|
||||
+ LIBS="$LIBS -L$RSADIR"
|
||||
+ AC_CHECK_LIB([rsaeuro],[RSAPublicEncrypt],[RSALIBS="-L$RSADIR -lrsaeuro"])
|
||||
LIBS="$save_libs"
|
||||
- BOINC_CFLAGS="-I$BOINCDIR/api -I$BOINCDIR/lib"
|
||||
+ BOINC_CFLAGS="-I$BOINCDIR/include/BOINC"
|
||||
AC_SUBST([BOINC_CFLAGS])
|
||||
- RSA_CFLAGS="-I$RSADIR/source"
|
||||
+ RSA_CFLAGS="-I$BOINCDIR/include/BOINC"
|
||||
AC_SUBST([RSA_CFLAGS])
|
||||
AC_SUBST([RSADIR])
|
||||
AC_SUBST([RSALIBS])
|
@ -1,11 +0,0 @@
|
||||
--- m4/sah_header_stdcxx.m4.orig Mon Nov 17 18:33:14 2003
|
||||
+++ m4/sah_header_stdcxx.m4 Tue Mar 1 10:37:29 2005
|
||||
@@ -9,7 +9,7 @@
|
||||
save_inc="$ac_includes_default"
|
||||
ac_includes_default="$ac_includes_default
|
||||
#define CONFIG_TEST
|
||||
-#include \"$BOINCDIR/lib/std_fixes.h\"
|
||||
+#include <BOINC/std_fixes.h>
|
||||
"
|
||||
sah_stdcxx_headers="algorithm bitset cassert cctype cerrno cfloat climits clocale cmath complex csetjmp csignal cstdarg cstddef cstdio cstdlib cstring ctime deque fstream functional iomanip ios iosfwd iostream istream iterator limits list locale map memory numeric ostream queue set sstream stack stdexcept streambuf string utility valarray vector"
|
||||
AC_LANG_PUSH(C++)
|
@ -1,11 +0,0 @@
|
||||
--- m4/sah_largefile_breaks_cxx.m4.orig Mon Nov 17 18:33:14 2003
|
||||
+++ m4/sah_largefile_breaks_cxx.m4 Tue Mar 1 10:38:00 2005
|
||||
@@ -18,7 +18,7 @@
|
||||
[AC_DEFINE([LARGEFILE_BREAKS_CXX],[1],
|
||||
["Define to 1 if largefile support causes missing symbols in C++"] )
|
||||
tmp_res="yes"
|
||||
- sah_cxx_includes=`echo "#include \"$BOINCDIR/lib/std_fixes.h\"" ; echo $sah_cxx_includes`
|
||||
+ sah_cxx_includes=`echo "#include <BOINC/std_fixes.h>" ; echo $sah_cxx_includes`
|
||||
]
|
||||
)
|
||||
AC_MSG_RESULT($tmp_res)
|
@ -1,9 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
case "$2" in
|
||||
POST-INSTALL)
|
||||
install -d -o %%BOINC_USER%% -g %%BOINC_GROUP%% %%BOINC_HOME%%/projects/%%SETI_SITE%%
|
||||
ln -s %%PREFIX%%/lib/boinc/%%SETI_BINARY%% %%BOINC_HOME%%/projects/%%SETI_SITE%%
|
||||
#ln -s %%PREFIX%%/lib/boinc/%%SETI_BINARY%%.so %%BOINC_HOME%%/projects/%%SETI_SITE%%
|
||||
;;
|
||||
esac
|
@ -9,10 +9,9 @@ besides SETI@home are using BOINC. BOINC lets you participate in
|
||||
more than one project, and it lets you specify what fraction of
|
||||
your computer time should go to each project.
|
||||
|
||||
This port requires net/boinc-client and together these supersede
|
||||
the astro/setiathome port which is now known as SETI-Classic.
|
||||
This port requires net/boinc-client.
|
||||
|
||||
Be sure to join the "FreeBSD" team on the SETI website once you're
|
||||
up and running.
|
||||
|
||||
WWW: http://setiweb.ssl.berkeley.edu/
|
||||
WWW: http://setiathome.berkeley.edu/
|
||||
|
14
astro/boinc-setiathome/pkg-message
Normal file
14
astro/boinc-setiathome/pkg-message
Normal file
@ -0,0 +1,14 @@
|
||||
ATTACHING PROJECT
|
||||
|
||||
Just run boinc_gui, choose Attach, and follow instructions.
|
||||
Project URL is setiathome.berkeley.edu
|
||||
|
||||
MANUAL INSTALLATION
|
||||
*) If this is your first time in any BOINC project, create a new account at
|
||||
http://setiathome.berkeley.edu/create_account_form.php
|
||||
|
||||
*) Or get your account key at http://setiathome.berkeley.edu/get_passwd.php
|
||||
|
||||
*) Attach to the project:
|
||||
cd /var/db/boinc
|
||||
boinc_cmd --project_attach setiathome.berkeley.edu <account key>
|
@ -1,6 +1,4 @@
|
||||
@comment @unexec %D/lib/boinc_client -detach_project %%SETI_SITE%%
|
||||
lib/boinc/%%SETI_BINARY%%
|
||||
@comment %%BOINC_GUI%%lib/boinc/%%SETI_BINARY%%.so
|
||||
@unexec rm %%BOINC_HOME%%/projects/%%SETI_SITE%%/app_info.xml 2>&1 >/dev/null || true
|
||||
@unexec rm %%BOINC_HOME%%/projects/%%SETI_SITE%%/%%SETI_BINARY%% 2>&1 >/dev/null || true
|
||||
@comment %%BOINC_GUI%%@unexec rm %%BOINC_HOME%%/projects/%%SETI_SITE%%/%%SETI_BINARY%%.so 2>&1 >/dev/null || true
|
||||
@cwd %%BOINC_HOME%%
|
||||
projects/%%SETI_SITE%%/app_info.xml
|
||||
projects/%%SETI_SITE%%/%%SETI_BINARY%%
|
||||
@unexec rmdir %D/projects/%%SETI_SITE%% 2>/dev/null || true
|
||||
|
Loading…
Reference in New Issue
Block a user