math/mathgl: Update to 2.4.2
Reported by: portscout
This commit is contained in:
parent
86615b1ffc
commit
3c9ce2f8ae
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465264
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mathgl
|
||||
DISTVERSION= 2.4.1
|
||||
DISTVERSION= 2.4.2
|
||||
CATEGORIES= math graphics
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1505889476
|
||||
SHA256 (mathgl-2.4.1.tar.gz) = 751488bb9454c057d6e2828867dd56e00507c84a47efa1b8546da55a3455a588
|
||||
SIZE (mathgl-2.4.1.tar.gz) = 22665490
|
||||
TIMESTAMP = 1521703603
|
||||
SHA256 (mathgl-2.4.2.tar.gz) = aeb3107101a21fa7f522746affc4aebfcfefbcc430a37dc8b8bc8413434f4af0
|
||||
SIZE (mathgl-2.4.2.tar.gz) = 22665821
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- CMakeLists.txt.orig 2017-07-20 06:27:40 UTC
|
||||
--- CMakeLists.txt.orig 2018-03-21 16:48:13 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -59,13 +59,13 @@ function(mgl_add_lib mgl_tmp_lib)
|
||||
@@ -74,13 +74,13 @@ function(mgl_add_lib mgl_tmp_lib)
|
||||
set(mgl_src_lst ${ARGV})
|
||||
list(REMOVE_AT mgl_src_lst 0)
|
||||
add_library(${mgllib} SHARED ${mgl_src_lst})
|
||||
@ -16,7 +16,7 @@
|
||||
if(MSVC)
|
||||
set(mgl_lib_static "-static")
|
||||
if(CMAKE_BUILD_TYPE STREQUAL "Debug")
|
||||
@@ -76,18 +76,18 @@ function(mgl_add_lib mgl_tmp_lib)
|
||||
@@ -91,18 +91,18 @@ function(mgl_add_lib mgl_tmp_lib)
|
||||
elseif(MSVC)
|
||||
set(mgl_lib_static)
|
||||
set_target_properties(${mgllib} PROPERTIES CLEAN_DIRECT_OUTPUT 1)
|
||||
@ -39,16 +39,7 @@
|
||||
EXPORT MathGLTargets
|
||||
RUNTIME DESTINATION ${MathGL_INSTALL_BIN_DIR}
|
||||
ARCHIVE DESTINATION ${MathGL_INSTALL_LIB_DIR}
|
||||
@@ -446,7 +446,7 @@ if(enable-hdf5)
|
||||
set(MGL_HAVE_HDF5 1)
|
||||
find_package(HDF5)
|
||||
if(NOT HDF5_FOUND)
|
||||
- find_package(HDF5 NAMES hdf5 COMPONENTS C shared static)
|
||||
+ find_package(HDF5 NAMES hdf5 COMPONENTS C shared)
|
||||
if(NOT HDF5_FOUND)
|
||||
message(SEND_ERROR "Couldn't find HDF5 library.")
|
||||
endif(NOT HDF5_FOUND)
|
||||
@@ -715,7 +715,7 @@ if(NOT enable-lgpl)
|
||||
@@ -738,7 +738,7 @@ if(NOT enable-lgpl)
|
||||
add_subdirectory( lang )
|
||||
endif(enable-python OR enable-lua OR enable-octave)
|
||||
add_subdirectory( utils )
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- examples/CMakeLists.txt.orig 2017-07-20 06:27:54 UTC
|
||||
--- examples/CMakeLists.txt.orig 2018-03-22 07:29:50 UTC
|
||||
+++ examples/CMakeLists.txt
|
||||
@@ -1,7 +1,7 @@
|
||||
file(COPY ${CMAKE_SOURCE_DIR}/examples/iris.dat DESTINATION ${CMAKE_BINARY_DIR}/examples)
|
||||
file(COPY ${CMAKE_SOURCE_DIR}/examples/Equirectangular-projection.jpg DESTINATION ${CMAKE_BINARY_DIR}/examples)
|
||||
@@ -3,7 +3,7 @@ file(COPY ${CMAKE_SOURCE_DIR}/examples/E
|
||||
file(COPY ${CMAKE_SOURCE_DIR}/examples/samples.cpp DESTINATION ${CMAKE_BINARY_DIR}/examples)
|
||||
file(COPY ${CMAKE_SOURCE_DIR}/examples/wnd_samples.cpp DESTINATION ${CMAKE_BINARY_DIR}/examples)
|
||||
add_executable(mgl_example wnd_samples.cpp full_test.cpp samples.cpp)
|
||||
-target_link_libraries(mgl_example mgl-static ${getopt_lib-static})
|
||||
+#target_link_libraries(mgl_example mgl-static ${getopt_lib-static})
|
||||
|
||||
if(MGL_HAVE_FLTK)
|
||||
include_directories(${FLTK_INCLUDE_DIR})
|
||||
if(CMAKE_BUILD_TYPE STREQUAL "Debug" AND CMAKE_COMPILER_IS_GNUCXX AND enable-lcov)
|
||||
setup_target_for_coverage(
|
||||
NAME mgl_coverage
|
||||
|
@ -47,7 +47,10 @@ include/mgl2/vect.h
|
||||
include/mgl2/vectors.fs
|
||||
include/mgl2/volume.h
|
||||
include/mgl2/wnd.h
|
||||
lib/cmake/mathgl2/mathgl2-config.cmake
|
||||
lib/cmake/mathgl/MathGL2Config.cmake
|
||||
lib/cmake/mathgl/MathGL2ConfigVersion.cmake
|
||||
lib/cmake/mathgl/MathGLTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/mathgl/MathGLTargets.cmake
|
||||
lib/libmgl2-glut.so
|
||||
lib/libmgl2-glut.so.%%SHLIB_VER%%
|
||||
%%QT5%%lib/libmgl2-qt.so
|
||||
|
Loading…
Reference in New Issue
Block a user