parent
da66d11416
commit
3c5d9ab754
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50552
@ -8,6 +8,7 @@
|
||||
|
||||
PORTNAME= mx-experimental
|
||||
PORTVERSION= 0.6.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= http://www.lemburg.com/files/python/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -15,13 +16,17 @@ DISTNAME= egenix-${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${PYDISTUTILS}
|
||||
BUILD_DEPENDS= ${PYDISTUTILS} \
|
||||
${PREFIX}/include/gmp.h:${PORTSDIR}/math/libgmp3
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/BeeBase/BeeBase.py:${PORTSDIR}/lang/py-mx-base
|
||||
|
||||
USE_PYTHON= yes
|
||||
|
||||
SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s|LIBGMPH|${PREFIX}/include|" ${WRKSRC}/mxEXPERIMENTAL.py
|
||||
|
||||
do-build:
|
||||
@${SETUP_CMD} build
|
||||
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- mx/Number/mxNumber/mxNumber.h.orig Mon Nov 26 12:46:34 2001
|
||||
+++ mx/Number/mxNumber/mxNumber.h Mon Nov 26 12:46:43 2001
|
||||
@@ -30,7 +30,7 @@
|
||||
#endif
|
||||
|
||||
/* Include the GNU MP header file */
|
||||
-#include "gmp.h"
|
||||
+#include <gmp.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
19
devel/py-mx-experimental/files/patch-mxEXPERIMENTAL.py
Normal file
19
devel/py-mx-experimental/files/patch-mxEXPERIMENTAL.py
Normal file
@ -0,0 +1,19 @@
|
||||
--- mxEXPERIMENTAL.py.orig Mon Nov 26 12:44:48 2001
|
||||
+++ mxEXPERIMENTAL.py Mon Nov 26 12:45:52 2001
|
||||
@@ -140,7 +140,7 @@
|
||||
|
||||
mx_Extension('mx.Number.mxNumber.mxNumber',
|
||||
['mx/Number/mxNumber/mxNumber.c'],
|
||||
- include_dirs=['mx/Number/mxNumber']),
|
||||
+ include_dirs=['mx/Number/mxNumber', 'LIBGMPH']),
|
||||
|
||||
]
|
||||
else:
|
||||
@@ -160,7 +160,6 @@
|
||||
'mx/Number/README',
|
||||
'mx/Number/mxNumber/mxNumber.h',
|
||||
'mx/Number/mxNumber/mxh.h',
|
||||
- 'mx/Number/mxNumber/gmp.h',
|
||||
|
||||
# mxTidy
|
||||
'mx/Tidy/Doc/mxTidy.html',
|
Loading…
Reference in New Issue
Block a user