- Add games/wordwarvi
Word War vi is your basic side-scrolling shoot 'em up '80s style arcade game. You pilot your "vi"per craft through core memory, rescuing lost .swp files, avoiding OS defenses, and wiping out those memory hogging emacs processes. When all the lost .swp files are rescued, head for the socket which will take you to the next node in the cluster. WWW: http://smcameron.github.io/wordwarvi/
This commit is contained in:
parent
97a1da384a
commit
3c27985b55
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=423738
@ -1038,6 +1038,7 @@
|
||||
SUBDIR += wolfpack
|
||||
SUBDIR += wop
|
||||
SUBDIR += wordplay
|
||||
SUBDIR += wordwarvi
|
||||
SUBDIR += worldofpadman
|
||||
SUBDIR += wtf
|
||||
SUBDIR += wxlauncher
|
||||
|
43
games/wordwarvi/Makefile
Normal file
43
games/wordwarvi/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= wordwarvi
|
||||
PORTVERSION= 1.0.2
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Side-scrolling shoot'em up '80s style arcade game
|
||||
|
||||
LICENSE= GPLv2+ CC-BY-2.0 CC-BY-SA-3.0
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= smcameron
|
||||
|
||||
USES= gmake pkgconfig
|
||||
USE_GNOME= gtk20
|
||||
|
||||
PORTDOCS= AAA_HOW_TO_MAKE_NEW_LEVELS.txt AUTHORS README changelog.txt
|
||||
PORTDATA= *
|
||||
PLIST_FILES= bin/${PORTNAME} \
|
||||
man/man6/${PORTNAME}.6.gz
|
||||
|
||||
OPTIONS_DEFINE= SOUND DOCS
|
||||
OPTIONS_DEFAULT=SOUND
|
||||
|
||||
SOUND_LIB_DEPENDS= libportaudio.so:audio/portaudio \
|
||||
libvorbisfile.so:audio/libvorbis
|
||||
SOUND_MAKE_ARGS_OFF= WITHAUDIO=no
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
3
games/wordwarvi/distinfo
Normal file
3
games/wordwarvi/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1475776055
|
||||
SHA256 (smcameron-wordwarvi-v1.0.2_GH0.tar.gz) = 361d15af6edbe6db032db24de54e8f489a05b230572a8793b9889e2b8308a7ad
|
||||
SIZE (smcameron-wordwarvi-v1.0.2_GH0.tar.gz) = 8814650
|
43
games/wordwarvi/files/patch-Makefile
Normal file
43
games/wordwarvi/files/patch-Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
--- Makefile.orig 2016-03-11 15:16:11 UTC
|
||||
+++ Makefile
|
||||
@@ -1,6 +1,6 @@
|
||||
-PREFIX=/usr
|
||||
+PREFIX?=/usr
|
||||
DATADIR=${PREFIX}/share/wordwarvi
|
||||
-MANDIR?=${PREFIX}/share/man
|
||||
+MANDIR?=${PREFIX}/man
|
||||
MANPAGEDIR=${MANDIR}/man6
|
||||
|
||||
SCREENSAVERFLAG=
|
||||
@@ -45,7 +45,7 @@ OPENLASELIBDIR=
|
||||
endif
|
||||
|
||||
CC ?= gcc
|
||||
-BUILD_CC ?= gcc
|
||||
+BUILD_CC ?= ${CC}
|
||||
|
||||
# DEBUG=-g
|
||||
# DEBUG=
|
||||
@@ -54,7 +54,8 @@ BUILD_CC ?= gcc
|
||||
#OPTIMIZE_FLAG=
|
||||
# OPTIMIZE_FLAG=-O3
|
||||
#OPTIMIZE_FLAG=-O3 -pedantic -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security
|
||||
-CFLAGS ?= -O3 -pedantic
|
||||
+CFLAGS ?= -O3
|
||||
+CFLAGS += -pedantic
|
||||
OPTIMIZE_FLAG = ${CFLAGS} ${CPPFLAGS}
|
||||
WARNFLAG=-pedantic -W -Wall
|
||||
|
||||
@@ -116,10 +117,10 @@ wordwarvi.6.gz: wordwarvi.6
|
||||
gzip -c wordwarvi.6 > wordwarvi.6.gz
|
||||
|
||||
install: wordwarvi wordwarvi.6.gz
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/games
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
|
||||
mkdir -p $(DESTDIR)$(DATADIR)/sounds
|
||||
mkdir -p $(DESTDIR)$(MANPAGEDIR)
|
||||
- install -p -m 755 wordwarvi $(DESTDIR)$(PREFIX)/games
|
||||
+ install -p -m 755 wordwarvi $(DESTDIR)$(PREFIX)/bin
|
||||
install -p -m 644 sounds/*.ogg $(DESTDIR)$(DATADIR)/sounds
|
||||
install -p -m 644 wordwarvi.6.gz $(DESTDIR)$(MANPAGEDIR)
|
||||
|
17
games/wordwarvi/files/patch-wordwarvi.c
Normal file
17
games/wordwarvi/files/patch-wordwarvi.c
Normal file
@ -0,0 +1,17 @@
|
||||
--- wordwarvi.c.orig 2016-03-11 15:16:11 UTC
|
||||
+++ wordwarvi.c
|
||||
@@ -11559,12 +11559,14 @@ void start_level()
|
||||
srandom(level.random_seed);
|
||||
generate_terrain(&terrain);
|
||||
|
||||
+#if 0
|
||||
add_buildings(&terrain);/* Some FreeBSD users report that */
|
||||
/*add_buildings() causes crashes. */
|
||||
/* Commenting this out on FreeBSD */
|
||||
/* may help, but, no buildings. */
|
||||
/* I've looked at the code, but */
|
||||
/* don't see anything wrong with it. */
|
||||
+#endif
|
||||
add_humanoids(&terrain);
|
||||
add_bridges(&terrain);
|
||||
add_socket(&terrain);
|
8
games/wordwarvi/pkg-descr
Normal file
8
games/wordwarvi/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
Word War vi is your basic side-scrolling shoot 'em up '80s style
|
||||
arcade game. You pilot your "vi"per craft through core memory,
|
||||
rescuing lost .swp files, avoiding OS defenses, and wiping out those
|
||||
memory hogging emacs processes. When all the lost .swp files are
|
||||
rescued, head for the socket which will take you to the next node
|
||||
in the cluster.
|
||||
|
||||
WWW: http://smcameron.github.io/wordwarvi/
|
Loading…
Reference in New Issue
Block a user