update devel/mico: 2.3.10 --> 2.3.10_1

- install HTML documentation
  - add build options: WITH_X11, WITH_QT, TITH_GTK, WITH_TCL
  - fix PLIST and make it flexible and depended on build options
  - add WITH_GCC32 option to build with lang/gcc32 on -STABLE
  - add patches and rename old
  - many style fixes
  - change COMMENT to correspond to Mico current state
  - decrease pkg-descr to 24 lines

PR:		53988
Submitted by:	Sergey Matveychuk <sem@ciam.ru> (maintainer)
This commit is contained in:
Daichi GOTO 2003-07-02 13:02:29 +00:00
parent 95843c0031
commit 3c251ab3e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84045
11 changed files with 1103 additions and 589 deletions

View File

@ -7,63 +7,111 @@
PORTNAME= mico
PORTVERSION= 2.3.10
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.mico.org/
MAINTAINER= sem@ciam.ru
COMMENT= An Open Source CORBA 2.3 implementation
COMMENT= Fully compliant implementation of CORBA2.3 with some CORBA3.0 features
WRKSRC= ${WRKDIR}/mico
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
doc-html.tar.gz
WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_GMAKE= yes
CONIFUGRE_ARGS+= --enable-cd --disable-mini-stl \
--enable-ccm --enable-threads
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --enable-ssl=${OPENSSLBASE}
.if defined(WITH_GCC32)
USE_GCC= 3.2
.endif
CONFIGURE_ARGS+= --enable-cd --disable-mini-stl --enable-threads \
--enable-ccm
CONFIGURE_ENV+= CXXFLAGS=${CPPFLAGS}
.if defined(WITH_X11)
USE_XLIBS= yes
CONFIGURE_ARGS+= --with-x
.else
CONFIGURE_ARGS+= --without-x
MICO_X11= "@comment "
.endif
.if defined(WITH_QT)
USE_QT_VER= 3
CONFIGURE_ARGS+= --with-qt=${LOCALBASE}
QTCPPFLAGS+= ${CPPFLAGS}
.else
MICO_QT= "@comment "
.endif
.if defined(WITH_GTK)
USE_GNOME= gtk12
CONFIGURE_ARGS+= --with-gtk=${LOCALBASE}
.else
MICO_GTK= "@comment "
.endif
.if defined(WITH_TCL)
LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+= --with-tcl
CPPFLAGS+= -I${LOCALBASE}/include/tcl8.3
CONFIGURE_ENV+= CPPFLAGS=${CPPFLAGS}
.else
MICO_TCL= "@comment "
.endif
.include <bsd.port.pre.mk>
.if defined(WITHOUT_SSL)
MICO_SSL= "@comment "
.else
USE_OPENSSL= yes
CONFIGURE_ARGS+= --enable-ssl=${OPENSSLBASE} --enable-csiv2
# CORBASecV2 doesn't build with gcc32 port because FlexLexer.h absent
.if !( ${OSVERSION} < 500035 && defined(WITH_GCC32) )
CONFIGURE_ARGS+= --enable-csl2
.endif
.endif
PLIST_SUB+= MICO_X11=${MICO_X11} MICO_QT=${MICO_QT} MICO_GTK=${MICO_GTK} \
MICO_TCL=${MICO_TCL} MICO_SSL=${MICO_SSL}
MAN1= idl.1 imr.1 nsadmin.1
MAN5= micorc.5
MAN8= ird.8 micod.8 nsd.8
.include <bsd.port.pre.mk>
pre-fetch:
@${ECHO} "============================================================================"
.if ${OSVERSION} < 500035
@${ECHO} "Use WITH_GCC32=yes to build Mico with gcc 3.2 for better stability."
@${ECHO}
.endif
@${ECHO} "Following options are allowed:"
@${ECHO} "WITHOUT_SSL=yes, WITH_X11=yes, WITH_QT=yes, WITH_GTK=yes, WITH_TCL=yes"
@${ECHO} "============================================================================"
post-extract:
${TAR} xzf ${DISTDIR}/doc-html.tar.gz -C ${WRKDIR}
post-patch:
${REINPLACE_CMD} -e "s,so.1.0,so, ;s,-O2,${CFLAGS}," ${WRKSRC}/configure
${REINPLACE_CMD} -e "s#-O2#${CFLAGS}#" ${WRKSRC}/configure
post-configure:
${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
${REINPLACE_CMD} -e "s,/doc/,/share/doc/,"
${REINPLACE_CMD} -e "s,/doc/,/share/doc/," ${WRKSRC}/demo/MakeVars
${FIND} ${WRKSRC}/demo -name Makefile | ${XARGS} \
${REINPLACE_CMD} -e "s#/doc/mico/examples#/share/examples/mico#"
${REINPLACE_CMD} -e "s#/doc/mico/examples#/share/examples/mico#" ${WRKSRC}/demo/MakeVars
${REINPLACE_CMD} -e "s#ministl##" ${WRKSRC}/include/Makefile
${RM} ${WRKSRC}/include/mico/*.orig
post-install:
${LN} -sf ${PREFIX}/lib/libmico${PORTVERSION}.so.1 ${PREFIX}/lib/libmico.${PORTVERSION}.so
${LN} -sf ${PREFIX}/lib/libmicoaux${PORTVERSION}.so.1 ${PREFIX}/lib/libmicoaux.${PORTVERSION}.so
${LN} -sf ${PREFIX}/lib/libmicocoss${PORTVERSION}.so.1 ${PREFIX}/lib/libmicocoss.${PORTVERSION}.so
${LN} -sf ${PREFIX}/lib/libmicogtk${PORTVERSION}.so.1 ${PREFIX}/lib/libmicogtk.${PORTVERSION}.so
${LN} -sf ${PREFIX}/lib/libmicoqt${PORTVERSION}.so.1 ${PREFIX}/lib/libmicoqt.${PORTVERSION}.so
${LN} -sf ${PREFIX}/lib/libmicotcl${PORTVERSION}.so.1 ${PREFIX}/lib/libmicotcl.${PORTVERSION}.so
${LN} -sf ${PREFIX}/lib/libmicox${PORTVERSION}.so.1 ${PREFIX}/lib/libmicox.${PORTVERSION}.so
@${STRIP_CMD} ${PREFIX}/bin/containmentd
@${STRIP_CMD} ${PREFIX}/bin/eventd
@${STRIP_CMD} ${PREFIX}/bin/idl
@${STRIP_CMD} ${PREFIX}/bin/imr
@${STRIP_CMD} ${PREFIX}/bin/iordump
@${STRIP_CMD} ${PREFIX}/bin/ird
@${STRIP_CMD} ${PREFIX}/bin/mico-cpp
@${STRIP_CMD} ${PREFIX}/bin/micod
@${STRIP_CMD} ${PREFIX}/bin/noded
@${STRIP_CMD} ${PREFIX}/bin/nsadmin
@${STRIP_CMD} ${PREFIX}/bin/nsd
@${STRIP_CMD} ${PREFIX}/bin/propertyd
@${STRIP_CMD} ${PREFIX}/bin/proxyd
@${STRIP_CMD} ${PREFIX}/bin/randomd
@${STRIP_CMD} ${PREFIX}/bin/referenced
@${STRIP_CMD} ${PREFIX}/bin/timed
@${STRIP_CMD} ${PREFIX}/bin/traderd
@${STRIP_CMD} ${PREFIX}/bin/traversald
@for i in `${GREP} '^lib/lib.*so$$' ${TMPPLIST}`; do \
${LN} -fs ${PREFIX}/$$i ${PREFIX}/$$i.1; \
done; \
for i in `${GREP} ^bin/ ${TMPPLIST}`; do \
(${STRIP_CMD} ${PREFIX}/$$i || ${TRUE}) 2> /dev/null; \
done
.if !defined(NOPORTDOCS)
${GMAKE} -C ${WRKSRC} install-doc
${MKDIR} ${PREFIX}/share/doc/mico/html
${INSTALL_DATA} ${WRKDIR}/doc/doc/* ${PREFIX}/share/doc/mico/html
.endif
.include <bsd.port.post.mk>

View File

@ -1 +1,2 @@
MD5 (mico-2.3.10.tar.gz) = 0f27a8d66bc57100d762302cdf4868bf
MD5 (doc-html.tar.gz) = f32f618cfb2da541efd5dba50c3e2273

View File

@ -1,10 +0,0 @@
--- Makefile.orig Fri Dec 3 14:35:16 1999
+++ Makefile Fri Dec 3 14:36:14 1999
@@ -62,7 +62,6 @@
$(IDIRCMD) $(SHARED_INSTDIR)/doc/mico; \
$(IMANCMD) doc/doc.ps $(SHARED_INSTDIR)/doc/mico/manual.ps; \
fi
- -ldconfig
install-cd:
for i in $(INSTALLDIRS); do $(MAKE) -C $$i install-cd || exit 1; done

View File

@ -0,0 +1,11 @@
--- demo/Makefile.orig Mon Jun 30 05:51:13 2003
+++ demo/Makefile Mon Jun 30 05:51:23 2003
@@ -27,7 +27,7 @@
RUNDIRS = bench dynany interceptor codesets poa obv mcast generic pi
-INST_DIRS = $(DIRS) shlib ssl
+INST_DIRS = $(DIRS) shlib
ifeq ($(HAVE_DYNAMIC), yes)
DIRS := $(DIRS) shlib

View File

@ -0,0 +1,13 @@
--- tclmico.h.orig Mon May 26 14:55:46 2003
+++ include/mico/tclmico.h Sun Jun 29 02:25:42 2003
@@ -32,6 +32,10 @@
#include <tcl.h>
#endif
+using std::list;
+using std::set;
+using std::less;
+
class TclDispatcher : public CORBA::Dispatcher {
struct FileEvent {

View File

@ -0,0 +1,28 @@
--- Makefile.orig Fri Feb 14 13:55:53 2003
+++ Makefile Sun Jun 29 13:49:37 2003
@@ -27,7 +27,7 @@
PRGDIRS = orb ir cpp idl daemon auxdir coss ccm tools
EXTRADIRS = test demo
ALLDIRS = admin orb ir daemon idl cpp auxdir coss ccm test tools demo
-INSTALLDIRS = admin orb ir daemon idl cpp auxdir coss ccm tools include man demo
+INSTALLDIRS = admin orb ir daemon idl cpp auxdir coss ccm tools include man
# Bootstrap minimal build configuration
MINLIBDIRS = orb ir idl
MINPRGDIRS = cpp idl
@@ -68,11 +68,13 @@
install:
for i in $(INSTALLDIRS); do $(MAKE) -C $$i install || exit 1; done
+
+install-doc:
+ $(MAKE) -C demo install || exit 1;
if test -f doc/doc.ps; then \
- $(IDIRCMD) $(SHARED_INSTDIR)/doc/mico; \
- $(IMANCMD) doc/doc.ps $(SHARED_INSTDIR)/doc/mico/manual.ps; \
+ $(IDIRCMD) $(SHARED_INSTDIR)/share/doc/mico; \
+ $(IMANCMD) doc/doc.ps $(SHARED_INSTDIR)/share/doc/mico/manual.ps; \
fi
- -ldconfig
install-cd:
for i in $(INSTALLDIRS); do $(MAKE) -C $$i install-cd || exit 1; done

View File

@ -0,0 +1,43 @@
--- configure.orig Mon May 26 14:55:21 2003
+++ configure Sun Jun 29 05:48:32 2003
@@ -3130,7 +3130,7 @@
# System dependencies.
#
-CONF_OPT_FLAGS=-O2
+CONF_OPT_FLAGS="-O2"
CONF_DEBUG_FLAGS=-g
CONF_LIBNSL=yes
CONF_EXCEPT_FLAGS=
@@ -3155,7 +3155,7 @@
CFLAGS="-Wall $CFLAGS"
if test X"$use_speed_tune" = Xyes; then
- CONF_OPT_FLAGS=-O2
+ CONF_OPT_FLAGS="-O2"
fi
CONF_SHARED_CC="$CXX -shared"
@@ -3233,6 +3233,12 @@
CXXFLAGS="$CXXFLAGS -D_THREAD_SAFE"
fi
;;
+ *freebsd5*)
+ # must not use .so.1.0 here
+ if test X"$use_threads" = Xyes; then
+ CXXFLAGS="$CXXFLAGS -D_THREAD_SAFE"
+ fi
+ ;;
*netbsd*)
# must not use .so.1.0 here
if test X"$use_threads" = Xyes; then
@@ -4274,7 +4280,8 @@
rm -rf conftest*
if test X"$TCL_VERSION" != X; then
TCL_VERSION=`echo $TCL_VERSION | tr -d \"`
- TCL_LIBS=-ltcl$TCL_VERSION
+ TCL_LIBS="-ltcl$TCL_VERSION -L/usr/local/lib"
+ TCL_LIBS=`echo $TCL_LIBS | tr -d .`
HAVE_TCL=yes
echo "$ac_t""$TCL_VERSION" 1>&6
else

View File

@ -1,16 +1,13 @@
The acronym MICO expands to MICO Is CORBA. The intention of this project
is to provide a freely available and fully compliant implementation of
the latest CORBA standard.
the latest CORBA standard for C++ developers.
Here is some of MICO features:
* IDL to C++ mapping
* Multi-threaded
* Dynamic Invocation Interface (DII)
* Dynamic Skeleton Interface (DSI)
* graphical Interface Repository browser
* Interface Repository (IR)
* Dynamic Invocation Interface (DII) and Dynamic Skeleton Interface (DSI)
* Interface Repository (IR) with graphical Interface Repository browser
* IIOP as native protocol (ORB prepared for multiprotocol support)
* Portable Object Adapter (POA)
* Portable Object Adapter (POA) and Basic Object Adapter (BOA) support
* Objects by Value (OBV)
* CORBA Components (CCM)
* Dynamic Any
@ -19,8 +16,9 @@ Here is some of MICO features:
* Support for nested method invocations
* Any offers an interface for inserting and extracting constructed
types that were not known at compile time
* CORBA Services: o Interoperable Naming service, o Trading service,
o Event service, o Relationship service, o Property service,
o Time service, o Security service
* CORBA Services:
o Interoperable Naming service, o Trading service, o Event service,
o Relationship service, o Property service, o Time service,
o Security service
WWW: http://www.mico.org

File diff suppressed because it is too large Load Diff