databases/tora: use OPTIONS helpers
- Use OPTIONS helpers where possible. - Drop qt4-linguist dependency - the port does not use it (and it already contains prebuilt translations). - Regenerate patches. PR: 201724 Submitted by: s3erios@gmail.com
This commit is contained in:
parent
4960dcfa25
commit
3c25045697
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=394644
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= tora
|
||||
PORTVERSION= 2.1.3
|
||||
PORTREVISION= 9
|
||||
PORTREVISION= 10
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= SF
|
||||
@ -21,7 +21,7 @@ OPTIONS_DEFINE= PGSQL MYSQL DOCS
|
||||
OPTIONS_DEFINE_i386= ORACLE
|
||||
OPTIONS_DEFAULT= PGSQL MYSQL
|
||||
|
||||
USE_QT4= gui corelib sql xml network linguist moc_build uic_build rcc_build
|
||||
USE_QT4= corelib gui sql xml network moc_build uic_build rcc_build
|
||||
USES= autoreconf gmake libtool makeinfo
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-pcre=${LOCALBASE}
|
||||
@ -30,29 +30,20 @@ INSTALL_TARGET= install-strip
|
||||
|
||||
PREFIX2FIX= doc/help/preferences.texi doc/help/preferences.html
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
DOCS_USES= makeinfo
|
||||
DOCS_INFO= tora
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
USES+= makeinfo
|
||||
INFO= tora
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMYSQL}
|
||||
RUN_DEPENDS+= ${QT_PLUGINDIR}/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPGSQL}
|
||||
RUN_DEPENDS+= ${QT_PLUGINDIR}/sqldrivers/libqsqlpsql.so:${PORTSDIR}/databases/qt4-pgsql-plugin
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MORACLE}
|
||||
BUILD_DEPENDS+= ${ORACLE_HOME}/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
|
||||
RUN_DEPENDS+= ${ORACLE_HOME}/network/admin/tnsnames.ora:${PORTSDIR}/databases/oracle8-client
|
||||
MYSQL_RUN_DEPENDS= ${QT_PLUGINDIR}/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin
|
||||
PGSQL_RUN_DEPENDS= ${QT_PLUGINDIR}/sqldrivers/libqsqlpsql.so:${PORTSDIR}/databases/qt4-pgsql-plugin
|
||||
|
||||
ORACLE_HOME?= ${LOCALBASE}/oracle8-client
|
||||
ORACLE_VER= 8i # Client version
|
||||
CONFIGURE_ARGS+= --with-oracle=${ORACLE_HOME} --with-oci-version=${ORACLE_VER:tu}
|
||||
.endif
|
||||
|
||||
ORACLE_BUILD_DEPENDS= ${ORACLE_HOME}/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
|
||||
ORACLE_RUN_DEPENDS= ${ORACLE_HOME}/network/admin/tnsnames.ora:${PORTSDIR}/databases/oracle8-client
|
||||
ORACLE_CONFIGURE_ON= --with-oracle=${ORACLE_HOME} --with-oci-version=${ORACLE_VER:tu}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- config/m4/oracle.m4.orig 2008-05-14 19:07:34.000000000 +0200
|
||||
+++ config/m4/oracle.m4 2009-05-07 19:15:56.463399933 +0200
|
||||
@@ -113,6 +113,11 @@
|
||||
--- config/m4/oracle.m4.orig 2009-10-23 16:19:57 UTC
|
||||
+++ config/m4/oracle.m4
|
||||
@@ -113,6 +113,11 @@ Please install the instant client sdk pa
|
||||
ora_cflags="$ora_cflags -I$dir"
|
||||
echo "adding -I$dir" >&AS_MESSAGE_LOG_FD()
|
||||
fi
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig 2008-11-03 21:33:32.000000000 +0100
|
||||
+++ configure 2009-05-07 19:58:09.238375523 +0200
|
||||
@@ -25140,6 +25140,11 @@
|
||||
--- configure.orig 2010-09-19 17:15:52 UTC
|
||||
+++ configure
|
||||
@@ -17436,6 +17436,11 @@ Please install the instant client sdk pa
|
||||
ora_cflags="$ora_cflags -I$dir"
|
||||
echo "adding -I$dir" >&5
|
||||
fi
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.ac.orig 2008-09-14 23:54:41.000000000 +0200
|
||||
+++ configure.ac 2009-05-07 19:16:01.329388208 +0200
|
||||
@@ -54,6 +54,9 @@
|
||||
--- configure.ac.orig 2010-06-06 19:50:46 UTC
|
||||
+++ configure.ac
|
||||
@@ -57,6 +57,9 @@ TORA_CHECK_QSCINTILLA
|
||||
AX_PATH_LIB_PCRE
|
||||
AM_PATH_CPPUNIT([1.10.2], found_cppunit=yes)
|
||||
AM_CONDITIONAL([CPPUNIT], [test "x$found_cppunit" = "xyes"])
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- doc/Makefile.am.orig 2008-07-30 15:50:50.000000000 +0200
|
||||
+++ doc/Makefile.am 2009-05-10 18:04:15.478423171 +0200
|
||||
@@ -3,19 +3,20 @@
|
||||
--- doc/Makefile.am.orig 2009-10-23 16:19:55 UTC
|
||||
+++ doc/Makefile.am
|
||||
@@ -3,19 +3,20 @@ EXTRA_DIST = help
|
||||
dist-hook:
|
||||
rm -rf `find $(distdir) -name .svn`
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- doc/help/tora.texi.orig 2008-09-14 23:54:41.000000000 +0200
|
||||
+++ doc/help/tora.texi 2009-05-07 21:36:32.058998814 +0200
|
||||
--- doc/help/tora.texi.orig 2010-07-18 10:48:45 UTC
|
||||
+++ doc/help/tora.texi
|
||||
@@ -7,6 +7,10 @@
|
||||
@c @image{images/tora_manual}
|
||||
@c %**end of header
|
||||
@ -9,5 +9,5 @@
|
||||
+@end direntry
|
||||
+
|
||||
@copying
|
||||
This manual is for TOra, version 1.4.0.
|
||||
This manual is for TOra, version 2.1.3+.
|
||||
@end copying
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/Makefile.am.orig 2010-09-19 20:07:44.000000000 +0200
|
||||
+++ src/Makefile.am 2010-11-01 23:01:57.000000000 +0100
|
||||
@@ -37,7 +37,7 @@
|
||||
--- src/Makefile.am.orig 2010-09-19 18:07:44 UTC
|
||||
+++ src/Makefile.am
|
||||
@@ -37,7 +37,7 @@ AM_LDFLAGS = $(PCRE_LIBS) \
|
||||
# fix for annoying automake naming problems.
|
||||
tora_CXXFLAGS = $(AM_CXXFLAGS)
|
||||
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
if HAVE_ORACLE
|
||||
EXTRA_ORACLE_MONO_SOURCE = tooracleconnection.cpp tooraclesetting.h \
|
||||
@@ -439,6 +439,7 @@
|
||||
@@ -439,6 +439,7 @@ BUILT_SOURCES = \
|
||||
moc_tobrowserdblinkswidget.cpp \
|
||||
moc_tobrowserdirectorieswidget.cpp \
|
||||
moc_toresultgrants.cpp \
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/toextract.cpp.orig 2010-02-02 18:25:43.000000000 +0000
|
||||
--- src/toextract.cpp.orig 2010-02-02 18:25:43 UTC
|
||||
+++ src/toextract.cpp
|
||||
@@ -39,6 +39,7 @@
|
||||
*
|
||||
|
@ -1,16 +1,18 @@
|
||||
--- src/toextract.h 2010-02-02 13:25:43.000000000 -0500
|
||||
+++ src/toextract.h 2015-03-08 20:14:45.000000000 -0400
|
||||
@@ -783,5 +783,5 @@
|
||||
--- src/toextract.h.orig 2010-02-02 18:25:43 UTC
|
||||
+++ src/toextract.h
|
||||
@@ -782,13 +782,13 @@ public:
|
||||
}
|
||||
/** Implement sort order based only on Order field.
|
||||
*/
|
||||
- bool operator <(const columnInfo &inf)
|
||||
+ bool operator <(const columnInfo &inf) const
|
||||
{
|
||||
return Order < inf.Order;
|
||||
@@ -789,5 +789,5 @@
|
||||
}
|
||||
/** Implement sort order based only on Order field.
|
||||
*/
|
||||
- bool operator ==(const columnInfo &inf)
|
||||
+ bool operator ==(const columnInfo &inf) const
|
||||
{
|
||||
return Order == inf.Order;
|
||||
}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/tooracleconnection.cpp.orig 2008-10-29 16:59:11.000000000 +0100
|
||||
+++ src/tooracleconnection.cpp 2009-05-07 19:16:09.390371657 +0200
|
||||
@@ -57,7 +57,6 @@
|
||||
--- src/tooracleconnection.cpp.orig 2010-09-19 09:27:38 UTC
|
||||
+++ src/tooracleconnection.cpp
|
||||
@@ -58,7 +58,6 @@
|
||||
|
||||
#define OTL_STL
|
||||
#define OTL_EXCEPTION_ENABLE_ERROR_OFFSET
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- ./src/topiechart.h.orig 2009-10-23 18:19:33.000000000 +0200
|
||||
+++ ./src/topiechart.h 2014-07-21 19:25:58.000000000 +0200
|
||||
--- src/topiechart.h.orig 2009-10-23 16:19:33 UTC
|
||||
+++ src/topiechart.h
|
||||
@@ -44,6 +44,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/toreport.cpp.orig 2010-01-14 16:39:02.000000000 +0000
|
||||
--- src/toreport.cpp.orig 2010-01-14 16:39:02 UTC
|
||||
+++ src/toreport.cpp
|
||||
@@ -39,6 +39,7 @@
|
||||
*
|
||||
|
Loading…
Reference in New Issue
Block a user