astro/boinc-astropulse: catch astro/boinc-setiathome rename, fix -lexecinfo
astro/boinc-setiathome-v8 -> astro/boinc-setiathome per adamw - reroll local distfile to reflect real SVN revision - fix sah_config.h C++ errors
This commit is contained in:
parent
20d10694c1
commit
3be55871f7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=459014
1
MOVED
1
MOVED
@ -9848,3 +9848,4 @@ editors/vim-lite|editors/vim-console|2018-01-11|Renamed to reflect that it is co
|
||||
devel/py-repl|devel/py-pyrepl|2018-01-10|Rename to match pypi name
|
||||
devel/lua-bitop-51|devel/lua51-bitop|2018-01-14|Rename to lua51- prefix
|
||||
astro/boinc-setiathome-v7|astro/boinc-setiathome-v8|2018-01-14|Rename to v8 to reflect current version
|
||||
astro/boinc-setiathome-v8|astro/boinc-setiathome|2018-01-14|Rename to unversioned per adamw@
|
||||
|
@ -7,7 +7,7 @@
|
||||
SUBDIR += accrete
|
||||
SUBDIR += astrometry
|
||||
SUBDIR += boinc-astropulse
|
||||
SUBDIR += boinc-setiathome-v8
|
||||
SUBDIR += boinc-setiathome
|
||||
SUBDIR += celestia
|
||||
SUBDIR += celestia-gnome
|
||||
SUBDIR += celestia-gtk
|
||||
|
@ -15,7 +15,7 @@ LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3 \
|
||||
${NONEXISTENT}:astro/boinc-setiathome-v8:patch
|
||||
${NONEXISTENT}:astro/boinc-setiathome:patch
|
||||
RUN_DEPENDS= boinc_client:net/boinc-client
|
||||
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
|
||||
|
||||
@ -26,14 +26,14 @@ USES= autoreconf gmake libtool pkgconfig tar:xz
|
||||
WRKSRC_SUBDIR= client
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
LIBS+= -L${LOCALBASE}/lib -lexecinfo
|
||||
|
||||
# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
|
||||
BOINC_CLIENT_USER?= boinc
|
||||
BOINC_CLIENT_GROUP?= boinc
|
||||
BOINC_CLIENT_HOME?= /var/db/boinc
|
||||
|
||||
SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome-v8 && ${MAKE} -V WRKSRC
|
||||
SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome && ${MAKE} -V WRKSRC
|
||||
CONFIGURE_ENV= BOINCDIR="${NONEXISTENT}" \
|
||||
BOINC_DIR="${NONEXISTENT}" \
|
||||
SETI_BOINC_DIR="${SETI_WORK}"
|
||||
|
@ -1,3 +0,0 @@
|
||||
TIMESTAMP = 1515965298
|
||||
SHA256 (setiathome-svn-3725.tar.xz) = 78747ec516b122c681024d668a113e3bc72b2c0033b9de39c4933423f0821c57
|
||||
SIZE (setiathome-svn-3725.tar.xz) = 12548856
|
@ -3,9 +3,10 @@
|
||||
|
||||
PORTNAME= boinc-setiathome-v8
|
||||
PORTVERSION= 8.00
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= LOCAL/ler/setiathome
|
||||
DISTNAME= setiathome-svn-3725 # no releases available, snapshot
|
||||
DISTNAME= setiathome-svn-3727 # no releases available, snapshot
|
||||
|
||||
MAINTAINER= ler@FreeBSD.org
|
||||
COMMENT= Setiathome Enhanced for BOINC
|
3
astro/boinc-setiathome/distinfo
Normal file
3
astro/boinc-setiathome/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1515972172
|
||||
SHA256 (setiathome-svn-3727.tar.xz) = 81a49b8ca14286aa3822dcf47bf3fb82f679c0363e06c5e42b77f84056b671b0
|
||||
SIZE (setiathome-svn-3727.tar.xz) = 7234424
|
@ -1,4 +1,4 @@
|
||||
--- client/vector/hires_timer.cpp.orig 2018-01-14 21:26:29 UTC
|
||||
--- client/vector/hires_timer.cpp.orig 2018-01-14 23:02:12 UTC
|
||||
+++ client/vector/hires_timer.cpp
|
||||
@@ -267,7 +267,7 @@ hires_timer::hires_timer() : rollover(0),last_ticks(0)
|
||||
#endif
|
@ -1,4 +1,4 @@
|
||||
--- client/vector/sighandler.h.orig 2018-01-14 21:49:26 UTC
|
||||
--- client/vector/sighandler.h.orig 2018-01-14 23:02:12 UTC
|
||||
+++ client/vector/sighandler.h
|
||||
@@ -44,6 +44,7 @@
|
||||
#define SIGHANDLER_H
|
11
astro/boinc-setiathome/files/patch-sah__config.h
Normal file
11
astro/boinc-setiathome/files/patch-sah__config.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- sah_config.h.orig 2018-01-14 23:23:42 UTC
|
||||
+++ sah_config.h
|
||||
@@ -774,7 +774,7 @@
|
||||
#endif
|
||||
|
||||
#if !defined(CUSTOM_STRING) && defined(COMPILER_STRING)
|
||||
-#define CUSTOM_STRING PACKAGE_STRING" "SVN_REV" "COMPILER_STRING
|
||||
+#define CUSTOM_STRING PACKAGE_STRING" " SVN_REV" " COMPILER_STRING
|
||||
#endif
|
||||
|
||||
#include "std_fixes.h"
|
Loading…
Reference in New Issue
Block a user