MFH: r542025 r544404
Fix RUN_DEPENDS - Bump PORTREVISION for dependency change devel/py-importlib-metadata is not required for python 3.8+. Update to 1.2.0 Changes: https://github.com/matrix-org/python-canonicaljson/blob/master/CHANGES.md MFH: r542200 (partial) Update Python requirements for security/py-signedjson (avoid break bulk -a) PR: 249375 Approved by: ports-secteam (fluffy)
This commit is contained in:
parent
a2cc225b1d
commit
3bc9b74974
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q3/; revision=549855
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= canonicaljson
|
||||
PORTVERSION= 1.1.4
|
||||
PORTVERSION= 1.2.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -14,12 +14,12 @@ LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}frozendict>=1.0:devel/py-frozendict@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}simplejson>=3.6.5:devel/py-simplejson@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}simplejson>=3.6.5:devel/py-simplejson@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
USES= python:3.5+
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
do-test:
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1528219967
|
||||
SHA256 (canonicaljson-1.1.4.tar.gz) = 45bce530ff5fd0ca93703f71bfb66de740a894a3b5dd6122398c6d8f18539725
|
||||
SIZE (canonicaljson-1.1.4.tar.gz) = 9355
|
||||
TIMESTAMP = 1596280080
|
||||
SHA256 (canonicaljson-1.2.0.tar.gz) = 99793988a301401c696c432d6636b6d6ef6ba0472ec923e67ec19ab31991d1ea
|
||||
SIZE (canonicaljson-1.2.0.tar.gz) = 9983
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= signedjson
|
||||
PORTVERSION= 1.1.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -15,19 +16,24 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}canonicaljson>=1.0.0:devel/py-canonicaljson@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pynacl>=0.3.0:security/py-pynacl@${PY_FLAVOR} \
|
||||
${PY_TYPING} \
|
||||
${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.5:devel/py-typing-extensions@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}unpaddedbase64>=1.0.1:devel/py-unpaddedbase64@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USES= python:3.6+
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PYTHON_REL} < 3800
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
do-test:
|
||||
@(cd ${WRKSRC} && ${PYTHON_CMD} -m pytest tests)
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
13
security/py-signedjson/files/patch-setup.py
Normal file
13
security/py-signedjson/files/patch-setup.py
Normal file
@ -0,0 +1,13 @@
|
||||
Obtained from: https://github.com/matrix-org/python-signedjson/commit/c40c83f844fee3c1c7b0c5d1508f87052334b4e5
|
||||
|
||||
--- setup.py.orig 2020-03-27 19:41:34 UTC
|
||||
+++ setup.py
|
||||
@@ -41,7 +41,7 @@ setup(
|
||||
"pynacl>=0.3.0",
|
||||
"typing_extensions>=3.5",
|
||||
'typing>=3.5;python_version<"3.5"',
|
||||
- "importlib_metadata",
|
||||
+ 'importlib_metadata;python_version<"3.8"',
|
||||
],
|
||||
long_description=read_file(("README.rst",)),
|
||||
keywords="json",
|
16
security/py-signedjson/files/patch-signedjson-__init__.py
Normal file
16
security/py-signedjson/files/patch-signedjson-__init__.py
Normal file
@ -0,0 +1,16 @@
|
||||
Obtained from: https://github.com/matrix-org/python-signedjson/commit/c40c83f844fee3c1c7b0c5d1508f87052334b4e5
|
||||
|
||||
--- signedjson/__init__.py.orig 2020-03-27 19:41:34 UTC
|
||||
+++ signedjson/__init__.py
|
||||
@@ -12,7 +12,10 @@
|
||||
# See the License for the specific language governing permissions and
|
||||
# limitations under the License.
|
||||
|
||||
-from importlib_metadata import version, PackageNotFoundError
|
||||
+try:
|
||||
+ from importlib.metadata import version, PackageNotFoundError
|
||||
+except ImportError: # pragma: nocover
|
||||
+ from importlib_metadata import version, PackageNotFoundError
|
||||
|
||||
try:
|
||||
__version__ = version(__name__)
|
Loading…
Reference in New Issue
Block a user