- Add stage support
This commit is contained in:
parent
a330b821bb
commit
3bc0b4e271
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=333646
@ -10,10 +10,9 @@ MASTER_SITES= SF
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Simulation of water waves on the desktop
|
||||
|
||||
MAN1= xdesktopwaves.1
|
||||
USE_XORG= x11 xext
|
||||
|
||||
PLIST_FILES= bin/xdesktopwaves
|
||||
PLIST_FILES= bin/xdesktopwaves \
|
||||
man/man1/xdesktopwaves.1.gz
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.orig Sat Dec 18 13:47:40 2004
|
||||
+++ Makefile Wed Feb 23 22:28:56 2005
|
||||
--- ./Makefile.orig 2004-12-18 03:47:40.000000000 -0200
|
||||
+++ ./Makefile 2013-11-13 00:35:29.000000000 -0200
|
||||
@@ -11,19 +11,19 @@
|
||||
|
||||
#=========================== C compiler configuration ==========================
|
||||
@ -26,3 +26,14 @@
|
||||
INSTALL = install
|
||||
RM = rm -f -v
|
||||
|
||||
@@ -41,8 +41,8 @@
|
||||
$(RM) xdesktopwaves.o
|
||||
|
||||
install: xdesktopwaves xdesktopwaves.1
|
||||
- $(INSTALL) -c -m 0755 -s xdesktopwaves $(BINDIR)/xdesktopwaves
|
||||
- $(INSTALL) -c -m 0444 xdesktopwaves.1 $(MAN1DIR)/xdesktopwaves.1
|
||||
+ $(INSTALL) -c -m 0755 -s xdesktopwaves ${DESTDIR}$(BINDIR)/xdesktopwaves
|
||||
+ $(INSTALL) -c -m 0444 xdesktopwaves.1 ${DESTDIR}$(MAN1DIR)/xdesktopwaves.1
|
||||
|
||||
uninstall:
|
||||
$(RM) $(BINDIR)/xdesktopwaves
|
||||
|
Loading…
Reference in New Issue
Block a user