Update audio/sayonara to latest upstream release

Between 1.1.1 (previous version in ports) and this, the upstream
migrated to GitLab. Patches for the build have been submitted upstream.

The changelog is pretty long:
	https://sayonara-player.com/changelog.php

It is mostly "more importers, polish the library, .."
This commit is contained in:
Adriaan de Groot 2019-12-30 16:31:31 +00:00
parent a8a2ebda28
commit 3bbe64a965
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=521496
6 changed files with 41 additions and 28 deletions

View File

@ -2,12 +2,8 @@
# $FreeBSD$
PORTNAME= sayonara
DISTVERSIONPREFIX= player-
DISTVERSION= 1.1.1
PORTREVISION= 3
DISTVERSIONSUFFIX= -git1-20180828
DISTVERSION= 1.5.1
CATEGORIES= audio
MASTER_SITES= http://www.sayonara-player.com/sw/
MAINTAINER= adridg@FreeBSD.org
COMMENT= Small, clear, and fast Qt-based audio player
@ -25,12 +21,15 @@ USE_GSTREAMER1= flac libav mpg123 ogg opus vorbis
USE_QT= dbus core gui network sql sql-sqlite3_run widgets xml \
buildtools_build qmake_build linguisttools_build
WRKSRC= ${WRKDIR}/${PORTNAME}-player
USE_GITLAB= yes
GL_ACCOUNT= luciocarreras
GL_PROJECT= ${PORTNAME}-player
GL_COMMIT= 328203669eac9156db6f72356b47ebfbfee978ef # 1.5.1-stable5
post-patch:
@${REINPLACE_CMD} -e '/man1/s,share/,,' \
${WRKSRC}/resources/CMakeLists.txt
@${REINPLACE_CMD} -e '/DESTINATION/s,/usr/,,' \
${WRKSRC}/src/GUI/Resources/Icons/CMakeLists.txt
${WRKSRC}/src/Gui/Resources/Icons/CMakeLists.txt
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1535722215
SHA256 (sayonara-player-1.1.1-git1-20180828.tar.gz) = 76160668567e91b410c6018f18952ad8255c5b1180e726ff00376fb5f1217e67
SIZE (sayonara-player-1.1.1-git1-20180828.tar.gz) = 1759841
TIMESTAMP = 1577708177
SHA256 (luciocarreras-sayonara-player-328203669eac9156db6f72356b47ebfbfee978ef_GL0.tar.gz) = e94d7db9842786c10e5859c87d14658c3cc049c9291cd6476803a6bf73877a2e
SIZE (luciocarreras-sayonara-player-328203669eac9156db6f72356b47ebfbfee978ef_GL0.tar.gz) = 2034701

View File

@ -1,11 +1,11 @@
--- src/Components/Covers/LocalCoverSearcher.cpp.orig 2018-09-02 20:19:55 UTC
--- src/Components/Covers/LocalCoverSearcher.cpp.orig 2019-12-30 12:19:50 UTC
+++ src/Components/Covers/LocalCoverSearcher.cpp
@@ -68,7 +68,7 @@ QStringList LocalSearcher::cover_paths_f
@@ -75,7 +75,7 @@ QStringList LocalSearcher::cover_paths_from_path_hint(
continue;
}
- double d = std::abs(height - width) / (width * 1.0) + 1.0;
+ double d = std::abs(static_cast<double>(height - width)) / (width * 1.0) + 1.0;
double pixels = static_cast<double>(width * height);
double pixels = double(width * height);
d = (d * d * std::max(width, height)) / pixels;

View File

@ -0,0 +1,27 @@
--- src/Components/Streaming/LastFM/LastFM.cpp.orig 2019-12-30 14:17:48 UTC
+++ src/Components/Streaming/LastFM/LastFM.cpp
@@ -51,6 +51,7 @@
#include <QUrl>
#include <ctime>
+#include <random>
namespace Algorithm=Util::Algorithm;
@@ -320,14 +321,14 @@ void Base::similar_artists_fetched(IdList artist_ids)
const MetaDataList& v_md = active_playlist->tracks();
- std::random_shuffle(artist_ids.begin(), artist_ids.end());
+ std::shuffle(artist_ids.begin(), artist_ids.end(), std::default_random_engine());
for( auto it=artist_ids.begin(); it != artist_ids.end(); it++ )
{
MetaDataList artist_tracks;
lib_db->getAllTracksByArtist(IdList{*it}, artist_tracks);
- std::random_shuffle(artist_tracks.begin(), artist_tracks.end());
+ std::shuffle(artist_tracks.begin(), artist_tracks.end(), std::default_random_engine());
// try all songs of artist
for(int rounds=0; rounds < artist_tracks.count(); rounds++)

View File

@ -1,13 +0,0 @@
Fix build with Qt 5.11
--- src/GUI/InfoDialog/GUI_InfoDialog.h.orig 2018-08-31 09:31:17 UTC
+++ src/GUI/InfoDialog/GUI_InfoDialog.h
@@ -29,6 +29,8 @@
#include "Utils/MetaData/MetaDataFwd.h"
#include "Utils/Pimpl.h"
+#include <QTabBar>
+
class GUI_TagEdit;
class GUI_Lyrics;
class InfoDialogContainer;

View File

@ -1,6 +1,4 @@
bin/sayonara
lib/sayonara/libsayonara_somafm.so
lib/sayonara/libsayonara_soundcloud.so
man/man1/sayonara.1.gz
share/appdata/sayonara.appdata.xml
share/applications/sayonara.desktop
@ -42,6 +40,7 @@ share/pixmaps/sayonara.png
%%DATADIR%%/translations/icons/pt_PT.png
%%DATADIR%%/translations/icons/ro_RO.png
%%DATADIR%%/translations/icons/ru_RU.png
%%DATADIR%%/translations/icons/sk_SK.png
%%DATADIR%%/translations/icons/tr_TR.png
%%DATADIR%%/translations/icons/uk_UA.png
%%DATADIR%%/translations/icons/zh_CN.png
@ -61,6 +60,7 @@ share/pixmaps/sayonara.png
%%DATADIR%%/translations/sayonara_lang_pt_PT.qm
%%DATADIR%%/translations/sayonara_lang_ro_RO.qm
%%DATADIR%%/translations/sayonara_lang_ru_RU.qm
%%DATADIR%%/translations/sayonara_lang_sk_SK.qm
%%DATADIR%%/translations/sayonara_lang_tr_TR.qm
%%DATADIR%%/translations/sayonara_lang_uk_UA.qm
%%DATADIR%%/translations/sayonara_lang_zh_CN.qm