De-libxul yelp. Use a webkit based sourceball found in gentoo portage. Which

was made by the OpenSuse people. This allows gnome2 to be packaged again. I
planned to do this update after 9.1 was released but I completely forgot about
packages for the release [1].

While here update Makefile header, remove shlib versions and update CONFLICT
for the gnome3 version when that arrives.

Reminded by:    mandree@ [1]
Obtained from:  gnome stage area
Feature safe:	yes
This commit is contained in:
Koop Mast 2012-11-03 02:34:41 +00:00
parent 74ba9ea4d6
commit 3b72a367cf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=306896
4 changed files with 12 additions and 67 deletions

View File

@ -1,28 +1,25 @@
# New ports collection makefile for: yelp
# Date created: 18 May 2002
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/x11/yelp/Makefile,v 1.164 2010/10/18 13:37:34 kwm Exp $
#
# $MCom: ports/x11/yelp/Makefile,v 1.171 2012/10/01 16:19:07 kwm Exp $
PORTNAME= yelp
PORTVERSION= 2.30.2
PORTREVISION= 4
PORTREVISION= 6
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
MASTER_SITES= LOCAL/kwm
DISTNAME= ${PORTNAME}-webkit-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A help browser for the GNOME 2 desktop
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
rarian.0:${PORTSDIR}/textproc/rarian
LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
startup-notification-1:${PORTSDIR}/x11/startup-notification \
webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2 \
rarian:${PORTSDIR}/textproc/rarian
CONFLICTS= yelp-2.31.*
CONFLICTS= yelp-3.[0-9]*
USE_GECKO= libxul19
USE_GETTEXT= yes
USE_BZIP2= yes
USE_XORG= ice
@ -32,8 +29,6 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-gecko=${GECKO:S/19//} \
--with-gecko-home=${LOCALBASE}/lib/${GECKO:S/19//}
MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
GCONF_SCHEMAS= yelp.schemas

View File

@ -1,2 +1,2 @@
SHA256 (gnome2/yelp-2.30.2.tar.bz2) = 5f8c35847bdae654e21cbba66865d6b582d9fc80a059ad29081bb87e146bb165
SIZE (gnome2/yelp-2.30.2.tar.bz2) = 1159521
SHA256 (gnome2/yelp-webkit-2.30.2.tar.bz2) = 8c49dffecdc07dfe1e1b03f6ec3c32c523650802b6aebaf0b232aaa1af5e9f88
SIZE (gnome2/yelp-webkit-2.30.2.tar.bz2) = 1125815

View File

@ -1,13 +0,0 @@
--- src/yelp-gecko-utils.cpp.orig 2009-03-29 23:21:59.000000000 -0400
+++ src/yelp-gecko-utils.cpp 2009-03-29 23:25:48.000000000 -0400
@@ -28,8 +28,10 @@
#include <nsStringAPI.h>
#ifdef HAVE_GECKO_1_9
+#ifdef XPCOM_GLUE
#include <gtkmozembed_glue.cpp>
#endif
+#endif
#include <gtkmozembed.h>
#include <gtkmozembed_internal.h>

View File

@ -1,37 +0,0 @@
--- src/yelp-window.c.orig 2010-10-16 23:06:05.000000000 +0400
+++ src/yelp-window.c 2010-10-17 03:58:57.000000000 +0400
@@ -1555,28 +1555,26 @@
gtk_label_set_mnemonic_widget (GTK_LABEL (label), priv->find_entry);
- box = gtk_hbox_new (FALSE, 0);
arrow = gtk_arrow_new (GTK_ARROW_LEFT, GTK_SHADOW_NONE);
label = gtk_label_new_with_mnemonic (_("Find _Previous"));
- gtk_box_pack_start (GTK_BOX (box), arrow, FALSE, FALSE, 0);
- gtk_box_pack_start (GTK_BOX (box), label, TRUE, TRUE, 0);
- priv->find_prev = gtk_tool_button_new (box, NULL);
+ priv->find_prev = gtk_tool_button_new (arrow, NULL);
+ gtk_tool_button_set_label_widget (GTK_TOOL_BUTTON (priv->find_prev), label);
g_signal_connect (priv->find_prev,
"clicked",
G_CALLBACK (window_find_clicked_cb),
window);
+ gtk_tool_item_set_is_important (priv->find_prev, TRUE);
gtk_toolbar_insert (GTK_TOOLBAR (find_bar), priv->find_prev, -1);
- box = gtk_hbox_new (FALSE, 0);
arrow = gtk_arrow_new (GTK_ARROW_RIGHT, GTK_SHADOW_NONE);
label = gtk_label_new_with_mnemonic (_("Find _Next"));
- gtk_box_pack_start (GTK_BOX (box), arrow, FALSE, FALSE, 0);
- gtk_box_pack_start (GTK_BOX (box), label, TRUE, TRUE, 0);
- priv->find_next = gtk_tool_button_new (box, NULL);
+ priv->find_next = gtk_tool_button_new (arrow, NULL);
+ gtk_tool_button_set_label_widget (GTK_TOOL_BUTTON (priv->find_next), label);
g_signal_connect (priv->find_next,
"clicked",
G_CALLBACK (window_find_clicked_cb),
window);
+ gtk_tool_item_set_is_important (priv->find_next, TRUE);
gtk_toolbar_insert (GTK_TOOLBAR (find_bar), priv->find_next, -1);
priv->find_sep = gtk_separator_tool_item_new ();