Add support for amd64 (from ports/83001, modified).
PR: ports/83001 Submitted by: Rasmus Kaj <kaj(at)kth.se>
This commit is contained in:
parent
33396bffa2
commit
3b0a63a191
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=157823
@ -67,11 +67,14 @@ ERLANG_PLIST= ${WRKDIR}/pkg-plist
|
||||
USE_GMAKE= yes
|
||||
USE_PERL5= yes
|
||||
GNU_CONFIGURE= yes
|
||||
ONLY_FOR_ARCHS= i386
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
REINPLACE_ARGS= -i
|
||||
|
||||
CONFIGURE_TARGET= # Empty
|
||||
CONFIGURE_ARGS+= --enable-threads --enable-hipe --enable-kernel-poll
|
||||
CONFIGURE_ARGS+= --enable-threads --enable-kernel-poll
|
||||
.if ${ARCH} == "i386"
|
||||
CONFIGURE_ARGS+= --enable-hipe
|
||||
.endif
|
||||
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
|
24
lang/erlang/files/patch-erts_configure
Normal file
24
lang/erlang/files/patch-erts_configure
Normal file
@ -0,0 +1,24 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- erts/configure.orig
|
||||
+++ erts/configure
|
||||
@@ -1283,6 +1283,7 @@
|
||||
i586) ARCH=x86;;
|
||||
i686) ARCH=x86;;
|
||||
x86_64) ARCH=amd64;;
|
||||
+amd64) ARCH=amd64;;
|
||||
ppc) ARCH=ppc;;
|
||||
ppc64) ARCH=ppc64;;
|
||||
"Power Macintosh") ARCH=ppc;;
|
||||
@@ -5804,7 +5805,9 @@
|
||||
|
||||
echo $ac_n "checking for unreliable floating point execptions""... $ac_c" 1>&6
|
||||
echo "configure:5807: checking for unreliable floating point execptions" >&5
|
||||
-if test "$cross_compiling" = yes; then
|
||||
+if test "${ARCH}" = amd64; then
|
||||
+ erl_ok=reliable
|
||||
+elif test "$cross_compiling" = yes; then
|
||||
erl_ok=unreliable
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
@ -67,11 +67,14 @@ ERLANG_PLIST= ${WRKDIR}/pkg-plist
|
||||
USE_GMAKE= yes
|
||||
USE_PERL5= yes
|
||||
GNU_CONFIGURE= yes
|
||||
ONLY_FOR_ARCHS= i386
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
REINPLACE_ARGS= -i
|
||||
|
||||
CONFIGURE_TARGET= # Empty
|
||||
CONFIGURE_ARGS+= --enable-threads --enable-hipe --enable-kernel-poll
|
||||
CONFIGURE_ARGS+= --enable-threads --enable-kernel-poll
|
||||
.if ${ARCH} == "i386"
|
||||
CONFIGURE_ARGS+= --enable-hipe
|
||||
.endif
|
||||
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
|
24
lang/erlang14/files/patch-erts_configure
Normal file
24
lang/erlang14/files/patch-erts_configure
Normal file
@ -0,0 +1,24 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- erts/configure.orig
|
||||
+++ erts/configure
|
||||
@@ -1283,6 +1283,7 @@
|
||||
i586) ARCH=x86;;
|
||||
i686) ARCH=x86;;
|
||||
x86_64) ARCH=amd64;;
|
||||
+amd64) ARCH=amd64;;
|
||||
ppc) ARCH=ppc;;
|
||||
ppc64) ARCH=ppc64;;
|
||||
"Power Macintosh") ARCH=ppc;;
|
||||
@@ -5804,7 +5805,9 @@
|
||||
|
||||
echo $ac_n "checking for unreliable floating point execptions""... $ac_c" 1>&6
|
||||
echo "configure:5807: checking for unreliable floating point execptions" >&5
|
||||
-if test "$cross_compiling" = yes; then
|
||||
+if test "${ARCH}" = amd64; then
|
||||
+ erl_ok=reliable
|
||||
+elif test "$cross_compiling" = yes; then
|
||||
erl_ok=unreliable
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
Loading…
Reference in New Issue
Block a user