deskutils/py-vdirsyncer: Add compatibility with latest py-click.

- vdirsyncer was failing at runtime due to requering
  a outdated py-click version.

PR:		247191
Reported by:	Simeon Simeonov <sgs@pichove.org>
This commit is contained in:
Alexandre C. Guimarães 2020-06-26 17:34:05 +00:00
parent 6a0cc49100
commit 3aab7a6b1b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=540535
2 changed files with 40 additions and 0 deletions

View File

@ -2,6 +2,7 @@
PORTNAME= vdirsyncer
DISTVERSION= 0.16.8
PORTREVISION= 1
CATEGORIES= deskutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -0,0 +1,39 @@
From 3eb9ce5ae4320d52e6c876874511ff96a8a45f51 Mon Sep 17 00:00:00 2001
From: Hugo Osvaldo Barrera <hugo@barrera.io>
Date: Tue, 9 Jun 2020 14:45:02 +0200
Subject: [PATCH] Add compatibility with latest click
---
setup.py | 2 +-
tests/system/cli/test_sync.py | 5 ++++-
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/setup.py b/setup.py
index 59549f16..d584b95d 100644
--- setup.py
+++ setup.py
@@ -11,7 +11,7 @@
requirements = [
# https://github.com/mitsuhiko/click/issues/200
- 'click>=5.0,<6.0',
+ 'click>=5.0',
'click-log>=0.3.0, <0.4.0',
# https://github.com/pimutils/vdirsyncer/issues/478
diff --git a/tests/system/cli/test_sync.py b/tests/system/cli/test_sync.py
index f2423764..43d35dd8 100644
--- tests/system/cli/test_sync.py
+++ tests/system/cli/test_sync.py
@@ -123,7 +123,10 @@ def test_verbosity(tmpdir, runner):
runner.write_with_general('')
result = runner.invoke(['--verbosity=HAHA', 'sync'])
assert result.exception
- assert 'invalid value for "--verbosity"' in result.output.lower()
+ assert (
+ 'invalid value for "--verbosity"' in result.output.lower()
+ or "invalid value for '--verbosity'" in result.output.lower()
+ )
def test_collections_cache_invalidation(tmpdir, runner):