Add qico 0.45pl3.1, a fidonet compatible mailer. I've put a copy on my
local-distfiles due to historic saturation on www.ruxy.org.ru's link. PR: 16989 Submitted by: Denis Shaposhnikov <dsh@vlink.ru>
This commit is contained in:
parent
8e634aac21
commit
3a5dc9adff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31528
@ -15,6 +15,7 @@
|
||||
SUBDIR += mlan
|
||||
SUBDIR += mserver
|
||||
SUBDIR += plp
|
||||
SUBDIR += qico
|
||||
SUBDIR += qpage
|
||||
SUBDIR += seyon
|
||||
SUBDIR += snooper
|
||||
|
36
comms/qico/Makefile
Normal file
36
comms/qico/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# New ports collection makefile for: qico
|
||||
# Date created: 13 Jan 2000
|
||||
# Whom: Denis Shaposhnikov <dsh@vlink.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= qico
|
||||
PORTVERSION= 0.45.3.1
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL} \
|
||||
http://www.ruxy.org.ru/~aaz/files/
|
||||
MASTER_SITE_SUBDIR= will
|
||||
DISTNAME= ${PORTNAME}-0.45pl3.1
|
||||
|
||||
MAINTAINER= dsh@vlink.ru
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV+= SH=${SH} AWK=${AWK} DEFS="${DEFS}"
|
||||
|
||||
.if defined(WITH_AMIGA4D)
|
||||
DEFS+= -DAMIGA4D
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/qico.conf ${PREFIX}/etc/qico.conf.sample
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/qico ${PREFIX}/libexec
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/qcc ${PREFIX}/bin
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/qico
|
||||
${INSTALL_MAN} ${WRKSRC}/FAQ ${PREFIX}/share/doc/qico/FAQ.ru
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/qico/README.ru
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
comms/qico/distinfo
Normal file
1
comms/qico/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (qico-0.45pl3.1.tar.gz) = 9fd337654a53b6bd56733035c8fb101d
|
51
comms/qico/files/patch-aa
Normal file
51
comms/qico/files/patch-aa
Normal file
@ -0,0 +1,51 @@
|
||||
--- CONFIG.orig Sat Mar 18 10:12:29 2000
|
||||
+++ CONFIG Sat Mar 18 11:43:16 2000
|
||||
@@ -6,7 +6,7 @@
|
||||
BINDIR = /usr/local/bin
|
||||
|
||||
# default config (can be overridden with -I)
|
||||
-CONF = /etc/ftn/qico.conf
|
||||
+CONF = ${PREFIX}/etc/qico.conf
|
||||
# non-binary file permissions
|
||||
PERM = 00600
|
||||
|
||||
@@ -20,10 +20,9 @@
|
||||
|
||||
# qcc features (for building this you must have ncurses-4.2+)
|
||||
MORDA = 1
|
||||
-#DEFS += -DFREE_BSD
|
||||
|
||||
# lock dir
|
||||
-DEFS += -DLOCK_DIR=\"/var/lock\"
|
||||
+DEFS += -DLOCK_DIR=\"/var/spool/lock\"
|
||||
|
||||
# communication socket
|
||||
DEFS += -DQIPC_SOCKET=\"/tmp/qlog\"
|
||||
@@ -52,19 +51,19 @@
|
||||
### OS depended settings #####################################################
|
||||
##############################################################################
|
||||
|
||||
-SHELL = /bin/sh
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
-INSTALL = install
|
||||
-LEX = lex
|
||||
+SHELL ?= /bin/sh
|
||||
+CC ?= gcc
|
||||
+AWK ?= awk
|
||||
+INSTALL?= install
|
||||
+LEX ?= lex
|
||||
#YACC = bison -y
|
||||
-YACC = yacc
|
||||
+YACC ?= yacc
|
||||
|
||||
# required for linux glibc2 systems
|
||||
#LIBS=-lresolv
|
||||
|
||||
-# required for FreeBSD, if define -DFREE_BSD
|
||||
-#LIBS=-lutil
|
||||
+# required for FreeBSD
|
||||
+LIBS=-lutil
|
||||
|
||||
#
|
||||
# $Id: CONFIG,v 1.7 2000/01/28 15:53:38 aaz Exp $
|
11
comms/qico/files/patch-ab
Normal file
11
comms/qico/files/patch-ab
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.orig Sun Feb 6 10:47:47 2000
|
||||
+++ Makefile Sun Feb 6 11:01:10 2000
|
||||
@@ -5,8 +5,6 @@
|
||||
|
||||
DIRS = src
|
||||
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
INSTALL = install
|
||||
|
||||
DIST = qico-$(VERSION).tar.gz
|
20
comms/qico/files/patch-ac
Normal file
20
comms/qico/files/patch-ac
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/Makefile.orig Sat Mar 18 10:12:29 2000
|
||||
+++ src/Makefile Sat Mar 18 12:02:56 2000
|
||||
@@ -3,7 +3,7 @@
|
||||
#
|
||||
include ../CONFIG
|
||||
|
||||
-STRIP=0
|
||||
+STRIP=1
|
||||
#DEFS += -DEMSI_LOG # log emsi in /tmp/emsi.log
|
||||
#DEFS += -DH_DEBUG # Hydra
|
||||
#DEFS += -DZ_DEBUG # ZModem
|
||||
@@ -14,7 +14,7 @@
|
||||
#DEFS += -DY_DEBUG #-DYYERROR_VERBOSE=1 -DYYDEBUG=100
|
||||
|
||||
DEFS += -DSHELL=\"$(SHELL)\" -DCONFIG=\"$(CONF)\"
|
||||
-CFLAGS = $(DEFS) -Wall -m486 -O2 -D_GNU_SOURCE=1 -D_BSD_SOURCE=1
|
||||
+CFLAGS += $(DEFS)
|
||||
ifeq (1,$(STRIP))
|
||||
IFLAGS = -s
|
||||
else
|
1
comms/qico/pkg-comment
Normal file
1
comms/qico/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Qico is an FidoNet Technology Network (FTN) compatible mailer for Unix systems
|
15
comms/qico/pkg-descr
Normal file
15
comms/qico/pkg-descr
Normal file
@ -0,0 +1,15 @@
|
||||
Qico is an FidoNet Technology Network (FTN) compatible mailer for Unix systems.
|
||||
It has slightly different architecture than ifcico.
|
||||
|
||||
Features:
|
||||
|
||||
* Support for EMSI, ZModem, ZedZap, Hydra
|
||||
* Support for 4D Binkley-style, Amiga-style outbound, fileboxes
|
||||
* Daemon mode for outgoing calls
|
||||
* Substs with support for hidden-lines
|
||||
* Support for session time limit
|
||||
* Support for minimum connect speed limit
|
||||
|
||||
and so on.
|
||||
|
||||
WWW: http://www.ruxy.org.ru/~aaz
|
6
comms/qico/pkg-plist
Normal file
6
comms/qico/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
etc/qico.conf.sample
|
||||
libexec/qico
|
||||
bin/qcc
|
||||
share/doc/qico/FAQ.ru
|
||||
share/doc/qico/README.ru
|
||||
@dirrm share/doc/qico
|
36
comms/qicosi/Makefile
Normal file
36
comms/qicosi/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# New ports collection makefile for: qico
|
||||
# Date created: 13 Jan 2000
|
||||
# Whom: Denis Shaposhnikov <dsh@vlink.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= qico
|
||||
PORTVERSION= 0.45.3.1
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL} \
|
||||
http://www.ruxy.org.ru/~aaz/files/
|
||||
MASTER_SITE_SUBDIR= will
|
||||
DISTNAME= ${PORTNAME}-0.45pl3.1
|
||||
|
||||
MAINTAINER= dsh@vlink.ru
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV+= SH=${SH} AWK=${AWK} DEFS="${DEFS}"
|
||||
|
||||
.if defined(WITH_AMIGA4D)
|
||||
DEFS+= -DAMIGA4D
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/qico.conf ${PREFIX}/etc/qico.conf.sample
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/qico ${PREFIX}/libexec
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/qcc ${PREFIX}/bin
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/qico
|
||||
${INSTALL_MAN} ${WRKSRC}/FAQ ${PREFIX}/share/doc/qico/FAQ.ru
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/qico/README.ru
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
comms/qicosi/distinfo
Normal file
1
comms/qicosi/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (qico-0.45pl3.1.tar.gz) = 9fd337654a53b6bd56733035c8fb101d
|
51
comms/qicosi/files/patch-aa
Normal file
51
comms/qicosi/files/patch-aa
Normal file
@ -0,0 +1,51 @@
|
||||
--- CONFIG.orig Sat Mar 18 10:12:29 2000
|
||||
+++ CONFIG Sat Mar 18 11:43:16 2000
|
||||
@@ -6,7 +6,7 @@
|
||||
BINDIR = /usr/local/bin
|
||||
|
||||
# default config (can be overridden with -I)
|
||||
-CONF = /etc/ftn/qico.conf
|
||||
+CONF = ${PREFIX}/etc/qico.conf
|
||||
# non-binary file permissions
|
||||
PERM = 00600
|
||||
|
||||
@@ -20,10 +20,9 @@
|
||||
|
||||
# qcc features (for building this you must have ncurses-4.2+)
|
||||
MORDA = 1
|
||||
-#DEFS += -DFREE_BSD
|
||||
|
||||
# lock dir
|
||||
-DEFS += -DLOCK_DIR=\"/var/lock\"
|
||||
+DEFS += -DLOCK_DIR=\"/var/spool/lock\"
|
||||
|
||||
# communication socket
|
||||
DEFS += -DQIPC_SOCKET=\"/tmp/qlog\"
|
||||
@@ -52,19 +51,19 @@
|
||||
### OS depended settings #####################################################
|
||||
##############################################################################
|
||||
|
||||
-SHELL = /bin/sh
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
-INSTALL = install
|
||||
-LEX = lex
|
||||
+SHELL ?= /bin/sh
|
||||
+CC ?= gcc
|
||||
+AWK ?= awk
|
||||
+INSTALL?= install
|
||||
+LEX ?= lex
|
||||
#YACC = bison -y
|
||||
-YACC = yacc
|
||||
+YACC ?= yacc
|
||||
|
||||
# required for linux glibc2 systems
|
||||
#LIBS=-lresolv
|
||||
|
||||
-# required for FreeBSD, if define -DFREE_BSD
|
||||
-#LIBS=-lutil
|
||||
+# required for FreeBSD
|
||||
+LIBS=-lutil
|
||||
|
||||
#
|
||||
# $Id: CONFIG,v 1.7 2000/01/28 15:53:38 aaz Exp $
|
11
comms/qicosi/files/patch-ab
Normal file
11
comms/qicosi/files/patch-ab
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.orig Sun Feb 6 10:47:47 2000
|
||||
+++ Makefile Sun Feb 6 11:01:10 2000
|
||||
@@ -5,8 +5,6 @@
|
||||
|
||||
DIRS = src
|
||||
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
INSTALL = install
|
||||
|
||||
DIST = qico-$(VERSION).tar.gz
|
20
comms/qicosi/files/patch-ac
Normal file
20
comms/qicosi/files/patch-ac
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/Makefile.orig Sat Mar 18 10:12:29 2000
|
||||
+++ src/Makefile Sat Mar 18 12:02:56 2000
|
||||
@@ -3,7 +3,7 @@
|
||||
#
|
||||
include ../CONFIG
|
||||
|
||||
-STRIP=0
|
||||
+STRIP=1
|
||||
#DEFS += -DEMSI_LOG # log emsi in /tmp/emsi.log
|
||||
#DEFS += -DH_DEBUG # Hydra
|
||||
#DEFS += -DZ_DEBUG # ZModem
|
||||
@@ -14,7 +14,7 @@
|
||||
#DEFS += -DY_DEBUG #-DYYERROR_VERBOSE=1 -DYYDEBUG=100
|
||||
|
||||
DEFS += -DSHELL=\"$(SHELL)\" -DCONFIG=\"$(CONF)\"
|
||||
-CFLAGS = $(DEFS) -Wall -m486 -O2 -D_GNU_SOURCE=1 -D_BSD_SOURCE=1
|
||||
+CFLAGS += $(DEFS)
|
||||
ifeq (1,$(STRIP))
|
||||
IFLAGS = -s
|
||||
else
|
1
comms/qicosi/pkg-comment
Normal file
1
comms/qicosi/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Qico is an FidoNet Technology Network (FTN) compatible mailer for Unix systems
|
15
comms/qicosi/pkg-descr
Normal file
15
comms/qicosi/pkg-descr
Normal file
@ -0,0 +1,15 @@
|
||||
Qico is an FidoNet Technology Network (FTN) compatible mailer for Unix systems.
|
||||
It has slightly different architecture than ifcico.
|
||||
|
||||
Features:
|
||||
|
||||
* Support for EMSI, ZModem, ZedZap, Hydra
|
||||
* Support for 4D Binkley-style, Amiga-style outbound, fileboxes
|
||||
* Daemon mode for outgoing calls
|
||||
* Substs with support for hidden-lines
|
||||
* Support for session time limit
|
||||
* Support for minimum connect speed limit
|
||||
|
||||
and so on.
|
||||
|
||||
WWW: http://www.ruxy.org.ru/~aaz
|
6
comms/qicosi/pkg-plist
Normal file
6
comms/qicosi/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
etc/qico.conf.sample
|
||||
libexec/qico
|
||||
bin/qcc
|
||||
share/doc/qico/FAQ.ru
|
||||
share/doc/qico/README.ru
|
||||
@dirrm share/doc/qico
|
Loading…
Reference in New Issue
Block a user