- Update to 0.9.7-p1[1]

- Disable installing documentation due to incompatibility with doxygen[2]
- Enable support for PowerPC architectures[3]
- Fix port to not assume GCC for ${LD}[4]

PR:		ports/155937[2], ports/152890[3], ports/159193[4]
Submitted by:	Francisco de Borja Lopez Rio <borja@codigo23.net>[1] (via private email)
	  	Peter Jeremy <peterjeremy@acm.org>[2]
		Jason Bacon <jwbacon@tds.net>[3]
		Test Rat <ttsestt@gmail.com>[4]
This commit is contained in:
Ashish SHUKLA 2011-09-19 15:36:04 +00:00
parent 88d17ea820
commit 3a4b755440
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=281997
4 changed files with 29 additions and 6 deletions

View File

@ -6,10 +6,10 @@
#
PORTNAME= libvpx
PORTVERSION= 0.9.6
PORTVERSION= 0.9.7
CATEGORIES= multimedia
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}-v${PORTVERSION}
DISTNAME= ${PORTNAME}-v${PORTVERSION}-p1
MAINTAINER= ashish@FreeBSD.org
COMMENT= VP8 Codec SDK
@ -35,7 +35,7 @@ OPTIONS= DEBUG "Enable debugging" OFF \
SHARED "Enable shared-library support" ON
ALL_TARGET=
CONFIGURE_ARGS+= --enable-pic --disable-install-srcs --enable-vp8
CONFIGURE_ARGS+= --enable-pic --disable-install-srcs --enable-vp8 --disable-install-docs
MAKE_ARGS+= DIST_DIR=${PREFIX} verbose=yes
.include <bsd.port.options.mk>
@ -71,11 +71,17 @@ CONFIGURE_ARGS+= --target=x86_64-linux-gcc
CONFIGURE_ARGS+= --target=x86-linux-gcc
.elif ${ARCH} == "ia64"
CONFIGURE_ARGS+= --target=ia64-linux-gcc
.elif ${ARCH} == "powerpc"
CONFIGURE_ARGS+= --target=ppc32-linux-gcc
.elif ${ARCH} == "powerpc64"
CONFIGURE_ARGS+= --target=ppc64-linux-gcc
.else
IGNORE= no support for ${ARCH} the moment. testing/patches are welcome
.endif
post-patch:
@${REINPLACE_CMD} 's|\(link_with_cc\)=gcc|\1=$${CC}|' \
${WRKSRC}/build/make/configure.sh
@${GREP} -Rl '^#!/bin/bash' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
-e 's,#!/bin/bash,#!${LOCALBASE}/bin/bash,g'
.if ${OSVERSION} < 700000

View File

@ -1,2 +1,2 @@
SHA256 (libvpx-v0.9.6.tar.bz2) = 28bd8a8ef216fb570912f0d378668051d99681bf13735b59e68a12ad79f2aa73
SIZE (libvpx-v0.9.6.tar.bz2) = 1230418
SHA256 (libvpx-v0.9.7-p1.tar.bz2) = 074583d46955d406cf63c6a8d0d5b0a75c2b98128e6d425ab481f57612e291f0
SIZE (libvpx-v0.9.7-p1.tar.bz2) = 1244783

View File

@ -0,0 +1,16 @@
$FreeBSD$
--- libs.mk.orig
+++ libs.mk
@@ -242,8 +242,8 @@
$(qexec)echo 'Conflicts:' >> $@
$(qexec)echo 'Libs: -L$${libdir} -lvpx' >> $@
$(qexec)echo 'Cflags: -I$${includedir}' >> $@
-INSTALL-LIBS-yes += $(LIBSUBDIR)/pkgconfig/vpx.pc
-INSTALL_MAPS += $(LIBSUBDIR)/pkgconfig/%.pc %.pc
+INSTALL-LIBS-yes += libdata/pkgconfig/vpx.pc
+INSTALL_MAPS += libdata/pkgconfig/%.pc %.pc
CLEAN-OBJS += vpx.pc
endif

View File

@ -13,8 +13,9 @@ include/vpx/vpx_encoder.h
include/vpx/vpx_image.h
include/vpx/vpx_integer.h
lib/libvpx.a
libdata/pkgconfig/vpx.pc
%%SHARED%%lib/libvpx.so
%%SHARED%%lib/libvpx.so.0
%%SHARED%%lib/libvpx.so.0.9
%%SHARED%%lib/libvpx.so.0.9.6
%%SHARED%%lib/libvpx.so.0.9.7
@dirrm include/vpx