Fix build on 10-CURRENT

This commit is contained in:
Kevin Lo 2012-05-11 07:08:07 +00:00
parent eaa2d73408
commit 3a41b98fde
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296408
2 changed files with 16 additions and 1 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= fusefs
DISTVERSION= 0.3.9-pre1.20080208
PORTREVISION= 9
PORTREVISION= 10
CATEGORIES= sysutils kld
MASTER_SITES= http://mercurial.creo.hu/repos/fuse4bsd-hg/index.cgi/archive/
PKGNAMESUFFIX= -kmod
@ -62,6 +62,10 @@ OPTIONS= AUTOSETUP "Automatic global config file setup" off
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fuse_module__fuse_vnops.c
.endif
.if ${OSVERSION} >= 1000011
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-fuse_module__fuse_vnops.c
.endif
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires the Kernel source to be installed. Set SRC_BASE if it is not in /usr/src
.endif

View File

@ -0,0 +1,11 @@
--- fuse_module/fuse_vnops.c.orig 2012-05-11 14:59:59.000000000 +0800
+++ fuse_module/fuse_vnops.c 2012-05-11 15:00:05.000000000 +0800
@@ -663,7 +663,7 @@
if ((err = fuse_recyc_backend(vp, td)))
return err;
- vrecycle(vp, td);
+ vrecycle(vp);
return (0);
}