- update to 0.3
- replace patches with REINPLACE_CMD - switch to bzip2 distribution - move license to proper Makefile section Changelog: https://gitorious.org/nmapsi4/pages/Released PR: 163869 Submitted by: Veniamin Gvozdikov <g.veniamin at googlemail dot com> (maintainer)
This commit is contained in:
parent
6103f7e5b7
commit
3a20d5f24f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=288699
@ -6,23 +6,29 @@
|
||||
#
|
||||
|
||||
PORTNAME= nmapsi4
|
||||
PORTVERSION= 0.2.1
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= GOOGLE_CODE
|
||||
|
||||
MAINTAINER= g.veniamin@googlemail.com
|
||||
COMMENT= GUI frontend for the nmap scanning utility
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_BZIP2= yes
|
||||
INSTALLS_ICONS= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build network \
|
||||
linguist webkit
|
||||
|
||||
pre-configure:
|
||||
${REINPLACE_CMD} -e 's#share/applications/kde4/#share/applications/#g' \
|
||||
${WRKSRC}/${PORTNAME}/CMakeLists.txt \
|
||||
${WRKSRC}/${PORTNAME}-logr/CMakeLists.txt
|
||||
|
||||
post-install:
|
||||
${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}
|
||||
${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}-logr
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (nmapsi4-0.2.1.tar.gz) = 4e7589b920473c0efa3aee3e818bd491ff271664fd1695c549b38dbcb5251c2e
|
||||
SIZE (nmapsi4-0.2.1.tar.gz) = 300265
|
||||
SHA256 (nmapsi4-0.3.tar.bz2) = 51aa7e5e16577c318478b10ab3d533a15ea9e4d8cb7b7fb19a52e9b47f8b201d
|
||||
SIZE (nmapsi4-0.3.tar.bz2) = 3398283
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- nmapsi4-logr/CMakeLists.txt.orig 2009-12-29 14:35:41.000000000 +0700
|
||||
+++ nmapsi4-logr/CMakeLists.txt 2009-12-29 14:36:02.000000000 +0700
|
||||
@@ -67,7 +67,7 @@ endif (WIN32)
|
||||
if (Q_WS_X11)
|
||||
install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/nmapsi4/locale)
|
||||
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/nmapsi4-logr" DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
- install(FILES "src/nmapsi4-logr.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
|
||||
+ install(FILES "src/nmapsi4-logr.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/)
|
||||
# install(FILES "src/kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
|
||||
# install(FILES "icons/16x16/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps/)
|
||||
# install(FILES "icons/32x32/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/32x32/apps/)
|
@ -1,13 +0,0 @@
|
||||
--- nmapsi4/CMakeLists.txt.orig 2009-12-29 14:34:58.000000000 +0700
|
||||
+++ nmapsi4/CMakeLists.txt 2009-12-29 14:35:22.000000000 +0700
|
||||
@@ -106,8 +106,8 @@ endif (NOT WIN32)
|
||||
if (Q_WS_X11)
|
||||
install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/nmapsi4/locale)
|
||||
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/nmapsi4" DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
- install(FILES "kde/nmapsi4.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
|
||||
- install(FILES "kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
|
||||
+ install(FILES "kde/nmapsi4.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/)
|
||||
+ install(FILES "kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/)
|
||||
install(FILES "../icons/16x16/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps/)
|
||||
install(FILES "../icons/32x32/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/32x32/apps/)
|
||||
install(FILES "../icons/64x64/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/64x64/apps/)
|
@ -3,8 +3,8 @@ bin/nmapsi4-logr
|
||||
share/applications/nmapsi4-admin.desktop
|
||||
share/applications/nmapsi4-logr.desktop
|
||||
share/applications/nmapsi4.desktop
|
||||
share/dbus-1/interfaces/org.nmapsi4.Nmapsi4.xml
|
||||
share/icons/hicolor/128x128/apps/nmapsi4.png
|
||||
share/icons/hicolor/16x16/apps/nmapsi4.png
|
||||
share/icons/hicolor/32x32/apps/nmapsi4.png
|
||||
share/icons/hicolor/64x64/apps/nmapsi4.png
|
||||
%%DATADIR%%/locale/nmapsi4-logr_cs.qm
|
||||
@ -20,6 +20,7 @@ share/icons/hicolor/64x64/apps/nmapsi4.png
|
||||
%%DATADIR%%/locale/nmapsi4_it.qm
|
||||
%%DATADIR%%/locale/nmapsi4_pl.qm
|
||||
%%DATADIR%%/locale/nmapsi4_pt_BR.qm
|
||||
%%DATADIR%%/locale/nmapsi4_ru.qm
|
||||
@dirrm %%DATADIR%%/locale
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrmtry share/icons/hicolor/128x128/apps
|
||||
@ -29,7 +30,6 @@ share/icons/hicolor/64x64/apps/nmapsi4.png
|
||||
@dirrmtry share/icons/hicolor/32x32/apps
|
||||
@dirrmtry share/icons/hicolor/32x32
|
||||
@dirrmtry share/icons/hicolor/16x16/apps
|
||||
@dirrmtry share/icons/hicolor/16x16
|
||||
@dirrmtry share/icons/hicolor
|
||||
@dirrmtry share/icons
|
||||
@dirrmtry share/applications
|
||||
|
Loading…
Reference in New Issue
Block a user