Upgrade fldigi

=Version 3.23.03=

FSQ and fixes for FSQ bugs.
Various fixes for Olivia/Contestia, macro bug, WEFAX hang on INFO
Added ifkp modem
This commit is contained in:
Diane Bruce 2015-10-03 00:47:16 +00:00
parent a60a45deff
commit 39dd7c1d08
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=398456
18 changed files with 94 additions and 36 deletions

View File

@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= fldigi
PORTVERSION= 3.22.13
PORTVERSION= 3.23.03
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/downloads/fldigi/\
LOCAL/shurd
LOCAL/db
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Digital decoder for psk, cw, psk31, olivia
@ -54,15 +54,19 @@ HAMLIB_LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
BROKEN_sparc64= Fails to install
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
BROKEN= Fails to install
.endif
.if ${PORT_OPTIONS:MFLARQ}
MAN1+= flarq.1
.endif
PLIST_SUB+= XMLRPC=""
# Always need asciidoc for man pages
CONFIGURE_ARGS+=--with-asciidoc
post-patch:
@${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|' \
${WRKSRC}/src/widgets/picture.cxx
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/Makefile.in
@ -73,8 +77,10 @@ post-configure:
${RM} ${WRKSRC}/doc/*.1
post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/guide.html ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (fldigi-3.22.13.tar.gz) = f055b607dd28bde847541bd4518e5ceac49e0eccf4bda97c4c589d598c4a3baf
SIZE (fldigi-3.22.13.tar.gz) = 2909523
SHA256 (fldigi-3.23.03.tar.gz) = b308ceb0581e7668eedf83042baf6f9ae4af938648436cd1857655cad8fe978e
SIZE (fldigi-3.23.03.tar.gz) = 2951727

View File

@ -1,4 +1,4 @@
--- src/dialogs/fl_digi.cxx.orig 2015-04-23 11:39:24 UTC
--- src/dialogs/fl_digi.cxx.orig 2015-09-29 12:58:57 UTC
+++ src/dialogs/fl_digi.cxx
@@ -26,6 +26,7 @@
#include <config.h>

View File

@ -1,4 +1,4 @@
--- src/dominoex/dominoex.cxx.orig 2015-04-22 15:17:06 UTC
--- src/dominoex/dominoex.cxx.orig 2015-08-12 20:42:39 UTC
+++ src/dominoex/dominoex.cxx
@@ -63,7 +63,7 @@ void dominoex::tx_init(SoundBase *sc)

View File

@ -1,14 +1,49 @@
--- src/fsq/fsq.cxx.orig 2015-08-15 03:43:43 UTC
--- src/fsq/fsq.cxx.orig 2015-09-28 18:24:41 UTC
+++ src/fsq/fsq.cxx
@@ -1198,8 +1198,9 @@ int fsq::rx_process(const double *buf, i
@@ -1193,9 +1193,12 @@ int fsq::rx_process(const double *buf, i
&rx_stream[SHIFT_SIZE], // from
BLOCK_SIZE*sizeof(*rx_stream)); // # bytes
memset(fft_data, 0, sizeof(fft_data));
for (int i = 0; i < BLOCK_SIZE; i++)
- for (int i = 0; i < BLOCK_SIZE; i++)
- fft_data[i].real() = fft_data[i].imag() =
- rx_stream[i] * a_blackman[i];
+ fft_data[i] = complex <double>
+ (rx_stream[i] * a_blackman[i],
+ for (int i = 0; i < BLOCK_SIZE; i++) {
+ fft_data[i].real(
+ rx_stream[i] * a_blackman[i]);
+ fft_data[i].imag(
+ rx_stream[i] * a_blackman[i]);
+ }
fft->ComplexFFT(fft_data);
process_tones();
}
@@ -1423,7 +1426,7 @@ static string tx_text_queue = "";
static vector<string> commands;
#define NUMCOMMANDS 10
-static size_t next = 0;
+static size_t nexti = 0;
double fsq_xmtdelay() // in seconds
{
@@ -1440,9 +1443,9 @@ double fsq_xmtdelay() // in seconds
void fsq_repeat_last_command()
{
fsq_tx_text->clear();
- fsq_tx_text->addstr(sz2utf8(commands[next].c_str()));
- next++;
- if (next == commands.size()) next = 0;
+ fsq_tx_text->addstr(sz2utf8(commands[nexti].c_str()));
+ nexti++;
+ if (nexti == commands.size()) nexti = 0;
}
int get_fsq_tx_char(void)
@@ -1484,7 +1487,7 @@ void try_transmit(void *)
if (active_modem != fsq_modem) return;
if (!active_modem->fsq_squelch_open() && trx_state == STATE_RX) {
- next = 0;
+ nexti = 0;
fsq_que_clear();
//LOG_WARN("%s", "start_tx()");
start_tx();

View File

@ -0,0 +1,18 @@
--- src/ifkp/ifkp.cxx.orig 2015-10-02 23:20:08 UTC
+++ src/ifkp/ifkp.cxx
@@ -580,9 +580,12 @@ int ifkp::rx_process(const double *buf,
&rx_stream[IFKP_SHIFT_SIZE], // from
IFKP_BLOCK_SIZE*sizeof(*rx_stream)); // # bytes
memset(fft_data, 0, sizeof(fft_data));
- for (int i = 0; i < IFKP_BLOCK_SIZE; i++)
- fft_data[i].real() = fft_data[i].imag() =
- rx_stream[i] * a_blackman[i];
+ for (int i = 0; i < IFKP_BLOCK_SIZE; i++) {
+ fft_data[i].real(
+ rx_stream[i] * a_blackman[i]);
+ fft_data[i].imag(
+ rx_stream[i] * a_blackman[i]);
+ }
fft->ComplexFFT(fft_data);
process_tones();
}

View File

@ -1,4 +1,4 @@
--- src/include/data_io.h.orig 2015-04-18 13:26:19 UTC
--- src/include/data_io.h.orig 2015-08-12 20:42:40 UTC
+++ src/include/data_io.h
@@ -27,6 +27,8 @@
#ifndef fldigi_data_io_h

View File

@ -1,4 +1,4 @@
--- src/include/qrunner.h.orig 2015-03-21 00:29:03 UTC
--- src/include/qrunner.h.orig 2015-08-12 20:42:40 UTC
+++ src/include/qrunner.h
@@ -32,6 +32,7 @@
#include <cerrno>

View File

@ -1,11 +0,0 @@
--- src/logbook/lookupcall.cxx.orig 2015-04-23 11:39:24 UTC
+++ src/logbook/lookupcall.cxx
@@ -1188,7 +1188,7 @@ static void *EQSL_loop(void *args)
return NULL;
size_t p;
- if (fetch_http(EQSL_url, EQSL_xmlpage, 5.0) == -1)
+ if (fetch_http(EQSL_url, EQSL_xmlpage, 5.0) == false)
LOG_ERROR("%s", "eQSL not available");
else if ((p = EQSL_xmlpage.find("Error:")) != std::string::npos) {

View File

@ -1,4 +1,4 @@
--- src/misc/newinstall.cxx.orig 2015-03-21 00:29:03 UTC
--- src/misc/newinstall.cxx.orig 2015-08-12 20:42:32 UTC
+++ src/misc/newinstall.cxx
@@ -84,7 +84,7 @@ Age: \n\
Rig: \n\

View File

@ -1,4 +1,4 @@
--- src/qrunner/qrunner.cxx.orig 2015-03-21 00:29:04 UTC
--- src/qrunner/qrunner.cxx.orig 2015-08-12 20:42:38 UTC
+++ src/qrunner/qrunner.cxx
@@ -103,7 +103,7 @@ void qrunner::execute(int fd, void *arg)
return;

View File

@ -1,4 +1,4 @@
--- src/soundcard/sound.cxx.orig 2015-05-11 09:19:59 UTC
--- src/soundcard/sound.cxx.orig 2015-08-12 20:42:32 UTC
+++ src/soundcard/sound.cxx
@@ -689,7 +689,7 @@ size_t SoundOSS::Read(float *buffer, siz

View File

@ -1,4 +1,4 @@
--- src/spot/pskrep.cxx.orig 2015-03-21 00:29:04 UTC
--- src/spot/pskrep.cxx.orig 2015-09-15 14:09:37 UTC
+++ src/spot/pskrep.cxx
@@ -50,7 +50,7 @@
#include <algorithm>

View File

@ -1,4 +1,4 @@
--- src/thor/thor.cxx.orig 2015-04-22 15:17:06 UTC
--- src/thor/thor.cxx.orig 2015-09-30 11:23:49 UTC
+++ src/thor/thor.cxx
@@ -63,7 +63,7 @@ void thor::tx_init(SoundBase *sc)
videoText();

View File

@ -1,4 +1,4 @@
--- src/wefax/wefax.cxx.orig 2015-04-22 15:17:06 UTC
--- src/wefax/wefax.cxx.orig 2015-09-12 20:02:06 UTC
+++ src/wefax/wefax.cxx
@@ -556,7 +556,7 @@ private:
= wf->powerDensity(m_carrier - 2 * m_apt_start_freq, bandwidth_apt_start)

View File

@ -0,0 +1,10 @@
--- src/widgets/picture.cxx.orig 2015-09-12 20:02:06 UTC
+++ src/widgets/picture.cxx
@@ -40,6 +40,7 @@
#include <algorithm>
#include <time.h>
+#include <unistd.h>
#include <sys/stat.h>
#include <sys/types.h>

View File

@ -1,4 +1,4 @@
--- src/xmlrpcpp/XmlRpcBase64.h.orig 2015-04-23 11:39:24 UTC
--- src/xmlrpcpp/XmlRpcBase64.h.orig 2015-08-12 20:42:40 UTC
+++ src/xmlrpcpp/XmlRpcBase64.h
@@ -18,6 +18,7 @@
#if !defined(__BASE64_H_INCLUDED__)

View File

@ -13,4 +13,4 @@ WWV Receive only - calibrate your sound card to WWV and
Freq Analysis Receive only - be ready for the (next)
ARRL FMT (freq meas test).
WWW: http://www.w1hkj.com/Fldigi.html
WWW: http://www.w1hkj.com