Remove devel/pkg-config it has been replaced by devel/pkgconf

This commit is contained in:
Baptiste Daroussin 2012-07-26 06:21:51 +00:00
parent 04b1320746
commit 39cf5a337e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301542
9 changed files with 1 additions and 135 deletions

1
MOVED
View File

@ -3559,3 +3559,4 @@ mail/mutt-devel|mail/mutt|2012-07-22|mail/mutt-devel is ready for primetime
mail/mutt-devel-lite|mail/mutt-lite|2012-07-22|mail/mutt-devel is ready for primetime
deskutils/phpgroupware|www/phpgroupware|2012-07-23|Moved to proper category
textproc/fcitx-keyboard||2012-07-25|Removed, merged into chinese/fcitx
devel/pkg-config|devel/pkgconf|2012-07-26|pkg-config has been replace by pkgconf

View File

@ -1,37 +0,0 @@
# New ports collection makefile for: pkgconfig
# Date created: 30 April 2001
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
# $MCom: ports/devel/pkg-config/Makefile,v 1.12 2008/02/04 19:22:00 mezz Exp $
#
PORTNAME= pkg-config
PORTVERSION= 0.25
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://pkgconfig.freedesktop.org/releases/
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A utility to retrieve information about installed libraries
USE_CSTD= gnu89
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= pkg-config.1
.include <bsd.port.pre.mk>
PC_PATH=${PREFIX}/libdata/pkgconfig
PC_PATH:=${PC_PATH}:${PREFIX}/lib/pkgconfig
.if ${LOCALBASE} != ${PREFIX}
PC_PATH:= ${PC_PATH}:${LOCALBASE}/libdata/pkgconfig
PC_PATH:= ${PC_PATH}:${LOCALBASE}/lib/pkgconfig
.endif
CONFIGURE_ARGS= --disable-threads \
--with-pc-path="${PC_PATH}"
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (gnome2/pkg-config-0.25.tar.gz) = 3ba691ee2431f32ccb8efa131e59bf23e37f122dc66791309023ca6dcefcd10e
SIZE (gnome2/pkg-config-0.25.tar.gz) = 988899

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig 2010-05-28 11:55:55.000000000 -0400
+++ Makefile.in 2010-07-24 14:52:26.000000000 -0400
@@ -19,7 +19,7 @@
VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
+pkglibdir = $(prefix)/libdata/@PACKAGE@
pkglibexecdir = $(libexecdir)/@PACKAGE@
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
install_sh_DATA = $(install_sh) -c -m 644

View File

@ -1,10 +0,0 @@
--- glib-1.2.10/Makefile.in.orig Tue Apr 12 13:51:56 2005
+++ glib-1.2.10/Makefile.in Tue Apr 12 13:52:41 2005
@@ -727,7 +727,6 @@
installdirs-am:
install: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) install-recursive
install-exec: install-exec-recursive
install-data: install-data-recursive
uninstall: uninstall-recursive

View File

@ -1,48 +0,0 @@
--- parse.c.orig Sun Oct 16 13:09:39 2005
+++ parse.c Sat Sep 2 14:09:44 2006
@@ -707,6 +707,16 @@ static void _do_parse_libs (Package *pkg
i++;
g_free(framework);
}
+ else if ((strcmp("-Wl,--rpath",p) == 0 || strcmp("-Wl,-rpath",p) == 0) &&
+ i+1 < argc)
+ {
+ gchar *rpath = trim_string (argv[i+1]);
+
+ pkg->other_libs = g_slist_prepend (pkg->other_libs,
+ g_strconcat(arg, " ", rpath, NULL));
+ i++;
+ g_free(rpath);
+ }
else
{
if (*arg != '\0')
@@ -1190,9 +1200,9 @@ get_compat_package (const char *name)
{
char *output;
- debug_spew ("Calling glib-config\n");
+ debug_spew ("Calling glib12-config\n");
- pkg->version = backticks ("glib-config --version");
+ pkg->version = backticks ("glib12-config --version");
if (pkg->version == NULL)
{
g_free (pkg);
@@ -1203,12 +1213,12 @@ get_compat_package (const char *name)
pkg->key = g_strdup ("glib");
pkg->description = g_strdup ("C Utility Library");
- output = backticks ("glib-config --libs");
- parse_libs (pkg, output, "glib-config");
+ output = backticks ("glib12-config --libs");
+ parse_libs (pkg, output, "glib12-config");
g_free (output);
- output = backticks ("glib-config --cflags");
- parse_cflags (pkg, output, "glib-config");
+ output = backticks ("glib12-config --cflags");
+ parse_cflags (pkg, output, "glib12-config");
g_free (output);
return pkg;

View File

@ -1,7 +0,0 @@
--- pkg.m4.orig 2009-12-06 20:39:02.000000000 +0000
+++ pkg.m4 2010-08-25 16:59:38.000000000 +0000
@@ -137,3 +137,3 @@
-_PKG_TEXT])dnl
+_PKG_TEXT])[]dnl
])

View File

@ -1,14 +0,0 @@
The pkg-config program is used to retrieve information about installed
libraries in the system. It is typically used to compile and link against one
or more libraries. It's more useful to the compilation process than to
the end-user.
pkg-config retrieves information about packages from special metadata files.
These files are named after the package, with the extension .pc. By default,
pkg-config looks for these files in the following directories:
${PREFIX}/libdata/pkgconfig, ${PREFIX}/lib/pkgconfig,
${LOCALBASE}/libdata/pkgconfig, and ${LOCALBASE}/lib/pkgconfig; it will also
look in the list of directories specified by the PKG_CONFIG_PATH environment
variable.
WWW: http://pkgconfig.freedesktop.org/wiki/

View File

@ -1,6 +0,0 @@
bin/pkg-config
share/aclocal/pkg.m4
%%DOCSDIR%%/pkg-config-guide.html
@dirrm %%DOCSDIR%%
@dirrmtry lib/pkgconfig
@unexec rmdir %%LOCALBASE%%/lib/pkgconfig 2>/dev/null || true