- Fix build with gcc 3.4 [1]
- Fix build on amd64 Reported by: pointyhat via kris [1]
This commit is contained in:
parent
820e0a1724
commit
39b9a98c25
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116162
@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
|
||||
pre-configure:
|
||||
${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
11
graphics/kimagemapeditor/files/patch-kimagemapeditor.cpp
Normal file
11
graphics/kimagemapeditor/files/patch-kimagemapeditor.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/kimagemapeditor.cpp.orig Sat Aug 14 01:43:23 2004
|
||||
+++ src/kimagemapeditor.cpp Sat Aug 14 01:48:29 2004
|
||||
@@ -76,7 +76,7 @@
|
||||
|
||||
// Factory code for KDE 3
|
||||
typedef KParts::GenericFactory<KImageMapEditor> KimeFactory;
|
||||
-K_EXPORT_COMPONENT_FACTORY( libkimagemapeditor , KimeFactory );
|
||||
+K_EXPORT_COMPONENT_FACTORY( libkimagemapeditor , KimeFactory )
|
||||
|
||||
KImageMapEditor::KImageMapEditor(QWidget *parentWidget, const char *,
|
||||
QObject *parent, const char *name, const QStringList & )
|
11
graphics/kimagemapeditor/files/patch-kimearea.cpp
Normal file
11
graphics/kimagemapeditor/files/patch-kimearea.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/kimearea.cpp.orig Sat Aug 14 01:41:52 2004
|
||||
+++ src/kimearea.cpp Sat Aug 14 01:42:17 2004
|
||||
@@ -440,7 +440,7 @@
|
||||
}
|
||||
p.setRasterOp(Qt::XorROP);
|
||||
|
||||
-};
|
||||
+}
|
||||
|
||||
QRect* Area::onSelectionPoint(const QPoint & p, double zoom) const
|
||||
{
|
Loading…
Reference in New Issue
Block a user