accessibility/speech-dispatcher: use patch to replace static content
While here, improve formatting
This commit is contained in:
parent
16c0e6d272
commit
3996713ea4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=519156
@ -15,7 +15,7 @@ LIB_DEPENDS= libdotconf.so:devel/dotconf \
|
||||
libltdl.so:devel/libltdl \
|
||||
libsndfile.so:audio/libsndfile
|
||||
|
||||
USES= alias gettext gmake gnome pathfix pkgconfig libtool
|
||||
USES= alias gettext gmake gnome libtool pathfix pkgconfig
|
||||
USE_GNOME= glib20 intltool
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --without-espeak-ng
|
||||
@ -26,24 +26,23 @@ INSTALL_TARGET= install-strip
|
||||
|
||||
.if !defined(SPEECH_SLAVE)
|
||||
|
||||
CONFIGURE_ARGS+=--disable-python
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
|
||||
ETCFILES= clients/emacs.conf modules/pico-generic.conf \
|
||||
modules/cicero.conf modules/dtk-generic.conf \
|
||||
ETCFILES= clients/emacs.conf modules/cicero.conf modules/dtk-generic.conf \
|
||||
modules/epos-generic.conf modules/espeak-generic.conf \
|
||||
modules/espeak-mbrola-generic.conf modules/espeak.conf \
|
||||
modules/festival.conf modules/flite.conf modules/ibmtts.conf \
|
||||
modules/ivona.conf modules/llia_phon-generic.conf \
|
||||
modules/swift-generic.conf speechd.conf \
|
||||
modules/espeak-ng.conf
|
||||
modules/espeak-mbrola-generic.conf modules/espeak-ng.conf \
|
||||
modules/espeak.conf modules/festival.conf modules/flite.conf \
|
||||
modules/ibmtts.conf modules/ivona.conf \
|
||||
modules/llia_phon-generic.conf modules/pico-generic.conf \
|
||||
modules/swift-generic.conf speechd.conf
|
||||
|
||||
PORTDOCS= ANNOUNCE AUTHORS FAQ NEWS README TODO
|
||||
|
||||
INFO= spd-say speech-dispatcher speech-dispatcher-cs ssip
|
||||
|
||||
OPTIONS_DEFINE= ALSA AO DOCS ESPEAK FESTIVAL FLITE NAS PULSEAUDIO
|
||||
OPTIONS_DEFAULT=ESPEAK
|
||||
OPTIONS_SUB= yes
|
||||
OPTIONS_DEFINE= ALSA AO DOCS ESPEAK FESTIVAL FLITE NAS PULSEAUDIO
|
||||
OPTIONS_DEFAULT= ESPEAK
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
|
||||
ALSA_CONFIGURE_WITH= alsa
|
||||
@ -56,8 +55,8 @@ ESPEAK_LIB_DEPENDS= libespeak.so:audio/espeak
|
||||
ESPEAK_CONFIGURE_WITH= espeak
|
||||
|
||||
FESTIVAL_DESC= Festival Speech Synthesis System support
|
||||
FESTIVAL_RUN_DEPENDS= festival:audio/festival \
|
||||
${LOCALBASE}/share/festival/lib/${PORTNAME}.scm:audio/festival-freebsoft-utils
|
||||
FESTIVAL_RUN_DEPENDS= ${LOCALBASE}/share/festival/lib/${PORTNAME}.scm:audio/festival-freebsoft-utils \
|
||||
festival:audio/festival
|
||||
|
||||
FLITE_DESC= Flite speech synthesis engine support
|
||||
FLITE_LIB_DEPENDS= libflite.so:audio/flite
|
||||
@ -66,12 +65,10 @@ FLITE_CONFIGURE_WITH= flite
|
||||
NAS_LIB_DEPENDS= libaudio.so:audio/nas
|
||||
NAS_CONFIGURE_WITH= nas
|
||||
|
||||
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
|
||||
PULSEAUDIO_CONFIGURE_WITH=pulse
|
||||
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
|
||||
PULSEAUDIO_CONFIGURE_WITH= pulse
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/SUBDIRS/ s/tests//' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,g' \
|
||||
${WRKSRC}/src/modules/*.c \
|
||||
${WRKSRC}/config/modules/*.conf
|
||||
|
11
accessibility/speech-dispatcher/files/patch-src_Makefile.in
Normal file
11
accessibility/speech-dispatcher/files/patch-src_Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/Makefile.in.orig 2019-12-06 16:28:36 UTC
|
||||
+++ src/Makefile.in
|
||||
@@ -382,7 +382,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-SUBDIRS = common server audio modules api clients tests
|
||||
+SUBDIRS = common server audio modules api clients
|
||||
all: all-recursive
|
||||
|
||||
.SUFFIXES:
|
Loading…
Reference in New Issue
Block a user