audio/denemo: update to 1.0.8
- Update to 1.0.8 [1] - Allow staging [1] - Convert lib depends to new format PR: ports/181881 [1] Submitted by: KATO Tsuguru <tkato432 yahoo.com>
This commit is contained in:
parent
d18af3af6b
commit
398cb808fc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=331574
@ -2,23 +2,24 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= denemo
|
||||
PORTVERSION= 1.0.4
|
||||
PORTVERSION= 1.0.8
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= GNU
|
||||
|
||||
MAINTAINER= multimedia@FreeBSD.org
|
||||
COMMENT= Graphical score editor
|
||||
|
||||
BUILD_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
|
||||
LIB_DEPENDS= aubio:${PORTSDIR}/audio/aubio \
|
||||
fluidsynth:${PORTSDIR}/audio/fluidsynth \
|
||||
jack:${PORTSDIR}/audio/jack \
|
||||
smf:${PORTSDIR}/audio/libsmf \
|
||||
sndfile:${PORTSDIR}/audio/libsndfile \
|
||||
evview:${PORTSDIR}/graphics/evince \
|
||||
guile:${PORTSDIR}/lang/guile \
|
||||
fftw3:${PORTSDIR}/math/fftw3
|
||||
RUN_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2 \
|
||||
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/portaudio-2.0.pc:${PORTSDIR}/audio/portaudio2
|
||||
LIB_DEPENDS= libaubio.so:${PORTSDIR}/audio/aubio \
|
||||
libfluidsynth.so:${PORTSDIR}/audio/fluidsynth \
|
||||
libjack.so:${PORTSDIR}/audio/jack \
|
||||
libsmf.so:${PORTSDIR}/audio/libsmf \
|
||||
libsndfile.so:${PORTSDIR}/audio/libsndfile \
|
||||
librubberband.so:${PORTSDIR}/audio/rubberband \
|
||||
libevview.so:${PORTSDIR}/graphics/evince \
|
||||
libguile.so:${PORTSDIR}/lang/guile \
|
||||
libfftw3.so:${PORTSDIR}/math/fftw3
|
||||
RUN_DEPENDS= portaudio2>=0:${PORTSDIR}/audio/portaudio2 \
|
||||
xdg-open:${PORTSDIR}/devel/xdg-utils
|
||||
|
||||
LICENSE= GPLv3
|
||||
@ -28,7 +29,6 @@ LILYPOND_DESC= Install LilyPond (Printing)
|
||||
|
||||
USE_GNOME= gtk20 gtksourceview2 librsvg2 libxml2
|
||||
USES= bison gmake pkgconfig
|
||||
NO_STAGE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-gtk2 \
|
||||
--enable-jack \
|
||||
@ -53,35 +53,36 @@ post-patch:
|
||||
/) install-data-hook/s|^|#|' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|"firefox"|"xdg-open"|' ${WRKSRC}/src/prefops.c
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/get_playback_speed/s|^volatile ||' ${WRKSRC}/src/audiointerface.h
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${DATADIR}
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
.for i in actions templates
|
||||
@(cd ${WRKSRC} && ${TAR} --exclude "*Makefile*" -cf - ${i}) | \
|
||||
(cd ${DATADIR} && ${TAR} --unlink -xf -)
|
||||
@${FIND} ${DATADIR}/${i} -print0 | \
|
||||
(cd ${STAGEDIR}${DATADIR} && ${TAR} --unlink -xf -)
|
||||
@${FIND} ${STAGEDIR}${DATADIR}/${i} -print0 | \
|
||||
${XARGS} -0 ${CHOWN} ${SHAREOWN}:${SHAREGRP}
|
||||
@${FIND} ${DATADIR}/${i} -type d -print0 | \
|
||||
@${FIND} ${STAGEDIR}${DATADIR}/${i} -type d -print0 | \
|
||||
${XARGS} -0 ${CHMOD} a+rx
|
||||
@${FIND} ${DATADIR}/${i} -type f -print0 | \
|
||||
@${FIND} ${STAGEDIR}${DATADIR}/${i} -type f -print0 | \
|
||||
${XARGS} -0 ${CHMOD} ${SHAREMODE}
|
||||
.endfor
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for i in AUTHORS ChangeLog NEWS README
|
||||
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
|
||||
.endfor
|
||||
.for i in DESIGN DESIGN.lilypond GOALS TODO
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
|
||||
(cd ${WRKSRC}/doc && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
|
||||
.endfor
|
||||
@${MKDIR} ${DOCSDIR}/manual
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/manual
|
||||
@${MKDIR} ${DOCSDIR}/manual/images
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/images/*.png ${DOCSDIR}/manual/images
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/*.denemo ${EXAMPLESDIR}
|
||||
.endif
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/manual
|
||||
(cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html \
|
||||
${STAGEDIR}${DOCSDIR}/manual)
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/manual/images
|
||||
(cd ${WRKSRC}/doc/images && ${INSTALL_DATA} *.png \
|
||||
${STAGEDIR}${DOCSDIR}/manual/images)
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
(cd ${WRKSRC}/examples && ${INSTALL_DATA} *.denemo \
|
||||
${STAGEDIR}${EXAMPLESDIR})
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (denemo-1.0.4.tar.gz) = 1f2bda76e05bac6db231681a36dd6a5a1110c42bedf45291ff51d709d15eb258
|
||||
SIZE (denemo-1.0.4.tar.gz) = 13479760
|
||||
SHA256 (denemo-1.0.8.tar.gz) = b7e80cbe4809892b13dc1653d040ce5d3e7905a9395abdb157125244a403cbc4
|
||||
SIZE (denemo-1.0.8.tar.gz) = 13398074
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- src/file.c.orig
|
||||
+++ src/file.c
|
||||
@@ -571,7 +571,7 @@
|
||||
@@ -569,7 +569,7 @@
|
||||
{
|
||||
if (system_example_path == NULL)
|
||||
{
|
||||
- system_example_path = g_build_filename (get_data_dir (), "examples", NULL);
|
||||
+ system_example_path = g_build_filename (get_data_dir (), "..", "examples", NULL);
|
||||
- system_example_path = g_build_filename (get_system_data_dir (), "examples", NULL);
|
||||
+ system_example_path = g_build_filename (get_system_data_dir (), "..", "examples", "denemo", NULL);
|
||||
GDir *denemo_path = g_dir_open (system_example_path, 0, NULL);
|
||||
if (denemo_path == NULL)
|
||||
{
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- src/help.c.orig
|
||||
+++ src/help.c
|
||||
@@ -63,7 +63,7 @@
|
||||
@@ -56,7 +56,7 @@
|
||||
GError *error = NULL;
|
||||
|
||||
/* get the uri to the manual */
|
||||
- gchar *manualpath = g_build_filename (get_data_dir (), "manual",
|
||||
+ gchar *manualpath = g_build_filename (get_data_dir (), "..", "doc", "denemo", "manual",
|
||||
- gchar *manualpath = g_build_filename (get_system_data_dir (), "manual",
|
||||
+ gchar *manualpath = g_build_filename (get_system_data_dir (), "..", "doc", "denemo", "manual",
|
||||
"denemo-manual.html", NULL);
|
||||
gchar *manualuri = url?g_strdup(url):g_filename_to_uri (manualpath, NULL, NULL);
|
||||
gchar *manualuri = url ? g_strdup (url) : g_filename_to_uri (manualpath, NULL, NULL);
|
||||
|
||||
|
11
audio/denemo/files/patch-src__importmusicxml.c
Normal file
11
audio/denemo/files/patch-src__importmusicxml.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/importmusicxml.c.orig
|
||||
+++ src/importmusicxml.c
|
||||
@@ -392,7 +392,7 @@
|
||||
duration -= divisions/32;
|
||||
return get_rest_for_duration(ret, duration, divisions);
|
||||
} else if (duration==0)
|
||||
- return;
|
||||
+ return -1;
|
||||
|
||||
g_string_append(ret, "\n;Duration of rest not recognized\n");
|
||||
}
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user