graphics/kphotoalbum: prepare for exiv2-0.27

Import gentoo's patch from:
https://gitweb.gentoo.org/repo/gentoo.git/tree/media-gfx/kphotoalbum/files/kphotoalbum-5.4-exiv2-0.27.patch?id=8487b360db9fcf049fe9a5543469b8e6fee28e4d

PR:		235943
This commit is contained in:
Tobias C. Berner 2019-03-08 22:15:23 +00:00
parent 0063345510
commit 394336f668
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495082
2 changed files with 63 additions and 0 deletions

View File

@ -2,6 +2,7 @@
PORTNAME= kphotoalbum
DISTVERSION= 5.4.2
PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/
DIST_SUBDIR= KDE

View File

@ -0,0 +1,62 @@
From 41c7da0531c8a1eb7046345c2b991e7a5d1e6657 Mon Sep 17 00:00:00 2001
From: Johannes Zarl-Zierl <johannes@zarl-zierl.at>
Date: Sun, 30 Dec 2018 23:36:24 +0100
Subject: Use Exiv2 0.27 if available.
Beginning with version 0.27, Exiv2 ships with cmake package config
files.
---
CMakeLists.txt | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3012f7a..5dcc29c 100644
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -44,7 +44,17 @@ if(JPEG_FOUND)
include_directories(${JPEG_INCLUDE_DIR})
endif()
-find_package(Exiv2 REQUIRED)
+### 2018-12-30 jzarl
+# When Exiv2 0.26 can be deprecated, FindExiv2.cmake should be removed
+# and only find_package(exiv2) should be used
+find_package(exiv2 CONFIG QUIET)
+if(exiv2_FOUND)
+ # search againg with REQUIRED, so that the feature summary correctly shows exiv as required dependency
+ find_package(exiv2 CONFIG REQUIRED)
+ set(EXIV2_LIBRARIES exiv2lib)
+else()
+ find_package(Exiv2 REQUIRED)
+endif()
find_package(KF5Kipi 5.1.0)
set_package_properties(KF5Kipi
--
cgit v1.1
From cf4f7645b3c94246a1fcf664f1c865a93ae2b684 Mon Sep 17 00:00:00 2001
From: Johannes Zarl-Zierl <johannes@zarl-zierl.at>
Date: Sun, 30 Dec 2018 23:43:14 +0100
Subject: Fix compilation with exiv2 0.27
---
Exif/Info.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Exif/Info.cpp b/Exif/Info.cpp
index be4c88f..9545360 100644
--- Exif/Info.cpp
+++ Exif/Info.cpp
@@ -28,7 +28,8 @@
#include <QFile>
#include <exiv2/image.hpp>
-#include <exiv2/exif.hpp>
+#include <exiv2/exv_conf.h>
+#include <exiv2/version.hpp>
using namespace Exif;
--
cgit v1.1