- Update to 0.7.4b

PR:		ports/177589
Submitted by:	Kaspars Bankovskis <kaspars@bankovskis.lv> (maintainer)
This commit is contained in:
Guido Falsi 2013-09-01 00:10:16 +00:00
parent c97fef8a33
commit 39398c2846
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=325837
8 changed files with 100 additions and 63 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vifm
PORTVERSION= 0.6.3
PORTVERSION= 0.7.4b
CATEGORIES= misc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@ -12,40 +12,21 @@ COMMENT= Ncurses based file manager with vi like keybindings
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= VIFM_SCREEN
VIFM_SCREEN_DESC= Use vifm with the screen program
USES= ncurses
USES= gmake ncurses
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --without-gtk
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
AUTOMAKE="${TRUE}"
MAN1= vifm.1
MAN1= vifm.1 \
vifm-pause.1 \
vifmrc-converter.1
PLIST_FILES= bin/vifm \
bin/vifmrc-converter \
bin/vifm-pause \
%%DATADIR%%/startup \
%%DATADIR%%/vifm-help.txt \
%%DATADIR%%/vifm.txt \
%%DATADIR%%/vifm.vim \
%%DATADIR%%/vifmrc
PLIST_DIRS= %%DATADIR%%
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVIFM_SCREEN}
RUN_DEPENDS= screen:${PORTSDIR}/sysutils/screen
.endif
post-patch:
@${REINPLACE_CMD} -e 's/resize_term/resizeterm/g' \
${WRKSRC}/src/ui.c
.if ${PORT_OPTIONS:MVIFM_SCREEN}
@${REINPLACE_CMD} -e "s/cfg.use_screen = 0/cfg.use_screen = 1/" \
${WRKSRC}/src/config.c
@${REINPLACE_CMD} -e "s/USE_SCREEN=0/USE_SCREEN=1/" \
${WRKSRC}/src/vifmrc
.endif
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (vifm-0.6.3.tar.bz2) = 7b6ac1056e7fbca46fb8eb1a40f31c92fc5694b19ca4267fc63e9e295d8cb3ec
SIZE (vifm-0.6.3.tar.bz2) = 386861
SHA256 (vifm-0.7.4b.tar.bz2) = 90b4fb64501e436d7ac8699f0cc75d013a72aa471f978ada0ce9b90506213c57
SIZE (vifm-0.7.4b.tar.bz2) = 562778

View File

@ -0,0 +1,42 @@
--- configure.in.orig 2013-04-02 18:52:13.000000000 +0300
+++ configure.in 2013-04-02 18:53:57.000000000 +0300
@@ -24,7 +24,6 @@
AC_CHECK_HEADER([limits.h], [], [AC_MSG_ERROR([limits.h header not found.])])
AC_CHECK_HEADER([locale.h], [], [AC_MSG_ERROR([locale.h header not found.])])
AC_CHECK_HEADER([math.h], [], [AC_MSG_ERROR([math.h header not found.])])
-AC_CHECK_HEADER([mntent.h], [], [AC_MSG_ERROR([mntent.h header not found.])])
AC_CHECK_HEADER([pwd.h], [], [AC_MSG_ERROR([pwd.h header not found.])])
AC_CHECK_HEADER([signal.h], [], [AC_MSG_ERROR([signal.h header not found.])])
AC_CHECK_HEADER([stdarg.h], [], [AC_MSG_ERROR([stdarg.h header not found.])])
@@ -69,7 +68,6 @@
AC_CHECK_FUNC([closedir], [], [AC_MSG_ERROR([closedir() function not found.])])
AC_CHECK_FUNC([dup], [], [AC_MSG_ERROR([dup() function not found.])])
AC_CHECK_FUNC([dup2], [], [AC_MSG_ERROR([dup2() function not found.])])
-AC_CHECK_FUNC([endmntent], [], [AC_MSG_ERROR([endmntent() function not found.])])
AC_CHECK_FUNC([execve], [], [AC_MSG_ERROR([execve() function not found.])])
AC_CHECK_FUNC([execvp], [], [AC_MSG_ERROR([execvp() function not found.])])
AC_CHECK_FUNC([exit], [], [AC_MSG_ERROR([exit() function not found.])])
@@ -91,7 +89,6 @@
AC_CHECK_FUNC([getgrgid], [], [AC_MSG_ERROR([getgrgid() function not found.])])
AC_CHECK_FUNC([getgrgid_r], [], [AC_MSG_ERROR([getgrgid_r() function not found.])])
AC_CHECK_FUNC([getgrnam], [], [AC_MSG_ERROR([getgrnam() function not found.])])
-AC_CHECK_FUNC([getmntent], [], [AC_MSG_ERROR([getmntent() function not found.])])
AC_CHECK_FUNC([getpid], [], [AC_MSG_ERROR([getpid() function not found.])])
AC_CHECK_FUNC([getppid], [], [AC_MSG_ERROR([getppid() function not found.])])
AC_CHECK_FUNC([getpwent], [], [AC_MSG_ERROR([getpwent() function not found.])])
@@ -132,7 +129,6 @@
AC_CHECK_FUNC([setenv], [], [AC_MSG_ERROR([setenv() function not found.])])
AC_CHECK_FUNC([setgrent], [], [AC_MSG_ERROR([setgrent() function not found.])])
AC_CHECK_FUNC([setlocale], [], [AC_MSG_ERROR([setlocale() function not found.])])
-AC_CHECK_FUNC([setmntent], [], [AC_MSG_ERROR([setmntent() function not found.])])
AC_CHECK_FUNC([setpgid], [], [AC_MSG_ERROR([setpgid() function not found.])])
AC_CHECK_FUNC([setpwent], [], [AC_MSG_ERROR([setpwent() function not found.])])
AC_CHECK_FUNC([setsid], [], [AC_MSG_ERROR([setsid() function not found.])])
@@ -164,7 +160,6 @@
AC_CHECK_FUNC([strtok_r], [], [AC_MSG_ERROR([strtok_r() function not found.])])
AC_CHECK_FUNC([strtol], [], [AC_MSG_ERROR([strtol() function not found.])])
AC_CHECK_FUNC([strtoll], [], [AC_MSG_ERROR([strtoll() function not found.])])
-AC_CHECK_FUNC([strverscmp], [], [AC_MSG_ERROR([strverscmp() function not found.])])
AC_CHECK_FUNC([sysconf], [], [AC_MSG_ERROR([sysconf() function not found.])])
AC_CHECK_FUNC([time], [], [AC_MSG_ERROR([time() function not found.])])
AC_CHECK_FUNC([tolower], [], [AC_MSG_ERROR([tolower() function not found.])])

View File

@ -0,0 +1,29 @@
--- src/sort.c.orig 2013-04-02 18:55:08.000000000 +0300
+++ src/sort.c 2013-04-02 18:37:26.000000000 +0300
@@ -46,7 +46,7 @@
static int sort_dir_list(const void *one, const void *two);
TSTATIC int strnumcmp(const char s[], const char t[]);
-#if defined(_WIN32) || defined(__APPLE__) || defined(__CYGWIN__)
+#if defined(_WIN32) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__FreeBSD__)
static int vercmp(const char s[], const char t[]);
#else
static char * skip_leading_zeros(const char str[]);
@@ -106,7 +106,7 @@
TSTATIC int
strnumcmp(const char s[], const char t[])
{
-#if defined(_WIN32) || defined(__APPLE__) || defined(__CYGWIN__)
+#if defined(_WIN32) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__FreeBSD__)
return vercmp(s, t);
#else
const char *new_s = skip_leading_zeros(s);
@@ -115,7 +115,7 @@
#endif
}
-#if defined(_WIN32) || defined(__APPLE__) || defined(__CYGWIN__)
+#if defined(_WIN32) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__FreeBSD__)
static int
vercmp(const char s[], const char t[])
{

View File

@ -0,0 +1,20 @@
--- src/utils/utils.c.orig 2013-04-02 18:56:49.000000000 +0300
+++ src/utils/utils.c 2013-04-02 18:21:24.000000000 +0300
@@ -34,7 +34,7 @@
#include <sys/wait.h> /* waitpid() */
#endif
-#if !defined(_WIN32) && !defined(__APPLE__)
+#if !defined(_WIN32) && !defined(__APPLE__) && !defined(__FreeBSD__)
#include <mntent.h> /* getmntent() */
#endif
@@ -267,7 +267,7 @@
int
is_on_slow_fs(const char *full_path)
{
-#if defined(_WIN32) || defined(__APPLE__)
+#if defined(_WIN32) || defined(__APPLE__) || defined(__FreeBSD__)
return 0;
#else
FILE *f;

View File

@ -1,11 +0,0 @@
--- src/commands.c.orig 2011-06-19 22:52:25.000000000 +0900
+++ src/commands.c 2011-06-26 15:19:03.000000000 +0900
@@ -27,6 +27,8 @@
#include <stdlib.h> /* system() */
#include <string.h> /* strncmp() */
#include <time.h>
+#include <sys/types.h>
+#include <sys/wait.h>
#include "background.h"
#include "bookmarks.h"

View File

@ -1,13 +0,0 @@
--- src/file_magic.c.orig 2011-06-19 22:52:25.000000000 +0900
+++ src/file_magic.c 2011-06-26 15:30:02.000000000 +0900
@@ -9,7 +9,9 @@
#include <magic.h>
#endif
-#include <sys/dir.h>
+#include <sys/types.h>
+#include <dirent.h>
+#include <limits.h>
#include <stdio.h>
#include <stdlib.h>

View File

@ -1,11 +0,0 @@
--- src/fileops.c.orig 2011-07-21 15:59:01.000000000 +0300
+++ src/fileops.c 2011-08-29 22:03:45.000000000 +0300
@@ -1255,7 +1255,7 @@
stat(temp_file, &st_after);
- if(memcmp(&st_after.st_mtim, &st_before.st_mtim,
+ if(memcmp(&st_after.st_mtime, &st_before.st_mtime,
sizeof(st_after.st_mtime)) == 0)
{
unlink(temp_file);