Pongix is a free game based on classical pong game with support for net game.

WWW:	http://www.losersjuegos.com.ar

PR:		ports/95390
Submitted by:	Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Approved by:	lawrance (mentor, implicit)
This commit is contained in:
Ion-Mihai Tetcu 2006-06-07 19:20:27 +00:00
parent 5916ca5af1
commit 3902d8cadd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164743
6 changed files with 82 additions and 0 deletions

View File

@ -497,6 +497,7 @@
SUBDIR += pmars
SUBDIR += pmars-sdl
SUBDIR += polypuzzle
SUBDIR += pongix
SUBDIR += pouetchess
SUBDIR += powermanga
SUBDIR += powwow

45
games/pongix/Makefile Normal file
View File

@ -0,0 +1,45 @@
# New ports collection makefile for: pongix
# Date created: 2006-04-01
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
#
# $FreeBSD$
#
PORTNAME= pongix
PORTVERSION= 0.4
CATEGORIES= games
MASTER_SITES= http://www.losersjuegos.com.ar/juegos/pongix/descargas/
MAINTAINER= acardenas@bsd.org.pe
COMMENT= Free pong-like game
USE_X_PREFIX= yes
USE_SDL= sdl image net
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
post-extract:
@${FIND} -E ${WRKSRC}/src/ -type f -iregex ".*\.(c|h)" \
-print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's/<SDL/<SDL11/g'
do-install:
${MKDIR} ${DATADIR}
@cd ${WRKSRC}/src && \
${INSTALL_PROGRAM} pongix ${PREFIX}/bin
@cd ${WRKSRC}/data && \
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} -E * -type f -iregex ".*\.(jpg|bmp)" \
-exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && \
${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
.endif
.include <bsd.port.mk>

3
games/pongix/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (pongix-0.4.tar.gz) = 225972add1588c6ba33d7d2cf87e7b38
SHA256 (pongix-0.4.tar.gz) = b72060ded5446f60e187aff1a35eb727484a3b2f798134dc920a16c75b09175e
SIZE (pongix-0.4.tar.gz) = 207490

View File

@ -0,0 +1,20 @@
--- configure Sun Dec 25 16:08:14 2005
+++ configure Wed Apr 5 21:28:25 2006
@@ -2800,7 +2800,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lSDL $LIBS"
+LIBS="`sdl11-config --libs` $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -2862,7 +2862,7 @@
#define HAVE_LIBSDL 1
_ACEOF
- LIBS="-lSDL $LIBS"
+ LIBS="`sdl11-config --libs` $LIBS"
else
\

3
games/pongix/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
Pongix is a free game based on classical pong game with support for net game.
WWW: http://www.losersjuegos.com.ar

10
games/pongix/pkg-plist Normal file
View File

@ -0,0 +1,10 @@
bin/pongix
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
%%DATADIR%%/fondo_juego.jpg
%%DATADIR%%/fuente.bmp
%%DATADIR%%/paleta.bmp
%%DATADIR%%/pelota.bmp
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%