A shell programming utility that prints to stdout a series of numbers from

`start' to `end'

PR:		ports/88391
Submitted by:	Murray Nesbitt <freebsd@nesbitt.ca>
This commit is contained in:
Pav Lucistnik 2005-11-12 11:55:10 +00:00
parent 433ac546cb
commit 38f074d320
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=148022
5 changed files with 43 additions and 0 deletions

View File

@ -289,6 +289,7 @@
SUBDIR += linux-opengroupware
SUBDIR += localedata
SUBDIR += logsurfer
SUBDIR += loop
SUBDIR += lr
SUBDIR += lv
SUBDIR += magicpoint

20
misc/loop/Makefile Normal file
View File

@ -0,0 +1,20 @@
# New ports collection makefile for: loop
# Date created: 12 November 2005
# Whom: Murray Nesbitt <freebsd@nesbitt.ca>
#
# $FreeBSD$
#
PORTNAME= loop
PORTVERSION= 1.0
CATEGORIES= misc
MASTER_SITES= http://www.nesbitt.ca/downloads/loop/
MAINTAINER= freebsd@nesbitt.ca
COMMENT= Prints to stdout a series of numbers from `start' to `end'
MAN1= loop.1
MANCOMPRESSED= yes
PLIST_FILES= bin/loop
.include <bsd.port.mk>

3
misc/loop/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (loop-1.0.tar.gz) = 4655feb51abfb082a06035a3e7e36d4a
SHA256 (loop-1.0.tar.gz) = 6cae60f7114f4d643ae6f2fa4a36e3ed96fa356dde22742d0969527f64a24b7f
SIZE (loop-1.0.tar.gz) = 2007

View File

@ -0,0 +1,13 @@
--- Makefile.orig Wed Nov 2 01:23:17 2005
+++ Makefile Wed Nov 2 01:18:17 2005
@@ -1,7 +1,7 @@
-CC = gcc
-CFLAGS = -Wall -O
-DESTDIR = /usr/local
+CC ?= gcc
+CFLAGS += -Wall
+DESTDIR = ${PREFIX}
loop:
${CC} ${CFLAGS} -o loop loop.c

6
misc/loop/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
Prints to stdout a series of numbers from `start' to `end', with
optional increment and zero-padded field width. Hex (-x) or octal
(-o) output formats are available. Negative numbers are allowed,
and a negative `increment' does the expected thing.
WWW: http://www.nesbitt.ca/downloads/loop/