Avoid linking with libintl. As found by kris, opmixer does not

really use it (PORTREVISION 4).
This commit is contained in:
Trevor Johnson 2004-03-28 12:50:27 +00:00
parent 02c02682a8
commit 38e947497b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105499
2 changed files with 7 additions and 6 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= opmixer
PORTVERSION= 0.70
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= optronic
@ -19,7 +19,6 @@ LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk--
DOCDIR= share/doc/${PORTNAME}
USE_BZIP2= yes
USE_GETTEXT= yes
USE_X_PREFIX= yes
PLIST= ${WRKDIR}/pkg-plist
WRKSRC= ${WRKDIR}/opmixer

View File

@ -1,13 +1,15 @@
$FreeBSD$
--- Makefile.orig Wed Jun 20 16:34:12 2001
+++ Makefile Sat Sep 21 14:52:09 2002
@@ -1,6 +1,6 @@
--- Makefile.orig Wed Jun 20 23:34:12 2001
+++ Makefile Sun Mar 28 12:49:48 2004
@@ -1,7 +1,7 @@
# Generated automatically from Makefile.in by configure.
-CFLAGS := -g -O2 -DLINUX -Wall
-CXXFLAGS := -g -O2 -DLINUX -Wall -I/usr/local/include `gtkmm-config --cflags`
-LDFLAGS := `gtkmm-config --libs`
+CFLAGS += -DLINUX
+CXXFLAGS += -DLINUX `gtkmm-config --cflags`
LDFLAGS := `gtkmm-config --libs`
+LDFLAGS := `gtkmm-config --libs | sed 's/-lintl//'`
all: opmixer opmixer-load volset
%.o : %.c