Improve amd64 fix, Only build shared library with -fPIC

This commit is contained in:
Tilman Keskinoz 2004-03-22 08:43:56 +00:00
parent 37c29839e6
commit 38cde263a3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=104905
2 changed files with 10 additions and 7 deletions

View File

@ -15,15 +15,13 @@ COMMENT= Intelligent Chinese encoding converter
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
CFLAGS+= ${CPPFLAGS} -fPIC
MAKE_ENV= CFLAG="${CPPFLAGS}" LIBS="${LDFLAGS}"
INSTALLS_SHLIB= yes
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
post-patch:
.for dir in hzconvert contrib/xchat-plugins
@${REINPLACE_CMD} -e "s|^CFLAGS|#CLFAGS|" ${WRKSRC}/${dir}/Makefile
.endfor
@${REINPLACE_CMD} -e "s|^CFLAGS|#CFLAGS|" \
${WRKSRC}/contrib/xchat-plugins/Makefile
pre-install:
@${MKDIR} ${DATADIR}

View File

@ -1,6 +1,11 @@
--- hzconvert/Makefile.orig Mon Jan 8 18:05:51 2001
+++ hzconvert/Makefile Tue Jan 9 02:02:33 2001
@@ -5,14 +5,14 @@
--- hzconvert/Makefile.orig Mon Jan 8 11:03:21 2001
+++ hzconvert/Makefile Mon Mar 22 09:39:15 2004
@@ -1,18 +1,18 @@
CC=gcc -I../include
-CFLAGS=-O2 -Wall -g
+CFLAGS+=-fPIC -Wall -g
SHARED_LIB=libhz.so
SHARED_LIB_MAJOR=$(SHARED_LIB).0
SHARED_LIB_MINOR=$(SHARED_LIB_MAJOR).0
OBJS=b2g.o b2u.o g2u.o hz2gb.o b2g_tables.o b2u_tables.o g2u_tables.o io.o unicode.o judge.o judge3.o gbpercent.o b5percent.o search.o