This is a new user process PPP software pakgae. It is easy to setup

and has nice GUI to control connection. This PPP software make a
connection on demand and can traslate IP address and port numbers as
called as NAT. This spackage have many console programs, ppxp is
standard terminal oriented console, xppxp is X client console, tkppxp
is Tcl/Tk based console, and much more.
Submitted by:	Norio Suzuki <nosuzuki@e-mail.ne.jp>,
		KUNISHIMA Takeo <kunishi@c.oka-pu.ac.jp>
This commit is contained in:
SADA Kenji 1998-12-31 17:20:18 +00:00
parent 90f0b636a6
commit 3898f250e0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15740
8 changed files with 312 additions and 0 deletions

83
net/ppxp/Makefile Normal file
View File

@ -0,0 +1,83 @@
# New ports collection makefile for: ppxp
# Version required: 0.98112523
# Date created: 16 June 1998
# Whom: Norio Suzuki
# Based on: KUNISHIMA Takeo <kunishi@c.oka-pu.ac.jp>
#
# $Id$
#
# The option "TCLJP" doesn't work fine on 3.0-CURRENT.
DISTNAME= ppxp-0.98112523
CATEGORIES= net tk80
.if defined(TCLJP)
CATEGORIES+= japanese
.endif
MASTER_SITES= http://www.dsl.ics.tut.ac.jp/~manabe/PPxP/packages/ \
http://www.dsl.gr.jp/~manabe/PPxP/packages/
MAINTAINER= nosuzuki@e-mail.ne.jp
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
xforms.0:${PORTSDIR}/x11-toolkits/xforms
.if defined(TCLJP)
BUILD_DEPENDS= wish8.0jp:${PORTSDIR}/japanese/tk80 \
tclsh8.0jp:${PORTSDIR}/japanese/tcl80
RUN_DEPENDS= wish8.0jp:${PORTSDIR}/japanese/tk80 \
tclsh8.0jp:${PORTSDIR}/japanese/tcl80
.else
BUILD_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80 \
tclsh8.0:${PORTSDIR}/lang/tcl80
RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80 \
tclsh8.0:${PORTSDIR}/lang/tcl80
.endif
WRKSRC= ${WRKDIR}/ppxp
USE_GMAKE= yes
MAKEFILE= makefile
GNU_CONFIGURE= yes
.if defined(TCLJP)
CONFIGURE_ARGS+= --with-tclsh=${PREFIX}/bin/tclsh8.0jp \
--with-wish=${PREFIX}/bin/wish8.0jp \
--with-tcl-includes=${PREFIX}/include/tcl8.0jp \
--with-tcl-config=${PREFIX}/lib/tcl8.0jp/tclConfig.sh \
--with-tk-config=${PREFIX}/lib/tk8.0jp/tkConfig.sh
.else
CONFIGURE_ARGS+= --with-tclsh=${PREFIX}/bin/tclsh8.0 \
--with-wish=${PREFIX}/bin/wish8.0 \
--with-tcl-includes=${PREFIX}/include/tcl8.0 \
--with-tcl-config=${PREFIX}/lib/tcl8.0/tclConfig.sh \
--with-tk-config=${PREFIX}/lib/tk8.0/tkConfig.sh
.endif
MAN1= PPxP.1
MAN5= ppxp-files.5
MANLANG= ja
DOC_C= QuickStart.txt
DOC_ja_JP= QuickStart.txt guide-1.html guide-2.html \
guide-3.html guide-4.html guide-5.html guide-6.html \
guide-7.html guide-8.html guide-9.html guide-10.html \
guide.html
post-patch:
@find ${WRKSRC} -name '*.orig' -exec ${RM} -f '{}' ';'
post-install:
@${INSTALL_MAN} ${WRKSRC}/doc/ja_JP/PPxP.1 ${PREFIX}/man/${MANLANG}/man1
@${INSTALL_MAN} ${WRKSRC}/doc/ja_JP/ppxp-files.5 ${PREFIX}/man/${MANLANG}/man5
@${MKDIR} ${PREFIX}/share/doc/ppxp/C
.for file in ${DOC_C}
@${INSTALL_DATA} ${WRKSRC}/doc/C/${file} ${PREFIX}/share/doc/ppxp/C
.endfor
@${MKDIR} ${PREFIX}/share/doc/ppxp/ja
.for file in ${DOC_ja_JP}
@${INSTALL_DATA} ${WRKSRC}/doc/ja_JP/${file} ${PREFIX}/share/doc/ppxp/ja
.endfor
@${MKDIR} ${PREFIX}/share/doc/tkppxp
@${INSTALL_DATA} ${WRKSRC}/console/tcltk/README ${PREFIX}/share/doc/tkppxp
@${MKDIR} ${PREFIX}/share/doc/xppxp
@${INSTALL_DATA} ${WRKSRC}/console/xppxp/README ${PREFIX}/share/doc/xppxp
@${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/ppxp/tcl
.include <bsd.port.mk>

1
net/ppxp/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ppxp-0.98112523.tar.gz) = c06c40b5352e2c35ef6aac7f64eee11b

28
net/ppxp/files/patch-aa Normal file
View File

@ -0,0 +1,28 @@
*** etc/modem/MC-6500@isdn Thu Jan 1 09:00:00 1970
--- etc/modem/MC-6500@isdn Mon Jun 15 22:41:37 1998
***************
*** 0 ****
--- 1,9 ----
+ include standard
+
+ Name "PHS alpha DATA MC-6500 @ ISDN"
+ MaxDTESpeed 115200
+ Initialize "ATE1Q0@O2"
+ PulseDial "ATD\p"
+ ToneDial "ATD\p"
+ Dial "ATD\p"
+ IsdnDial "ATD\p"
*** etc/modem/MC-6500@modem Thu Jan 1 09:00:00 1970
--- etc/modem/MC-6500@modem Mon Jun 15 22:42:20 1998
***************
*** 0 ****
--- 1,9 ----
+ include standard
+
+ Name "PHS alpha DATA MC-6500 @ modem"
+ MaxDTESpeed 115200
+ Initialize "ATE1Q0@O1"
+ PulseDial "ATD\p"
+ ToneDial "ATD\p"
+ Dial "ATD\p"
+ IsdnDial "ATD\p"

11
net/ppxp/files/patch-ab Normal file
View File

@ -0,0 +1,11 @@
--- console/xppxp/Makefile.in.orig Thu Dec 24 04:51:34 1998
+++ console/xppxp/Makefile.in Thu Dec 24 04:51:43 1998
@@ -16,7 +16,7 @@
#SIGVOID = -DHasVoidSignalReturn
#
CC = @CC@
-XLIB = @X_LIBS@ -lXaw -lXmu -lXt -lX11 -lXpm
+XLIB = @X_LIBS@ -lXaw -lXmu -lXt -lXext -lX11 @X_PRE_LIBS@ -lXpm
CFLAGS = @CFLAGS@ -I$(PPXPINC) -DXPPXPDIR=\"$(XPPXPDIR)\" @X_CFLAGS@
LDFLAGS = @LDFLAGS@ $(PPXPLIB) $(XLIB)
#

8
net/ppxp/files/patch-ac Normal file
View File

@ -0,0 +1,8 @@
--- console/forms/fip.c.orig Sat Dec 26 00:48:38 1998
+++ console/forms/fip.c Sat Dec 26 00:48:41 1998
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <sys/types.h>
#include <netinet/in.h>
#include "fppxp.h"

1
net/ppxp/pkg-comment Normal file
View File

@ -0,0 +1 @@
A new and easy to use PPP software

15
net/ppxp/pkg-descr Normal file
View File

@ -0,0 +1,15 @@
This is a new user process PPP software pakgae. It is easy to setup
and has nice GUI to control connection. This PPP software make a
connection on demand and can traslate IP address and port numbers as
called as NAT. This spackage have many console programs, ppxp is
standard terminal oriented console, xppxp is X client console, tkppxp
is Tcl/Tk based console, and much more.
There are more documentation under /usr/local/share/doc/ppxp.
Ref. <URL:http://www.dsl.ics.tut.ac.jp/~manabe/PPxP/>
Copyright (c) 1997, 1998 The PPxP Development Team. All rights reserved.
--
Norio Suzuki
nosuzuki@e-mail.ne.jp

165
net/ppxp/pkg-plist Normal file
View File

@ -0,0 +1,165 @@
bin/fppxp
bin/plast
bin/ppxp
bin/qdial
bin/tkppxp
bin/xppxp
bin/xppxpm
etc/ppxp/catcap
etc/ppxp/chat/justnet
etc/ppxp/chat/modemlogin
etc/ppxp/chat/nifty
etc/ppxp/conf/debug
etc/ppxp/conf/default
etc/ppxp/conf/filter01
etc/ppxp/conf/lcp.def
etc/ppxp/conf/modem
etc/ppxp/conf/qdial
etc/ppxp/conf/report
etc/ppxp/conf/serial
etc/ppxp/conf/serial.os
etc/ppxp/conf/server
etc/ppxp/ip/droutedown
etc/ppxp/ip/drouteup
etc/ppxp/ip/drupmq
etc/ppxp/ip/hroutedown
etc/ppxp/ip/hrouteup
etc/ppxp/keybind
etc/ppxp/modem/3c563
etc/ppxp/modem/MC-6500@isdn
etc/ppxp/modem/MC-6500@modem
etc/ppxp/modem/aterm
etc/ppxp/modem/default
etc/ppxp/modem/dn1280
etc/ppxp/modem/ex336
etc/ppxp/modem/generic
etc/ppxp/modem/mc6500
etc/ppxp/modem/mc6530
etc/ppxp/modem/mn128
etc/ppxp/modem/ms336
etc/ppxp/modem/pcins128
etc/ppxp/modem/pcmi336_128@64
etc/ppxp/modem/rta50i
etc/ppxp/modem/sta128
etc/ppxp/modem/standard
etc/ppxp/modem/ta777
etc/ppxp/modem/tmad1280@128
etc/ppxp/modem/tmad1280@64
etc/ppxp/modem/v34es2
etc/ppxp/modem/xj2144
etc/ppxp/rc/fetchmail.rc
etc/ppxp/rc/sendmail.rc
etc/ppxp/rc/skeleton.rc
etc/ppxp/rc/start
etc/ppxp/rc/stop
lib/ppxp/tcl/PPxP.so
lib/ppxp/tcl/pkgIndex.tcl
lib/ppxp/tkppxp/images/circle.xbm
lib/ppxp/tkppxp/images/double-right.xbm
lib/ppxp/tkppxp/images/down.xbm
lib/ppxp/tkppxp/images/eject.gif
lib/ppxp/tkppxp/images/in6x6.xbm
lib/ppxp/tkppxp/images/mini-down.xbm
lib/ppxp/tkppxp/images/mini-up.xbm
lib/ppxp/tkppxp/images/open-folder.gif
lib/ppxp/tkppxp/images/out6x6.xbm
lib/ppxp/tkppxp/images/pause.gif
lib/ppxp/tkppxp/images/rec.gif
lib/ppxp/tkppxp/images/skip_fw.gif
lib/ppxp/tkppxp/images/start.gif
lib/ppxp/tkppxp/images/stop.gif
lib/ppxp/tkppxp/images/up.xbm
lib/ppxp/tkppxp/resources/default
lib/ppxp/tkppxp/resources/qdial_message
lib/ppxp/tkppxp/resources/qdial_message.ja
lib/ppxp/tkppxp/scripts/conf.tcl
lib/ppxp/tkppxp/scripts/icon.tcl
lib/ppxp/tkppxp/scripts/indicator.tcl
lib/ppxp/tkppxp/scripts/log.tcl
lib/ppxp/tkppxp/scripts/modem.tcl
lib/ppxp/tkppxp/scripts/panel.tcl
lib/ppxp/tkppxp/scripts/popup.tcl
lib/ppxp/tkppxp/scripts/ppxplink.tcl
lib/ppxp/tkppxp/scripts/qdial.tcl
lib/ppxp/tkppxp/scripts/tclutil.tcl
lib/ppxp/tkppxp/scripts/terminal.tcl
lib/ppxp/tkppxp/scripts/toplevel.tcl
lib/ppxp/tkppxp/widgets/buttonbox.tcl
lib/ppxp/tkppxp/widgets/buttonentry.tcl
lib/ppxp/tkppxp/widgets/checkbox.tcl
lib/ppxp/tkppxp/widgets/ipentry.tcl
lib/ppxp/tkppxp/widgets/labelframe.tcl
lib/ppxp/tkppxp/widgets/listboxmenu.tcl
lib/ppxp/tkppxp/widgets/listframe.tcl
lib/ppxp/tkppxp/widgets/menuentry.tcl
lib/ppxp/tkppxp/widgets/notebook.tcl
lib/ppxp/tkppxp/widgets/radiobox.tcl
lib/ppxp/tkppxp/widgets/test.tcl
lib/ppxp/tkppxp/widgets/updownentry.tcl
lib/ppxp/tkppxp/widgets/widgetutil.tcl
sbin/in.ppxp
sbin/ppxpd
share/doc/ppxp/C/QuickStart.txt
share/doc/ppxp/ja/QuickStart.txt
share/doc/ppxp/ja/guide-1.html
share/doc/ppxp/ja/guide-10.html
share/doc/ppxp/ja/guide-2.html
share/doc/ppxp/ja/guide-3.html
share/doc/ppxp/ja/guide-4.html
share/doc/ppxp/ja/guide-5.html
share/doc/ppxp/ja/guide-6.html
share/doc/ppxp/ja/guide-7.html
share/doc/ppxp/ja/guide-8.html
share/doc/ppxp/ja/guide-9.html
share/doc/ppxp/ja/guide.html
share/doc/tkppxp/README
share/doc/xppxp/README
share/nls/ja_JP.EUC/ppxp.cat
share/nls/ja_JP.EUC/ppxpd.cat
share/ppxp/html/basic.html
share/ppxp/html/help.html
share/ppxp/html/index.html
share/ppxp/html/line.html
share/ppxp/html/log.html
share/ppxp/html/logo.gif
share/ppxp/html/menu.html
share/ppxp/html/quick.html
share/ppxp/label/asahi.xpm
share/ppxp/label/base.xpm
share/ppxp/label/bekkoame.xpm
share/ppxp/label/biglobe.xpm
share/ppxp/label/dti.xpm
share/ppxp/label/iij.xpm
share/ppxp/label/iij4u.xpm
share/ppxp/label/infopepper.xpm
share/ppxp/label/infosphere.xpm
share/ppxp/label/nifty.xpm
share/ppxp/label/ocn.xpm
share/ppxp/label/ppxp.xpm
share/ppxp/label/rim.xpm
share/ppxp/label/so-net.xpm
share/ppxp/label/worldnet.xpm
share/ppxp/label/xaxon.xpm
@exec mkdir -p /var/log/ppxp
@unexec rm -rf /var/log/ppxp
@dirrm share/ppxp/label
@dirrm share/ppxp/html
@dirrm share/ppxp
@dirrm share/doc/xppxp
@dirrm share/doc/tkppxp
@dirrm share/doc/ppxp/ja
@dirrm share/doc/ppxp/C
@dirrm share/doc/ppxp
@dirrm lib/ppxp/tkppxp/widgets
@dirrm lib/ppxp/tkppxp/scripts
@dirrm lib/ppxp/tkppxp/resources
@dirrm lib/ppxp/tkppxp/images
@dirrm lib/ppxp/tkppxp
@dirrm lib/ppxp/tcl
@dirrm lib/ppxp
@dirrm etc/ppxp/rc
@dirrm etc/ppxp/modem
@dirrm etc/ppxp/ip
@dirrm etc/ppxp/conf
@dirrm etc/ppxp/chat
@dirrm etc/ppxp