Add a distinct package for eximon, the management GUI for the Exim

MTA.
This commit is contained in:
Sheldon Hearn 2001-08-27 13:19:14 +00:00
parent 8188cfcbb1
commit 38748d8321
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46971
10 changed files with 153 additions and 0 deletions

View File

@ -33,6 +33,7 @@
SUBDIR += exim
SUBDIR += exim-ldap
SUBDIR += exim-ldap2
SUBDIR += exim-monitor
SUBDIR += exim-mysql
SUBDIR += exim-postgresql
SUBDIR += exmh2

View File

@ -0,0 +1,44 @@
# New ports collection makefile for: exim-minitor
# Date created: 27 August 2001
# Whom: sheldonh@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= exim
PORTVERSION= 3.33
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
ftp://ftp.is.co.za/networking/mail/transport/exim/
MAINTAINER= sheldonh@FreeBSD.org
USE_BZIP2= yes
USE_PERL5= yes
USE_XLIB= yes
# This dependency is disabled, because it prevents package users from
# using the exim-monitor package with any of the exim slave packages.
#
#RUN_DEPENDS= ${LOCALBASE}/sbin/exim:${PORTSDIR}/mail/exim
MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
SEDLIST= -e 's,XX_PREFIX_XX,${PREFIX},'
do-configure:
${MKDIR} ${WRKSRC}/Local
${SED} ${SEDLIST} < ${WRKSRC}/src/EDITME > ${WRKSRC}/Local/Makefile
${CP} ${WRKSRC}/exim_monitor/EDITME ${WRKSRC}/Local/eximon.conf
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon.bin \
${PREFIX}/sbin/
${INSTALL_SCRIPT} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon \
${PREFIX}/sbin/
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (exim-3.33.tar.bz2) = d93a6f6387e18cf94c709f93c725b823

View File

@ -0,0 +1,12 @@
--- OS/Makefile-Base.orig Wed Aug 15 13:09:05 2001
+++ OS/Makefile-Base Mon Aug 27 14:59:04 2001
@@ -19,7 +19,8 @@
# up-to-date. Then the os-specific source files and the C configuration file
# are set up, and finally it goes to the main Exim target.
-all: $(EDITME) checklocalmake Makefile os.h os.c config.h allexim
+all: $(EDITME) checklocalmake Makefile os.h os.c config.h buildpcre \
+ eximon.bin
checklocalmake:
@if $(SHELL) $(SCRIPTS)/newer $(EDITME)-$(OSTYPE) $(EDITME) || \

View File

@ -0,0 +1,10 @@
--- OS/Makefile-FreeBSD.orig Mon Jun 11 12:04:05 2001
+++ OS/Makefile-FreeBSD Mon Jun 11 12:04:33 2001
@@ -5,6 +5,7 @@
PORTOBJFORMAT!= test -x /usr/bin/objformat && /usr/bin/objformat || echo aout
CHOWN_COMMAND=/usr/sbin/chown
+STRIP_COMMAND=/usr/bin/strip
HAVE_SA_LEN=YES

View File

@ -0,0 +1,64 @@
--- src/EDITME.orig Mon Aug 27 14:35:47 2001
+++ src/EDITME Mon Aug 27 14:37:31 2001
@@ -103,7 +103,7 @@
# installed in this directory. There is no default for this variable built into
# the source files; it must be set in one of the local configuration files.
-BIN_DIRECTORY=/usr/exim/bin
+BIN_DIRECTORY=XX_PREFIX_XX/bin
# The default distribution of Exim contains only the plain text form of the
@@ -121,14 +121,14 @@
# files. Both the name of the command and the suffix that it adds to files
# need to be defined here. See also the EXICYCLOG_MAX configuration.
-COMPRESS_COMMAND=/opt/gnu/bin/gzip
+COMPRESS_COMMAND=/usr/bin/gzip
COMPRESS_SUFFIX=gz
# If the exigrep utility is fed compressed log files, it tries to uncompress
# them using this command.
-ZCAT_COMMAND=/opt/gnu/bin/zcat
+ZCAT_COMMAND=/usr/bin/zcat
# The runtime configuration file: This variable defines where Exim's runtime
@@ -137,7 +137,7 @@
# location of all other runtime files and directories can be changed in the
# runtime configuration file.
-CONFIGURE_FILE=/usr/exim/configure
+CONFIGURE_FILE=XX_PREFIX_XX/etc/exim/configure
# In some installations there may be multiple machines sharing file systems,
@@ -286,7 +286,7 @@
# "panic", or "reject" to form the final file name. For example, some
# installations may want something like this:
-# LOG_FILE_PATH=/var/log/exim_%slog
+LOG_FILE_PATH=/var/log/exim/%slog
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -411,7 +411,7 @@
# the file name, allowing sites that run two separate daemons to distinguish
# them. Some installations may want something like this
-# PID_FILE_PATH=/var/lock/exim%s.pid
+PID_FILE_PATH=/var/run/exim%s.pid
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
# (see SPOOL_DIRECTORY below) with the name "exim-daemon.pid" for the standard
@@ -460,7 +460,7 @@
# uid and gid.
# Many installations will want something like this:
-# SPOOL_DIRECTORY=/var/spool/exim
+SPOOL_DIRECTORY=/var/spool/exim
# Others may prefer to keep all Exim things under one directory:
# SPOOL_DIRECTORY=/usr/exim/spool

View File

@ -0,0 +1 @@
The Exim monitor for the Exim MTA

View File

@ -0,0 +1,9 @@
The Exim monitor (eximon) is a graphical user interface for the Exim
mail transfer agent for Unix systems. Eximon is distributed as part
of the standard Exim distribution, but its dependency on XFree86
annoys many administrators.
For this reason, it is available as its own package to allow
administrators to easily install Exim without installing XFree86.
WWW: http://www.exim.org/

View File

@ -0,0 +1,9 @@
Although the Exim monitor has been correctly installed, please note
that it is useless without the Exim MTA. Install one of the Exim
packages available, which include documentation for the Exim monitor:
exim
exim-ldap
exim-ldap2
exim-mysql
exim-postgresql

View File

@ -0,0 +1,2 @@
sbin/eximon
sbin/eximon.bin