- Support staging

- Convert USE_GMAKE to USES
- Fix segfault
- Rename patches according to porter's handbook
This commit is contained in:
Dmitry Marakasov 2013-10-19 02:58:40 +00:00
parent 1960684ce4
commit 3855759fd5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=330839
5 changed files with 15 additions and 121 deletions

View File

@ -12,7 +12,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= SDL/OpenGL top-down shooter
GNU_CONFIGURE= yes
USE_GMAKE= yes
USES= gmake
USE_GL= gl
USE_SDL= sdl mixer image
@ -20,5 +20,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
NO_STAGE= yes
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- src/game/cMainMenu.cpp.orig 2004-02-21 15:48:50.000000000 +0300
+++ src/game/cMainMenu.cpp 2013-10-19 04:20:28.484773573 +0400
@@ -399,7 +399,7 @@
string &text = mDemoStrings[mCurrentString];
- static unsigned int i = 0;
+ static int i = 0;
if ( mLastLetter + 100 < now )
{
i++;

View File

@ -1,119 +0,0 @@
bin/shootingstar
%%DATADIR%%/animations/bloodpool
%%DATADIR%%/animations/enemy_shoot
%%DATADIR%%/animations/enemy_stand
%%DATADIR%%/animations/enemy_walk
%%DATADIR%%/animations/enemy_wshoot
%%DATADIR%%/animations/gibs
%%DATADIR%%/animations/medpack
%%DATADIR%%/animations/player1_shoot
%%DATADIR%%/animations/player1_stand
%%DATADIR%%/animations/player1_walk
%%DATADIR%%/animations/player1_wshoot
%%DATADIR%%/animations/player2_shoot
%%DATADIR%%/animations/player2_stand
%%DATADIR%%/animations/player2_walk
%%DATADIR%%/animations/player2_wshoot
%%DATADIR%%/animations/rocket
%%DATADIR%%/animations/weaponbox
%%DATADIR%%/maps/city.map
%%DATADIR%%/maps/city.obj
%%DATADIR%%/maps/factory.map
%%DATADIR%%/maps/factory.obj
%%DATADIR%%/maps/highway.map
%%DATADIR%%/maps/highway.obj
%%DATADIR%%/maps/levels
%%DATADIR%%/maps/office.map
%%DATADIR%%/maps/office.obj
%%DATADIR%%/maps/park.map
%%DATADIR%%/maps/park.obj
%%DATADIR%%/maps/test.map
%%DATADIR%%/maps/test.obj
%%DATADIR%%/maps/village.map
%%DATADIR%%/maps/village.obj
%%DATADIR%%/maps/warehouse.map
%%DATADIR%%/maps/warehouse.obj
%%DATADIR%%/shootingstar.cfg
%%DATADIR%%/sounds/bazookareload.wav
%%DATADIR%%/sounds/burning.wav
%%DATADIR%%/sounds/dead.ogg
%%DATADIR%%/sounds/death.wav
%%DATADIR%%/sounds/empty.wav
%%DATADIR%%/sounds/explosion.wav
%%DATADIR%%/sounds/flamer.wav
%%DATADIR%%/sounds/hit.wav
%%DATADIR%%/sounds/hurt.wav
%%DATADIR%%/sounds/machinegun.wav
%%DATADIR%%/sounds/menu.ogg
%%DATADIR%%/sounds/pickup.wav
%%DATADIR%%/sounds/pistol.wav
%%DATADIR%%/sounds/reload.wav
%%DATADIR%%/sounds/rocket.wav
%%DATADIR%%/sounds/shotgun.wav
%%DATADIR%%/sounds/shotgunreload.wav
%%DATADIR%%/textures/ammobox.png
%%DATADIR%%/textures/archive.png
%%DATADIR%%/textures/archive_open.png
%%DATADIR%%/textures/barrel.png
%%DATADIR%%/textures/barrel1.png
%%DATADIR%%/textures/barrel2.png
%%DATADIR%%/textures/bitmaps.png
%%DATADIR%%/textures/blood1.png
%%DATADIR%%/textures/blood2.png
%%DATADIR%%/textures/blood3.png
%%DATADIR%%/textures/blood4.png
%%DATADIR%%/textures/blood_big1.png
%%DATADIR%%/textures/blood_big2.png
%%DATADIR%%/textures/body1.png
%%DATADIR%%/textures/body2.png
%%DATADIR%%/textures/concrete.png
%%DATADIR%%/textures/enemy.png
%%DATADIR%%/textures/floor1.png
%%DATADIR%%/textures/floor2.png
%%DATADIR%%/textures/font_11x20.png
%%DATADIR%%/textures/gibs.png
%%DATADIR%%/textures/grass.png
%%DATADIR%%/textures/ground.png
%%DATADIR%%/textures/hear.png
%%DATADIR%%/textures/hud_p1.png
%%DATADIR%%/textures/hud_p2.png
%%DATADIR%%/textures/laatikko1.png
%%DATADIR%%/textures/laatikko2.png
%%DATADIR%%/textures/laatikko3.png
%%DATADIR%%/textures/laatikko4.png
%%DATADIR%%/textures/laatikko4_p.png
%%DATADIR%%/textures/laatikko_p.png
%%DATADIR%%/textures/logo_left.png
%%DATADIR%%/textures/logo_right.png
%%DATADIR%%/textures/mainmenu.png
%%DATADIR%%/textures/medpak.png
%%DATADIR%%/textures/menu_selector.png
%%DATADIR%%/textures/pipe.png
%%DATADIR%%/textures/player1.png
%%DATADIR%%/textures/player2.png
%%DATADIR%%/textures/poyta.png
%%DATADIR%%/textures/poyta2.png
%%DATADIR%%/textures/road.png
%%DATADIR%%/textures/smoke.png
%%DATADIR%%/textures/stonefloor.png
%%DATADIR%%/textures/stones1.png
%%DATADIR%%/textures/stones2.png
%%DATADIR%%/textures/stones3.png
%%DATADIR%%/textures/suer.png
%%DATADIR%%/textures/toilet_clean.png
%%DATADIR%%/textures/toilet_dirty.png
%%DATADIR%%/textures/track.png
%%DATADIR%%/textures/treetop1.png
%%DATADIR%%/textures/tuli2.png
%%DATADIR%%/textures/tuoli.png
%%DATADIR%%/textures/wall_32.png
%%DATADIR%%/textures/warning.png
%%DATADIR%%/textures/wcfloor.png
%%DATADIR%%/textures/weam.png
%%DATADIR%%/textures/weaponlogos.png
%%DATADIR%%/textures/woodfloor.png
@dirrm %%DATADIR%%/animations
@dirrm %%DATADIR%%/maps
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/textures
@dirrm %%DATADIR%%