Since c-client has to be update for pine, this has to be updated to match.
Mostly simple version update, but apply some of the same fixes from c-client. * Make some Makefile variables more... variable * SSLTYPE update to match new c-client makefile * Usual round of patch re-generation, but do some of the DRAC stuff in a way that has a better chance of surviving the next software update. * One hunk of patch-ah is now obsoleted * Add a patch for mailutil/Makefile similar to the other Makfile patches that fix c-client dependencies.
This commit is contained in:
parent
5ccd0436d2
commit
383d2b4189
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71114
@ -6,16 +6,15 @@
|
||||
#
|
||||
|
||||
PORTNAME= imap
|
||||
PORTVERSION= 2001a
|
||||
PORTVERSION= 2002
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
|
||||
ftp://ftp.nuug.no/pub/anders/distfiles/%SUBDIR%/ \
|
||||
http://atreides.freenix.no/~anders/%SUBDIR%/ \
|
||||
ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/mail/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= . old
|
||||
PKGNAMESUFFIX= -uw
|
||||
DISTNAME= imap-2001a
|
||||
DISTNAME= imap-${PORTVERSION}
|
||||
DISTFILES= ${DISTNAME}.tar.Z imap-utils.tar.Z
|
||||
|
||||
MAINTAINER= anders@FreeBSD.org
|
||||
@ -25,13 +24,13 @@ LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
|
||||
.endif
|
||||
|
||||
WRKSRC= ${WRKDIR}/imap-2001a
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
|
||||
MAN8= ipopd.8 imapd.8
|
||||
|
||||
ALL_TARGET= bsf
|
||||
.if defined(WITH_SSL)
|
||||
MAKE_ARGS+= SSLTYPE=unix
|
||||
MAKE_ARGS+= SSLTYPE=unix.nopwd
|
||||
USE_OPENSSL= yes
|
||||
.endif
|
||||
|
||||
@ -120,8 +119,8 @@ post-install:
|
||||
@${ECHO}
|
||||
@${ECHO} "Example inetd config for SSL only services:"
|
||||
@${ECHO}
|
||||
@${ECHO} "pop3s stream tcp nowait root /usr/local/libexec/ipop3d ipop3d"
|
||||
@${ECHO} "imaps stream tcp nowait root /usr/local/libexec/imapd imapd"
|
||||
@${ECHO} "pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d"
|
||||
@${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
|
||||
@${ECHO}
|
||||
@${ECHO} "Remember to recompile and reinstall your cclient port with SSL support too, if"
|
||||
@${ECHO} "you had it installed without SSL support."
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (imap-2001a.tar.Z) = 42c5c8d049c209b15513a4f6ebba34d2
|
||||
MD5 (imap-2002.tar.Z) = ab5a7afb25cbd037b4490c42e0fe235e
|
||||
MD5 (imap-utils.tar.Z) = a54772a4954ecc145a5f962d8e6012bf
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/imapd/Makefile.orig Thu Jun 28 19:23:36 2001
|
||||
+++ src/imapd/Makefile Mon Oct 1 05:00:17 2001
|
||||
--- src/imapd/Makefile.orig Mon Nov 18 08:48:25 2002
|
||||
+++ src/imapd/Makefile Tue Nov 26 02:07:06 2002
|
||||
@@ -18,10 +18,10 @@
|
||||
# CPYRIGHT, included with this Distribution.
|
||||
|
||||
@ -13,24 +13,24 @@
|
||||
SHELL= /bin/sh
|
||||
|
||||
|
||||
@@ -37,7 +37,9 @@
|
||||
# NULs in the message text are technically a violation of both the message
|
||||
# format and the IMAP specification, they can happen. Fortunately, most
|
||||
# IMAP clients don't care. Netscape hangs.
|
||||
@@ -29,7 +29,9 @@
|
||||
# causes the "Manage Mail" menu item to open the given URL, e.g. to point to
|
||||
# an alternative IMAP client (e.g. Pine) or perhaps to a homebrew mail
|
||||
# account management page.
|
||||
-#NSBD= -DNETSCAPE_BRAIN_DAMAGE=\"http://www.washington.edu/pine\"
|
||||
+.if defined(WITH_NETSCAPE_BRAIN_DAMAGE)
|
||||
+NSBD= -DNETSCAPE_BRAIN_DAMAGE=\"http://www.washington.edu/pine\"
|
||||
+.endif
|
||||
|
||||
|
||||
# Un-comment this to get somewhat better interoperability with Microsoft
|
||||
@@ -61,22 +63,21 @@
|
||||
|
||||
@@ -44,22 +46,21 @@
|
||||
# Get local definitions from c-client directory
|
||||
|
||||
C = ../c-client
|
||||
-CCLIENTLIB = $C/c-client.a
|
||||
-CC = `cat $C/CCTYPE`
|
||||
-CFLAGS = -I$C `cat $C/CFLAGS` $(RFC1730) $(NSBD) $(MSBD) $(ENBD) \
|
||||
-CFLAGS = -I$C `cat $C/CFLAGS` $(NSBD) $(ENBD) \
|
||||
- -DANOFILE=\"$(ANO)\" -DALERTFILE=\"$(ALERT)\" \
|
||||
- -DUSERALERTFILE=\"$(USERALERT)\" -DSHUTDOWNFILE=\"$(SHUTDOWN)\"
|
||||
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
|
||||
@ -38,7 +38,7 @@
|
||||
+CFLAGS+= -DNFSKLUDGE -I$(LOCALBASE)/include/c-client -DANOFILE=\"$(ANO)\" \
|
||||
+ -DALERTFILE=\"$(ALERT)\" -DUSERALERTFILE=\"$(USERALERT)\" \
|
||||
+ -DSHUTDOWNFILE=\"$(SHUTDOWN)\"
|
||||
+LDFLAGS+= $(EXTRALDFLAGS) -L$(LOCALBASE)/lib -lc-client4
|
||||
+LDFLAGS+= $(EXTRALDFLAGS) -L$(LOCALBASE)/lib -lc-client4
|
||||
+.if defined(WITH_DRAC)
|
||||
+CFLAGS+= -DETC_DIR=\"$(PREFIX)/etc\" -DDRAC_AUTH
|
||||
+LDFLAGS+= -ldrac
|
||||
@ -48,7 +48,7 @@
|
||||
all: imapd
|
||||
|
||||
-imapd: $(CCLIENTLIB) imapd.o
|
||||
+imapd: imapd.o
|
||||
+imapd: imapd.o
|
||||
$(CC) $(CFLAGS) -o imapd imapd.o $(LDFLAGS)
|
||||
-
|
||||
-imapd.o: $C/mail.h $C/misc.h $C/osdep.h
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/ipopd/ipop3d.c.orig Sat Dec 8 14:22:36 2001
|
||||
+++ src/ipopd/ipop3d.c Sat Dec 8 14:22:41 2001
|
||||
--- src/ipopd/ipop3d.c.orig Tue Dec 18 13:41:46 2001
|
||||
+++ src/ipopd/ipop3d.c Tue Nov 26 02:15:13 2002
|
||||
@@ -28,6 +28,11 @@
|
||||
#include <time.h>
|
||||
#include "c-client.h"
|
||||
@ -12,29 +12,21 @@
|
||||
|
||||
#define CRLF PSOUT ("\015\012") /* primary output terpri */
|
||||
|
||||
@@ -57,6 +62,12 @@
|
||||
|
||||
/* Global storage */
|
||||
@@ -54,6 +59,13 @@
|
||||
#define STATUS "Status: %s%s\015\012"
|
||||
#define SLEN (sizeof (STATUS)-3)
|
||||
|
||||
+#ifdef DRAC_AUTH
|
||||
+#define DRACTIMEOUT 10*60 /* check every 10 minutes */
|
||||
+time_t lastdrac = 0; /* time of last drac check */
|
||||
+#define DRACTIMEOUT 10*60 /* check every 10 minutes */
|
||||
+time_t lastdrac = 0; /* time of last drac check */
|
||||
+extern char *getenv ();
|
||||
+#endif /* DRAC_AUTH */
|
||||
+
|
||||
char *version = "2001.78"; /* server version */
|
||||
short state = AUTHORIZATION; /* server state */
|
||||
short critical = NIL; /* non-zero if in critical code */
|
||||
@@ -100,7 +111,7 @@
|
||||
#include "linkage.c"
|
||||
/* initialize server */
|
||||
server_init (((s = strrchr (argv[0],'/')) || (s = strrchr (argv[0],'\\'))) ?
|
||||
- s+1 : argv[0],"pop3","pop3s","pop",clkint,kodint,hupint,trmint);
|
||||
+ s+1 : argv[0],"pop3","pop3s","pop3",clkint,kodint,hupint,trmint);
|
||||
challenge[0] = '\0'; /* find the CRAM-MD5 authenticator */
|
||||
if (i = mail_lookup_auth_name ("CRAM-MD5",NIL)) {
|
||||
AUTHENTICATOR *a = mail_lookup_auth (i);
|
||||
@@ -694,6 +705,46 @@
|
||||
+
|
||||
|
||||
/* Global storage */
|
||||
|
||||
@@ -696,6 +708,46 @@
|
||||
}
|
||||
sprintf (tmp,"+OK Mailbox open, %lu messages\015\012",nmsgs);
|
||||
PSOUT (tmp);
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/imapd/imapd.c.orig Sat Dec 8 14:25:00 2001
|
||||
+++ src/imapd/imapd.c Sat Dec 8 14:28:55 2001
|
||||
--- src/imapd/imapd.c.orig Mon Nov 18 14:29:04 2002
|
||||
+++ src/imapd/imapd.c Tue Nov 26 02:19:34 2002
|
||||
@@ -29,6 +29,11 @@
|
||||
#include "c-client.h"
|
||||
#include <sys/stat.h>
|
||||
@ -12,20 +12,21 @@
|
||||
|
||||
#define CRLF PSOUT ("\015\012") /* primary output terpri */
|
||||
|
||||
@@ -173,6 +178,12 @@
|
||||
@@ -176,6 +181,13 @@
|
||||
void mm_list_work (char *what,int delimiter,char *name,long attributes);
|
||||
char *lasterror (void);
|
||||
|
||||
/* Global storage */
|
||||
|
||||
+
|
||||
+#ifdef DRAC_AUTH
|
||||
+#define DRACTIMEOUT 10*60 /* check every 10 minutes */
|
||||
+time_t lastdrac = 0; /* time of last drac check */
|
||||
+#define DRACTIMEOUT 10*60 /* check every 10 minutes */
|
||||
+time_t lastdrac = 0; /* time of last drac check */
|
||||
+extern char *getenv ();
|
||||
+#endif /* DRAC_AUTH */
|
||||
+
|
||||
char *version = "2001.315"; /* version number of this server */
|
||||
time_t alerttime = 0; /* time of last alert */
|
||||
time_t sysalerttime = 0; /* time of last system alert */
|
||||
@@ -1226,6 +1237,45 @@
|
||||
/* Global storage */
|
||||
|
||||
char *version = "2002.332"; /* version number of this server */
|
||||
@@ -1184,6 +1196,45 @@
|
||||
lasterror ());
|
||||
return;
|
||||
}
|
||||
|
28
mail/imap-uw/files/patch-src_mailutil_Makefile
Normal file
28
mail/imap-uw/files/patch-src_mailutil_Makefile
Normal file
@ -0,0 +1,28 @@
|
||||
--- src/mailutil/Makefile.Dist Mon Nov 18 16:41:46 2002
|
||||
+++ src/mailutil/Makefile Tue Nov 26 02:36:10 2002
|
||||
@@ -19,22 +19,15 @@
|
||||
|
||||
|
||||
C = ../c-client
|
||||
-CCLIENTLIB = $C/c-client.a
|
||||
SHELL = /bin/sh
|
||||
|
||||
# Get local definitions from c-client directory
|
||||
|
||||
-CC = `cat $C/CCTYPE`
|
||||
-CFLAGS = -I$C `cat $C/CFLAGS`
|
||||
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
|
||||
+CFLAGS+= -DNFSKLUDGE -I$(LOCALBASE)/include/c-client
|
||||
+LDFLAGS+= -L$(LOCALBASE)/lib -lc-client4
|
||||
|
||||
-mailutil: $(CCLIENTLIB) mailutil.o
|
||||
+mailutil: mailutil.o
|
||||
$(CC) $(CFLAGS) -o mailutil mailutil.o $(LDFLAGS)
|
||||
-
|
||||
-mailutil.o: $C/mail.h $C/misc.h $C/osdep.h
|
||||
-
|
||||
-$(CCLIENTLIB):
|
||||
- cd $C;make
|
||||
|
||||
clean:
|
||||
rm -f *.o mailutil
|
Loading…
Reference in New Issue
Block a user