Update to 0.8

PR:		35789
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Patrick Li 2002-03-11 21:24:17 +00:00
parent 91829143b8
commit 3838f0c5a0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55886
5 changed files with 46 additions and 16 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= tvision
PORTVERSION= 0.7
PORTREVISION= 2
PORTVERSION= 0.8
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.sigala.it/sergio/tvision/mysource/
@ -15,7 +14,8 @@ MASTER_SITE_SUBDIR= devel/lang/c++
MAINTAINER= ports@FreeBSD.org
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (tvision-0.7.tar.gz) = 5ed8022a2db99b65789f484a2530dddd
MD5 (tvision-0.8.tar.gz) = 7f99404877bb45b2510d43065cbefe6c

View File

@ -1,11 +0,0 @@
--- lib/dialogs.h.old Tue Jun 19 18:29:26 2001
+++ lib/dialogs.h Tue Jun 19 18:29:41 2001
@@ -407,7 +407,7 @@
TSItem( const char *aValue, TSItem *aNext )
{ value = newStr(aValue); next = aNext; }
- ~TSItem() { delete (void *)value; }
+ ~TSItem() { delete value; }
const char *value;
TSItem *next;

View File

@ -0,0 +1,41 @@
--- ltmain.sh.orig Sun Sep 23 00:01:27 2001
+++ ltmain.sh Fri Mar 8 04:56:54 2002
@@ -1043,14 +1043,14 @@
# These systems don't actually have a C library (as such)
test "X$arg" = "X-lc" && continue
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
test "X$arg" = "X-lc" && continue
;;
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -2441,7 +2441,7 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
;;
*)
@@ -4210,10 +4210,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -25,5 +25,5 @@ include/tvision/validate.h
include/tvision/views.h
lib/libtvision.a
lib/libtvision.so
lib/libtvision.so.0.7
lib/libtvision.so.0
@dirrm include/tvision