x11-toolkits/irrlicht: update to 1.8.5

- Pet portlint
- Make sure to remove bundled dependencies
- Strip library
- Remove no longer needed patch
This commit is contained in:
Dmitry Marakasov 2021-11-09 15:45:26 +03:00
parent 2a1dd2d5d5
commit 3837774622
4 changed files with 18 additions and 22 deletions

View File

@ -1,8 +1,7 @@
# Created by: Simon Barner <barner@gmx.de>
PORTNAME= irrlicht
PORTVERSION= 1.8.4
PORTREVISION= 3
PORTVERSION= 1.8.5
CATEGORIES= x11-toolkits graphics
MASTER_SITES= SF/${PORTNAME}/Irrlicht%20SDK/${PORTVERSION:R}/${PORTVERSION}/
@ -14,8 +13,8 @@ LICENSE_FILE= ${WRKSRC}/readme.txt
LIB_DEPENDS= libpng.so:graphics/png
DOS2UNIX_GLOB= Makefile *.cpp *.h *.txt
USES= alias cpe dos2unix gl gmake jpeg zip xorg
DOS2UNIX_GLOB= Makefile *.cpp *.h *.txt
USE_GL= gl
USE_XORG= x11 xxf86vm
USE_LDCONFIG= yes
@ -35,6 +34,11 @@ OPTIONS_DEFINE= DEBUG EXAMPLES
DEBUG_MAKE_ENV_OFF= NDEBUG=1
post-extract:
.for bundled in bzip2 jpeglib libpng zlib
@${RM} -r ${WRKSRC}/source/Irrlicht/${bundled}
.endfor
post-patch:
@${REINPLACE_CMD} -e '/#define.*_IRR_USE_NON_SYSTEM_JPEG_LIB_/ d' \
-e '/#define.*_IRR_USE_NON_SYSTEM_LIB_PNG_/ d' \
@ -43,6 +47,9 @@ post-patch:
-e '/#define.*_IRR_COMPILE_WITH_JOYSTICK_EVENTS_/ d' \
${WRKSRC}/include/IrrCompileConfig.h
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIrrlicht.so
post-install-EXAMPLES-on:
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} "${EXAMPLEDIRS}" \
${STAGEDIR}${EXAMPLESDIR} \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1471244398
SHA256 (irrlicht-1.8.4.zip) = f42b280bc608e545b820206fe2a999c55f290de5c7509a02bdbeeccc1bf9e433
SIZE (irrlicht-1.8.4.zip) = 27927144
TIMESTAMP = 1636380510
SHA256 (irrlicht-1.8.5.zip) = effb7beed3985099ce2315a959c639b4973aac8210f61e354475a84105944f3d
SIZE (irrlicht-1.8.5.zip) = 21827696

View File

@ -1,12 +1,13 @@
--- source/Irrlicht/Makefile.orig 2014-10-18 07:47:20 UTC
--- source/Irrlicht/Makefile.orig 2021-11-08 14:14:39 UTC
+++ source/Irrlicht/Makefile
@@ -56,23 +56,20 @@
@@ -58,23 +58,20 @@ BZIP2OBJ = bzip2/blocksort.o bzip2/huffman.o bzip2/crc
EXTRAOBJ =
LINKOBJ = $(IRRMESHOBJ) $(IRROBJ) $(IRRPARTICLEOBJ) $(IRRANIMOBJ) \
$(IRRVIDEOOBJ) $(IRRSWRENDEROBJ) $(IRRIOOBJ) $(IRROTHEROBJ) \
- $(IRRGUIOBJ) $(ZLIBOBJ) $(JPEGLIBOBJ) $(LIBPNGOBJ) $(LIBAESGM) \
- $(BZIP2OBJ) $(EXTRAOBJ)
+ $(IRRGUIOBJ) $(LIBAESGM) \
$(BZIP2OBJ) $(EXTRAOBJ)
+ $(EXTRAOBJ)
###############
#Compiler flags
@ -26,7 +27,7 @@
sharedlib sharedlib_osx: CXXFLAGS += -fPIC
sharedlib sharedlib_osx: CFLAGS += -fPIC
@@ -83,13 +80,13 @@
@@ -85,13 +82,13 @@ LIBSELECT=64
endif
#Linux specific options

View File

@ -1,12 +0,0 @@
--- source/Irrlicht/COpenGLExtensionHandler.h.orig 2014-10-18 08:53:44 UTC
+++ source/Irrlicht/COpenGLExtensionHandler.h
@@ -59,6 +59,9 @@
#endif
#include <GL/gl.h>
#include <GL/glx.h>
+ #ifndef PFNGLBLENDEQUATIONPROC
+ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #endif
#if defined(_IRR_OPENGL_USE_EXTPOINTER_)
#include "glext.h"
#undef GLX_ARB_get_proc_address // avoid problems with local glxext.h