Hiroki Tagato 2022-06-30 16:25:28 +09:00
parent 80b4f695a7
commit 381a17a767
6 changed files with 55 additions and 11 deletions

View File

@ -1,7 +1,6 @@
PORTNAME= scrcpy
DISTVERSIONPREFIX= v
DISTVERSION= 1.21
PORTREVISION= 1
DISTVERSION= 1.24
CATEGORIES= comms net
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${DISTVERSIONFULL}/:server
DISTFILES= ${SERVER_FILE}:server
@ -26,9 +25,12 @@ USE_SDL= sdl2
MESON_ARGS= -Dportable=false \
-Dprebuilt_server=${WRKSRC}/${SERVER_FILE}
PLIST_FILES= bin/scrcpy man/man1/scrcpy.1.gz \
PLIST_FILES= bin/scrcpy \
etc/bash_completion.d/scrcpy \
man/man1/scrcpy.1.gz \
share/icons/hicolor/256x256/apps/scrcpy.png \
${DATADIR}/scrcpy-server
${DATADIR}/scrcpy-server \
share/zsh/site-functions/_scrcpy
PORTDOCS= FAQ.md README.md
OPTIONS_DEFINE= DOCS

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1638420118
SHA256 (scrcpy-server-v1.21) = dbcccab523ee26796e55ea33652649e4b7af498edae9aa75e4d4d7869c0ab848
SIZE (scrcpy-server-v1.21) = 40067
SHA256 (Genymobile-scrcpy-v1.21_GH0.tar.gz) = 76e16a894bdb483b14b7ae7dcc1be8036ec17924dfab070cf0cb3b47653a6822
SIZE (Genymobile-scrcpy-v1.21_GH0.tar.gz) = 360667
TIMESTAMP = 1656485534
SHA256 (scrcpy-server-v1.24) = ae74a81ea79c0dc7250e586627c278c0a9a8c5de46c9fb5c38c167fb1a36f056
SIZE (scrcpy-server-v1.24) = 41159
SHA256 (Genymobile-scrcpy-v1.24_GH0.tar.gz) = e3054ad453ac577b941f8df0eabc94e842affc6e1d10ba8d21cededfa2eacc73
SIZE (Genymobile-scrcpy-v1.24_GH0.tar.gz) = 424970

View File

@ -1,6 +1,6 @@
--- app/meson.build.orig 2021-12-02 04:47:49 UTC
--- app/meson.build.orig 2022-04-28 18:46:28 UTC
+++ app/meson.build
@@ -44,8 +44,8 @@ src = [
@@ -46,8 +46,8 @@ src = [
conf = configuration_data()
@ -11,3 +11,12 @@
conf.set('_GNU_SOURCE', true)
if host_machine.system() == 'windows'
@@ -230,7 +230,7 @@ install_data('data/icon.png',
install_data('data/zsh-completion/_scrcpy',
install_dir: 'share/zsh/site-functions')
install_data('data/bash-completion/scrcpy',
- install_dir: 'share/bash-completion/completions')
+ install_dir: 'etc/bash_completion.d')
### TESTS

View File

@ -0,0 +1,11 @@
--- app/src/usb/aoa_hid.h.orig 2022-06-30 04:28:03 UTC
+++ app/src/usb/aoa_hid.h
@@ -4,7 +4,7 @@
#include <stdint.h>
#include <stdbool.h>
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include "usb.h"
#include "util/acksync.h"

View File

@ -0,0 +1,11 @@
--- app/src/usb/usb.h.orig 2022-06-30 04:29:07 UTC
+++ app/src/usb/usb.h
@@ -4,7 +4,7 @@
#include "common.h"
#include <stdbool.h>
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include "util/thread.h"

View File

@ -0,0 +1,11 @@
--- app/src/version.c.orig 2022-06-30 04:29:39 UTC
+++ app/src/version.c
@@ -7,7 +7,7 @@
# include <libavdevice/avdevice.h>
#endif
#ifdef HAVE_USB
-# include <libusb-1.0/libusb.h>
+# include <libusb.h>
#endif
void