Update to 3.7

PR:		32103
Submitted by:	maintainer
This commit is contained in:
David W. Chapman Jr. 2001-11-24 01:56:44 +00:00
parent b5d6829c1c
commit 37f4f657e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50446
5 changed files with 35 additions and 81 deletions

View File

@ -6,16 +6,18 @@
#
PORTNAME= pcre
PORTVERSION= 3.4
PORTVERSION= 3.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= dom@happygiraffe.net
USE_LIBTOOL= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
MAN1= pcregrep.1 pcretest.1
MAN3= pcre.3 pcreposix.3
MAN1= pcregrep.1
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (pcre-3.4.tar.gz) = 75918d0111f592097939a7b8c490dcd0
MD5 (pcre-3.7.tar.bz2) = 90a6efb498fa13e788b2963715bb362a

View File

@ -1,75 +0,0 @@
--- Makefile.in.orig Tue Aug 22 05:05:43 2000
+++ Makefile.in Sun Dec 3 19:27:54 2000
@@ -43,7 +43,7 @@
# is set to "a" instead of "la", which causes the shared libraries not to be
# installed.
-LIBTOOL = @LIBTOOL@
+LIBTOOL = $(LOCALBASE)/bin/libtool
LIBSUFFIX = @LIBSUFFIX@
# These are the version numbers for the shared libraries
@@ -56,8 +56,10 @@
# A copy of install-sh is in this distribution and is used by default. #
#---------------------------------------------------------------------------#
-INSTALL = ./install-sh -c
-INSTALL_DATA = ${INSTALL} -m 644
+INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
+INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
+INSTALL_DATA = ${BSD_INSTALL_DATA}
+INSTALL_MAN = ${BSD_INSTALL_MAN}
#---------------------------------------------------------------------------#
@@ -78,7 +80,7 @@
OBJ = maketables.o get.o study.o pcre.o
LOBJ = maketables.lo get.lo study.lo pcre.lo
-all: libtool libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX) pcretest pcregrep
+all: libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX) pcretest pcregrep
libtool: config.guess config.sub ltconfig ltmain.sh
@if test "$(LIBTOOL)" = "./libtool"; then \
@@ -112,7 +114,7 @@
@echo '--- Building shared library: libpcre'
@echo ' '
-rm -f libpcre.la
- ./libtool $(CC) -version-info '$(PCRELIBVERSION)' -o libpcre.la -rpath $(LIBDIR) $(LOBJ)
+ $(LIBTOOL) $(CC) -version-info '$(PCRELIBVERSION)' -o libpcre.la -rpath $(LIBDIR) $(LOBJ)
libpcreposix.a: pcreposix.o
@echo ' '
@@ -127,7 +129,7 @@
@echo '--- Building shared library: libpcreposix'
@echo ' '
-rm -f libpcreposix.la
- ./libtool $(CC) -version-info '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la -rpath $(LIBDIR) pcreposix.lo
+ $(LIBTOOL) $(CC) -version-info '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la -rpath $(LIBDIR) pcreposix.lo
pcre.o: chartables.c pcre.c pcre.h internal.h config.h Makefile
$(LIBTOOL) $(CC) -c $(CFLAGS) $(UTF8) pcre.c
@@ -163,9 +165,9 @@
$(LIBTOOL) $(INSTALL_DATA) libpcreposix.$(LIBSUFFIX) $(DESTDIR)/$(LIBDIR)/libpcreposix.$(LIBSUFFIX)
$(INSTALL_DATA) pcre.h $(DESTDIR)/$(INCDIR)/pcre.h
$(INSTALL_DATA) pcreposix.h $(DESTDIR)/$(INCDIR)/pcreposix.h
- $(INSTALL_DATA) doc/pcre.3 $(DESTDIR)/$(MANDIR)/man3/pcre.3
- $(INSTALL_DATA) doc/pcreposix.3 $(DESTDIR)/$(MANDIR)/man3/pcreposix.3
- $(INSTALL_DATA) doc/pcregrep.1 $(DESTDIR)/$(MANDIR)/man1/pcregrep.1
+ $(INSTALL_MAN) doc/pcre.3 $(DESTDIR)/$(MANDIR)/man3/pcre.3
+ $(INSTALL_MAN) doc/pcreposix.3 $(DESTDIR)/$(MANDIR)/man3/pcreposix.3
+ $(INSTALL_MAN) doc/pcregrep.1 $(DESTDIR)/$(MANDIR)/man1/pcregrep.1
@if test "$(LIBTOOL)" = "./libtool"; then \
echo ' '; \
echo '--- Rebuilding pcregrep to use installed shared library ---'; \
@@ -175,8 +177,8 @@
echo $(CC) $(CFLAGS) -o pcretest pcretest.o -L$(DESTDIR)/$(LIBDIR) -lpcre -lpcreposix; \
$(CC) $(CFLAGS) -o pcretest pcretest.o -L$(DESTDIR)/$(LIBDIR) -lpcre -lpcreposix; \
fi
- $(INSTALL) pcregrep $(DESTDIR)/$(BINDIR)/pcregrep
- $(INSTALL) pcre-config $(DESTDIR)/$(BINDIR)/pcre-config
+ $(INSTALL_PROGRAM) .libs/pcregrep $(DESTDIR)/$(BINDIR)/pcregrep
+ $(INSTALL_SCRIPT) pcre-config $(DESTDIR)/$(BINDIR)/pcre-config
# We deliberately omit dftables and chartables.c from 'make clean'; once made
# chartables.c shouldn't change, and if people have edited the tables by hand,

View File

@ -0,0 +1,28 @@
$FreeBSD$
--- ltmain.sh.orig Fri Aug 17 03:16:16 2001
+++ ltmain.sh Fri Nov 16 17:54:42 2001
@@ -2408,6 +2408,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
@@ -4175,10 +4178,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,12 +1,11 @@
bin/pcre-config
bin/pcregrep
bin/pcretest
include/pcre.h
include/pcreposix.h
lib/libpcre.a
lib/libpcre.la
lib/libpcre.so
lib/libpcre.so.0
lib/libpcreposix.a
lib/libpcreposix.la
lib/libpcreposix.so
lib/libpcreposix.so.0