Enable build on FreeBSD7

Submitted by: Arseny Nasokin
This commit is contained in:
Volker Stolz 2006-05-14 13:02:28 +00:00
parent a7c5a86c67
commit 37a907f6f8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=162321
3 changed files with 35 additions and 4 deletions

View File

@ -40,8 +40,4 @@ do-configure:
BROKEN= "Build fails on alpha"
.endif
.if ${OSVERSION} >= 700000
BROKEN= "Configure needs updating"
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,10 @@
--- GCC/gcc/config.gcc.orig Thu Jan 22 23:50:26 2004
+++ GCC/gcc/config.gcc Sat May 13 16:27:18 2006
@@ -475,6 +475,7 @@
*-*-freebsd4 | *-*-freebsd[4].*) fbsd_tm_file="freebsd4.h";;
*-*-freebsd5 | *-*-freebsd[5].*) fbsd_tm_file="freebsd5.h";;
*-*-freebsd6 | *-*-freebsd[6].*) fbsd_tm_file="freebsd6.h";;
+ *-*-freebsd7 | *-*-freebsd[7].*) fbsd_tm_file="freebsd7.h";;
*) echo 'Please update *-*-freebsd* in gcc/config.gcc'; exit 1;;
esac
tmake_file="t-slibgcc-elf-ver t-freebsd"

View File

@ -0,0 +1,25 @@
--- /dev/null Sat May 13 16:25:00 2006
+++ GCC/gcc/config/freebsd7.h Sat May 13 16:28:29 2006
@@ -0,0 +1,22 @@
+/* FreeBSD version number setting for FreeBSD 6.x systems.
+ Copyright (C) 2001 Free Software Foundation, Inc.
+ Contributed by David E. O'Brien <obrien@FreeBSD.org> and BSDi.
+
+This file is part of GNU CC.
+
+GNU CC is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 2, or (at your option)
+any later version.
+
+GNU CC is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with GNU CC; see the file COPYING. If not, write to
+the Free Software Foundation, 59 Temple Place - Suite 330,
+Boston, MA 02111-1307, USA. */
+
+#define FBSD_MAJOR 7