- Update to 2.0.b10

PR:		107537
Submitted by:	trasz (Maintainer)
This commit is contained in:
Martin Wilke 2007-01-06 10:21:19 +00:00
parent 9e47ea441a
commit 376901c615
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=181620
5 changed files with 157 additions and 92 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= ardour
DISTVERSION= 2.0beta9
DISTVERSION= 2.0beta10
CATEGORIES= audio
MASTER_SITES= http://ardour.org/files/releases/
@ -22,12 +22,15 @@ LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
gnomecanvasmm-2.6:${PORTSDIR}/graphics/libgnomecanvasmm26 \
sqlite3:${PORTSDIR}/databases/sqlite3 \
lo.6:${PORTSDIR}/audio/liblo
BUILD_DEPENDS= ${LOCALBASE}/lib/libSoundTouch.a:${PORTSDIR}/audio/soundtouch
USE_SCONS= yes
SCONS_ENV+= SYSLIBS=yes PREFIX=${PREFIX}
SCONS_ENV+= SYSLIBS=yes PREFIX=${PREFIX} NLS=yes
USE_BZIP2= yes
USE_GNOME= gtk20 libxslt libgnomecanvas
USE_GNOME= gtk20 libxslt libgnomecanvas intltool
USE_GETTEXT= yes
USE_LDCONFIG= ${PREFIX}/lib/ardour2 ${PREFIX}/lib/ardour2/surfaces
TEMPLATESDIR= ${PREFIX}/share/ardour2/templates
.include <bsd.port.pre.mk>
@ -42,7 +45,7 @@ BROKEN= Does not compile on 4.x and 5.x
post-patch:
${REINPLACE_CMD} -e "s|%%CFLAGS%%|${CFLAGS}|" ${WRKSRC}/SConstruct
${REINPLACE_CMD} -e "s|alsa_pcm|oss|g" ${WRKSRC}/templates/*
${REINPLACE_CMD} -e "s|alsa_pcm|oss|g" ${WRKSRC}/templates/*.template
post-install:
${CHOWN} -R 0:0 ${PREFIX}/lib/ardour2/
@ -51,8 +54,7 @@ post-install:
${CHMOD} -R a+rX ${PREFIX}/etc/ardour2/
${CHOWN} -R 0:0 ${PREFIX}/share/ardour2/
${CHMOD} -R a+rX ${PREFIX}/share/ardour2/
${MKDIR} ${EXAMPLESDIR}
${MKDIR} ${EXAMPLESDIR}/templates
${INSTALL_DATA} ${WRKSRC}/templates/*.template ${EXAMPLESDIR}/templates/
${MKDIR} ${TEMPLATESDIR}
${INSTALL_DATA} ${WRKSRC}/templates/*.template ${TEMPLATESDIR}/
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (ardour-2.0beta9.tar.bz2) = c34bba4984e7d651c5dcc724282a447a
SHA256 (ardour-2.0beta9.tar.bz2) = 87da58c2025114d2949b8f9829b924da6ce0fc8c0002263a7389fc3bb6c24e78
SIZE (ardour-2.0beta9.tar.bz2) = 2589830
MD5 (ardour-2.0beta10.tar.bz2) = 47ea107f04233f82d16c368bcec75915
SHA256 (ardour-2.0beta10.tar.bz2) = 8683aa9f0e7e90d90e5156e68040c728e71bff82f00819d7a07be37fd32fdafa
SIZE (ardour-2.0beta10.tar.bz2) = 2676171

View File

@ -1,77 +1,15 @@
--- SConstruct.orig Thu Nov 30 18:48:18 2006
+++ SConstruct Thu Dec 7 20:11:33 2006
--- SConstruct.orig Wed Jan 3 20:17:56 2007
+++ SConstruct Thu Jan 4 22:26:17 2007
@@ -38,7 +38,7 @@
BoolOption('FPU_OPTIMIZATION', 'Build runtime checked assembler code', 1),
BoolOption('LIBLO', 'Compile with support for liblo library', 1),
BoolOption('NLS', 'Set to turn on i18n support', 1),
- PathOption('PREFIX', 'Set the install "prefix"', '/usr/local'),
+ PathOption('PREFIX', 'Set the install "prefix"', '/usr/local', PathOption.PathIsDirCreate),
BoolOption('SURFACES', 'Build support for control surfaces', 0),
BoolOption('SURFACES', 'Build support for control surfaces', 1),
BoolOption('SYSLIBS', 'USE AT YOUR OWN RISK: CANCELS ALL SUPPORT FROM ARDOUR AUTHORS: Use existing system versions of various libraries instead of internal ones', 0),
BoolOption('VERSIONED', 'Add revision information to ardour/gtk executable name inside the build directory', 0),
@@ -480,9 +480,6 @@
libraries['boost'] = LibraryInfo ()
conf = Configure (libraries['boost'])
-if conf.CheckHeader ('boost/shared_ptr.hpp', language='CXX') == False:
- print "Boost header files do not appear to be installed."
- sys.exit (1)
libraries['boost'] = conf.Finish ()
@@ -493,9 +490,6 @@
libraries['lo'] = LibraryInfo ()
conf = Configure (libraries['lo'])
- if conf.CheckLib ('lo', 'lo_server_new') == False:
- print "liblo does not appear to be installed."
- sys.exit (1)
libraries['lo'] = conf.Finish ()
@@ -526,7 +520,7 @@
libraries['sysmidi'] = LibraryInfo (LIBS='asound')
env['SYSMIDI'] = 'ALSA Sequencer'
subst_dict['%MIDITAG%'] = "seq"
- subst_dict['%MIDITYPE%'] = "alsa/sequencer"
+ subst_dict['%MIDITYPE%'] = "oss/sequencer"
elif conf.CheckCHeader('/System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h'):
# this line is needed because scons can't handle -framework in ParseConfig() yet.
libraries['sysmidi'] = LibraryInfo (LINKFLAGS= '-framework CoreMIDI -framework CoreFoundation -framework CoreAudio -framework CoreServices -framework AudioUnit -framework AudioToolbox -bind_at_load')
@@ -534,8 +528,10 @@
subst_dict['%MIDITAG%'] = "ardour"
subst_dict['%MIDITYPE%'] = "coremidi"
else:
- print "It appears you don't have the required MIDI libraries installed. For Linux this means you are missing the development package for ALSA libraries."
- sys.exit (1)
+ libraries['sysmidi'] = LibraryInfo (LIBS='lo')
+ env['SYSMIDI'] = 'nie ma'
+ subst_dict['%MIDITAG%'] = "nie ma"
+ subst_dict['%MIDITYPE%'] = "nie ma"
env = conf.Finish()
@@ -568,14 +564,17 @@
# libraries['libglademm'].ParseConfig ('pkg-config --cflags --libs libglademm-2.4')
# libraries['flowcanvas'] = LibraryInfo(LIBS='flowcanvas', LIBPATH='#/libs/flowcanvas', CPPPATH='#libs/flowcanvas')
- libraries['soundtouch'] = LibraryInfo()
- libraries['soundtouch'].ParseConfig ('pkg-config --cflags --libs soundtouch-1.0')
+ # We cannot use audio/soundtouch, because it doesn't install pkginfo file.
+ libraries['soundtouch'] = LibraryInfo(LIBS='soundtouch',
+ LIBPATH='#libs/soundtouch',
+ CPPPATH=['#libs', '#libs/soundtouch'])
libraries['appleutility'] = LibraryInfo(LIBS='libappleutility',
LIBPATH='#libs/appleutility',
CPPPATH='#libs/appleutility')
coredirs = [
+ 'libs/soundtouch',
'templates'
]
@@ -858,12 +857,7 @@
@@ -655,12 +655,7 @@
# prepend boiler plate optimization flags
#
@ -85,7 +23,94 @@
if env['DEBUG'] == 1:
env.Append(CCFLAGS=" ".join (debug_flags))
@@ -944,8 +938,8 @@
@@ -741,9 +736,9 @@
prep_libcheck(env, libraries['lo'])
conf = Configure (libraries['lo'])
- if conf.CheckLib ('lo', 'lo_server_new') == False:
- print "liblo does not appear to be installed."
- sys.exit (1)
+# if conf.CheckLib ('lo', 'lo_server_new') == False:
+# print "liblo does not appear to be installed."
+# sys.exit (1)
libraries['lo'] = conf.Finish ()
@@ -783,8 +778,10 @@
subst_dict['%MIDITAG%'] = "ardour"
subst_dict['%MIDITYPE%'] = "coremidi"
else:
- print "It appears you don't have the required MIDI libraries installed. For Linux this means you are missing the development package for ALSA libraries."
- sys.exit (1)
+ libraries['sysmidi'] = LibraryInfo (LIBS='lo')
+ env['SYSMIDI'] = 'none'
+ subst_dict['%MIDITAG%'] = "none"
+ subst_dict['%MIDITYPE%'] = "none"
env = conf.Finish()
@@ -1003,33 +1000,33 @@
# i18n support
#
-conf = Configure (env)
-if env['NLS']:
- nls_error = 'This system is not configured for internationalized applications. An english-only version will be built:'
- print 'Checking for internationalization support ...'
- have_gettext = conf.TryAction(Action('xgettext --version'))
- if have_gettext[0] != 1:
- nls_error += ' No xgettext command.'
- env['NLS'] = 0
- else:
- print "Found xgettext"
-
- have_msgmerge = conf.TryAction(Action('msgmerge --version'))
- if have_msgmerge[0] != 1:
- nls_error += ' No msgmerge command.'
- env['NLS'] = 0
- else:
- print "Found msgmerge"
-
- if not conf.CheckCHeader('libintl.h'):
- nls_error += ' No libintl.h.'
- env['NLS'] = 0
-
- if env['NLS'] == 0:
- print nls_error
- else:
- print "International version will be built."
-env = conf.Finish()
+#conf = Configure (env)
+#if env['NLS']:
+# nls_error = 'This system is not configured for internationalized applications. An english-only version will be built:'
+# print 'Checking for internationalization support ...'
+# have_gettext = conf.TryAction(Action('xgettext --version'))
+# if have_gettext[0] != 1:
+# nls_error += ' No xgettext command.'
+# env['NLS'] = 0
+# else:
+# print "Found xgettext"
+#
+# have_msgmerge = conf.TryAction(Action('msgmerge --version'))
+# if have_msgmerge[0] != 1:
+# nls_error += ' No msgmerge command.'
+# env['NLS'] = 0
+# else:
+# print "Found msgmerge"
+#
+# if not conf.CheckCHeader('libintl.h'):
+# nls_error += ' No libintl.h.'
+# env['NLS'] = 0
+#
+# if env['NLS'] == 0:
+# print nls_error
+# else:
+# print "International version will be built."
+#env = conf.Finish()
if env['NLS'] == 1:
env.Append(CCFLAGS="-DENABLE_NLS")
@@ -1046,8 +1043,8 @@
subst_dict['%JACK_INPUT%'] = "coreaudio:Built-in Audio:in"
subst_dict['%JACK_OUTPUT%'] = "coreaudio:Built-in Audio:out"
else:

View File

@ -1,12 +1,11 @@
--- libs/ardour/io.cc.orig Thu Dec 7 12:58:12 2006
+++ libs/ardour/io.cc Thu Dec 7 13:02:49 2006
@@ -2485,7 +2485,8 @@
--- libs/ardour/io.cc.orig Thu Jan 4 22:40:34 2007
+++ libs/ardour/io.cc Thu Jan 4 22:41:09 2007
@@ -2498,7 +2498,7 @@
} else {
// do falloff
new_peak = _visible_peak_power[n] - Config->get_meter_falloff();
// do falloff, the config value is in dB/sec, we get updated at 100/sec currently (should be a var somewhere)
new_peak = _visible_peak_power[n] - (Config->get_meter_falloff() * 0.01f);
- _visible_peak_power[n] = max (new_peak, -INFINITY);
+ // libs/ardour/io.cc:2488: error: no matching function for call to `max(float&, double)'
+ _visible_peak_power[n] = max (new_peak, (float)-INFINITY);
+ _visible_peak_power[n] = max ((double)new_peak, -INFINITY);
}
}
}

View File

@ -1,5 +1,4 @@
bin/ardour2
lib/ardour2/libsoundtouch.so
lib/ardour2/libsndfile-ardour.so
lib/ardour2/libpbd.so
lib/ardour2/libmidi++.so
@ -9,6 +8,8 @@ lib/ardour2/ardour.bin
lib/ardour2/libardour_cp.so
lib/ardour2/surfaces/libardour_genericmidi.so
@dirrm lib/ardour2/surfaces
lib/ardour2/engines/libclearlooks.so
@dirrm lib/ardour2/engines
@dirrm lib/ardour2
etc/ardour2/ardour2_ui.rc
etc/ardour2/ardour.menus
@ -93,12 +94,50 @@ share/ardour2/icons/nudge_left.png
share/ardour2/icons/transport_record.png
share/ardour2/icons/crossfade_out_slow-fade.png
share/ardour2/icons/nudge_right.png
share/ardour2/icons/ardour_icon_22px.png
share/ardour2/icons/zoom_smaller_out.png
share/ardour2/icons/zoom_small_out.png
share/ardour2/icons/ardour_icon_48px.png
share/ardour2/icons/zoom_smaller_in.png
share/ardour2/icons/ardour_icon_32px.png
share/ardour2/icons/zoom_small_full.png
share/ardour2/icons/zoom_small_in.png
share/ardour2/icons/zoom_smaller_full.png
share/ardour2/icons/ardour_icon_16px.png
@dirrm share/ardour2/icons
share/ardour2/templates/16 Tracks.template
share/ardour2/templates/2 Track.template
share/ardour2/templates/32 Tracks.template
share/ardour2/templates/4 Tracks.template
share/ardour2/templates/8 Tracks.template
@dirrm share/ardour2/templates
@dirrm share/ardour2
%%EXAMPLESDIR%%/templates/16 Tracks.template
%%EXAMPLESDIR%%/templates/2 Track.template
%%EXAMPLESDIR%%/templates/32 Tracks.template
%%EXAMPLESDIR%%/templates/4 Tracks.template
%%EXAMPLESDIR%%/templates/8 Tracks.template
@dirrm %%EXAMPLESDIR%%/templates
@dirrm %%EXAMPLESDIR%%
share/locale/it_IT/LC_MESSAGES/libardour.mo
share/locale/sv_SE/LC_MESSAGES/libardour.mo
share/locale/el_GR/LC_MESSAGES/libardour.mo
share/locale/ru_RU/LC_MESSAGES/libardour.mo
share/locale/el_GR/LC_MESSAGES/libgtkmm2ext.mo
share/locale/ru_RU/LC_MESSAGES/libgtkmm2ext.mo
share/locale/pt_BR/LC_MESSAGES/libgtkmm2ext.mo
share/locale/es_ES/LC_MESSAGES/libgtkmm2ext.mo
share/locale/it_IT/LC_MESSAGES/gtk_ardour.mo
share/locale/sv_SE/LC_MESSAGES/gtk_ardour.mo
share/locale/el_GR/LC_MESSAGES/gtk_ardour.mo
share/locale/fr_FR/LC_MESSAGES/gtk_ardour.mo
share/locale/ru_RU/LC_MESSAGES/gtk_ardour.mo
share/locale/pt_BR/LC_MESSAGES/gtk_ardour.mo
share/locale/es_ES/LC_MESSAGES/gtk_ardour.mo
share/locale/de_DE/LC_MESSAGES/gtk_ardour.mo
share/locale/pt_PT/LC_MESSAGES/gtk_ardour.mo
@dirrmtry share/locale/it_IT/LC_MESSAGES
@dirrmtry share/locale/it_IT
@dirrmtry share/locale/sv_SE/LC_MESSAGES
@dirrmtry share/locale/sv_SE
@dirrmtry share/locale/el_GR/LC_MESSAGES
@dirrmtry share/locale/el_GR
@dirrmtry share/locale/ru_RU/LC_MESSAGES
@dirrmtry share/locale/ru_RU
@dirrmtry share/locale/fr_FR/LC_MESSAGES
@dirrmtry share/locale/fr_FR
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE