Update to version 3.8.2

PR:		ports/72525
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2004-10-12 12:46:56 +00:00
parent 0dc1b60e2c
commit 374e07ba75
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118994
4 changed files with 14 additions and 36 deletions

View File

@ -7,22 +7,23 @@
#
PORTNAME= codeworker
PORTVERSION= 3.3
PORTREVISION= 1
PORTVERSION= 3.8.2
CATEGORIES= devel
MASTER_SITES= http://codeworker.free.fr/downloads/
DISTNAME= CodeWorker_SRC${PORTVERSION:S/./_/}
DISTNAME= CodeWorker_SRC${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
COMMENT= A parsing tool and a source code generator
PLIST_FILES= bin/codeworker
EXTRACT_BEFORE_ARGS= -qo -aa
WRKSRC= ${WRKDIR}/CodeWorker${PORTVERSION:S/./_/g}
USE_ZIP= yes
USE_REINPLACE= yes
NO_WRKSUBDIR= yes
LDFLAGS+= -lcompat
USE_GMAKE= yes
MAKE_ENV= LDFLAGS="${LDFLAGS}"
MAKE_ARGS= CC="${CXX}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" LFLAGS="-lm"
PLIST_FILES= bin/codeworker
.include <bsd.port.pre.mk>
@ -30,11 +31,9 @@ MAKE_ENV= LDFLAGS="${LDFLAGS}"
BROKEN= "Does not compile on !i386"
.endif
post-patch:
@${REINPLACE_CMD} -e "s|^CXXFLAGS|#CXXFLAGS|g" \
-e s"|LFLAGS|LDFLAGS|" -e "s|^LDFLAGS|#LDFLAGS|" \
-e "s|CC|CXX|g" -e "s|^CXX|#CXX|g" ${WRKSRC}/Makefile
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s| ||"
.if ${OSVERSION} < 500035
CFLAGS+= -fpermissive
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/codeworker ${PREFIX}/bin

View File

@ -1,2 +1,2 @@
MD5 (CodeWorker_SRC3_3.zip) = 1a2d88de860652e46356ba37bf9ea341
SIZE (CodeWorker_SRC3_3.zip) = 1982777
MD5 (CodeWorker_SRC3_8_2.zip) = c7294abc279b3e4990e460770ff22698
SIZE (CodeWorker_SRC3_8_2.zip) = 1659058

View File

@ -1,10 +0,0 @@
--- DtaPatternScript.h.orig Sun Jan 25 21:36:50 2004
+++ DtaPatternScript.h Sun Jan 25 21:40:17 2004
@@ -24,6 +24,7 @@
#include "DtaScript.h"
#include <map>
+#include <memory>
namespace CodeWorker {
#ifndef EXECUTE_FUNCTION_TYPE

View File

@ -1,11 +0,0 @@
--- ScpStream.h.orig Sun Jan 25 21:34:17 2004
+++ ScpStream.h Sun Jan 25 21:34:40 2004
@@ -34,6 +34,8 @@
#include <map>
#include <set>
+#include <ctime>
+
namespace CodeWorker {
#ifdef IN