Support stage

Fix build with clang
This commit is contained in:
Baptiste Daroussin 2014-04-07 08:16:47 +00:00
parent df840c4fe1
commit 374a765ad7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=350429
3 changed files with 26 additions and 5 deletions

View File

@ -15,9 +15,8 @@ LIB_DEPENDS= libcddb.so:${PORTSDIR}/audio/libcddb \
libtag.so:${PORTSDIR}/audio/taglib
USES= pkgconfig
NO_STAGE= yes
MAN1= taglookup.1
PLIST_FILES= bin/taglookup
PLIST_FILES= bin/taglookup \
man/man1/taglookup.1.gz
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- ./Makefile.orig 2007-10-29 08:02:54.000000000 -0400
+++ ./Makefile 2011-03-18 18:59:23.000000000 -0400
--- ./Makefile.orig 2007-10-29 13:02:54.000000000 +0100
+++ ./Makefile 2014-04-07 10:15:45.329720325 +0200
@@ -4,7 +4,7 @@
TAGLIB_INCLUDE = `taglib-config --cflags`
TAGLIB_LIBRARY = `taglib-config --libs`
@ -9,3 +9,14 @@
CPPFLAGS = -Wall $(TAGLIB_INCLUDE) $(LIBCDDB_INCLUDE) -c
LDFLAGS = $(TAGLIB_LIBRARY) $(LIBCDDB_LIBRARY)
@@ -18,8 +18,8 @@
all: $(EXE)
install: $(EXE)
- $(INSTALL) -c -o root -g wheel -m 644 taglookup.1 $(PREFIX)/man/man1/taglookup.1
- $(INSTALL) -c -o root -g wheel -m 755 $(EXE) $(PREFIX)/bin/taglookup
+ $(INSTALL) -c -m 644 taglookup.1 $(DESTDIR)$(PREFIX)/man/man1/taglookup.1
+ $(INSTALL) -c -m 755 $(EXE) $(DESTDIR)$(PREFIX)/bin/taglookup
$(EXE): $(OBJ)
$(CPP) $(LDFLAGS) $(OBJ) -o $(EXE)

View File

@ -0,0 +1,11 @@
--- ./command_line.cpp.orig 2007-10-01 21:09:46.000000000 +0200
+++ ./command_line.cpp 2014-04-07 10:14:49.462722923 +0200
@@ -105,7 +105,7 @@
bool CommandLineArgumentsParser::parsePort()
{
- int port = (int)std::strtol(ct_.c_str(), (char**)NULL, 10);
+ int port = (int)strtol(ct_.c_str(), (char**)NULL, 10);
if(port > 32767 || port <= 0)
{