- Update to 0.24.0

PR:		125693
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2008-07-17 23:12:29 +00:00
parent 24586440f7
commit 36e9bd321b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=216996
10 changed files with 49 additions and 126 deletions

View File

@ -6,44 +6,39 @@
#
PORTNAME= mifluz
PORTVERSION= 0.23.0
PORTREVISION= 4
PORTVERSION= 0.24.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library to build and query a full text inverted index
USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} --without-unac
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget
USE_BISON= build
USE_ICONV= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --without-unac
USE_LDCONFIG= yes
MAN1= htdb_dump.1 htdb_stat.1 htdb_load.1 mifluzdump.1 mifluzload.1 \
mifluzsearch.1 mifluzdict.1
MAN3= WordContext.3 WordList.3 WordDict.3 WordListOne.3 WordKey.3 \
WordKeyInfo.3 WordType.3 WordDBInfo.3 WordRecordInfo.3 \
WordRecord.3 WordReference.3 WordCursor.3 WordCursorOne.3 \
WordMonitor.3 Configuration.3 mifluz.3
INFO= mifluz
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= htdb_dump.1 htdb_stat.1 htdb_load.1 mifluz-config.1 \
mifluzdump.1 mifluzload.1 mifluzsearch.1 mifluzdict.1
MAN3= WordContext.3 WordList.3 WordDict.3 WordListOne.3 \
WordKey.3 WordKeyInfo.3 WordType.3 WordDBInfo.3 \
WordRecordInfo.3 WordRecord.3 WordReference.3 WordCursor.3 \
WordCursorOne.3 WordMonitor.3 Configuration.3 mifluz.3
INFO= mifluz
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} 's|-D_THREAD_SAFE -pthread|${PTHREAD_CFLAGS}|g ; \
s|-lpthread|${PTHREAD_LIBS}|g ;\
s|echo aout|echo elf|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-D_THREAD_SAFE -pthread|${PTHREAD_CFLAGS}|g' \
${WRKSRC}/configure
post-install:
@${SED} -e "s:%%PREFIX%%:${PREFIX}:g" ${PKGDIR}/pkg-message > \
${PKGMESSAGE}
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (mifluz-0.23.0.tar.gz) = 653c6629daf1881a07a1eece495bf972
SHA256 (mifluz-0.23.0.tar.gz) = b65adda2df55c56ebf0f51acaec7f7d3a25e3b1e4884c5fcf9b8c0bd8fa05f72
SIZE (mifluz-0.23.0.tar.gz) = 1290174
MD5 (mifluz-0.24.0.tar.gz) = b01cfe66d7d663e78d1e9048ea45766f
SHA256 (mifluz-0.24.0.tar.gz) = 41d08773637af180ef3afb39ac2e24c0dd4f0d4f1e4aa736b0909ecf28680c3b
SIZE (mifluz-0.24.0.tar.gz) = 1556772

View File

@ -0,0 +1,16 @@
--- clib/strcasestr2.c.orig 2008-06-05 00:01:39.000000000 +0900
+++ clib/strcasestr2.c 2008-07-11 22:26:07.000000000 +0900
@@ -12,6 +12,8 @@
#include "config.h"
#endif /* HAVE_CONFIG_H */
+#ifndef HAVE_STRCASESTR
+
#include <ctype.h>
#include <string.h>
@@ -32,3 +34,4 @@
}
return 0;
}
+#endif /* HAVE_STRCASESTR */

View File

@ -1,58 +0,0 @@
--- configure.orig 2001-07-23 14:55:39.000000000 +0200
+++ configure 2007-11-22 11:39:14.000000000 +0100
@@ -5982,6 +5982,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -6322,7 +6323,7 @@
LIBS="-lipc $LIBS";;
bsdi*) optimize_def="-O2";;
freebsd*) optimize_def="-O2"
- CPPFLAGS="-D_THREAD_SAFE -pthread $CPPFLAGS";;
+ CPPFLAGS=" $CPPFLAGS";;
hpux*) CPPFLAGS="-D_REENTRANT $CPPFLAGS";;
irix*) optimize_def="-O2"
CPPFLAGS="-D_SGI_MP_SOURCE $CPPFLAGS";;
@@ -7851,7 +7852,7 @@
fi
if test "$db_cv_mutex" = no; then
-LIBS="-lpthread $LIBS"
+LIBS="-pthread $LIBS"
if test "$cross_compiling" = yes; then
{ echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
else
@@ -8354,7 +8355,7 @@
#define HAVE_MUTEX_PTHREADS 1
EOF
;;
-POSIX/pthreads/library) LIBS="-lpthread $LIBS"
+POSIX/pthreads/library) LIBS="-pthread $LIBS"
cat >> confdefs.h <<\EOF
#define HAVE_MUTEX_PTHREAD 1
EOF
@@ -9702,16 +9703,16 @@
fi
done
-ac_safe=`echo "fstream.h" | sed 'y%./+-%__p_%'`
-echo $ac_n "checking for fstream.h""... $ac_c" 1>&6
-echo "configure:9708: checking for fstream.h" >&5
+ac_safe=`echo "fstream" | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for fstream""... $ac_c" 1>&6
+echo "configure:9708: checking for fstream" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
#line 9713 "configure"
#include "confdefs.h"
-#include <fstream.h>
+#include <fstream>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
{ (eval echo configure:9718: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }

View File

@ -1,10 +0,0 @@
--- doc/version.texi.orig Fri Jun 7 10:44:55 2002
+++ doc/version.texi Fri Jun 7 10:46:19 2002
@@ -1,3 +1,7 @@
@set UPDATED 29 June 2001
@set EDITION 0.23.0
@set VERSION 0.23.0
+@dircategory Programming & development tools
+@direntry
+* Mifluz: (mifluz). C++ library to build and query a full text inverted index
+@end direntry

View File

@ -1,11 +1,11 @@
--- mifluz/Makefile.in.orig Mon Jul 23 22:12:14 2001
+++ mifluz/Makefile.in Tue Jul 30 00:26:00 2002
@@ -147,7 +147,7 @@
--- mifluz/Makefile.in.orig 2008-07-11 21:45:32.000000000 +0900
+++ mifluz/Makefile.in 2008-07-11 21:47:15.000000000 +0900
@@ -300,7 +300,7 @@
WordType.cc
libmifluz_la_LDFLAGS = -version-info $(MAJOR_VERSION):$(MINOR_VERSION):$(MICRO_VERSION)
-libmifluz_la_LIBADD = ../db/libdb.la ../clib/libclib.la
+libmifluz_la_LIBADD = ../db/libdb.la ../clib/libclib.la @LIBICONV@
include_HEADERS = mifluz.h
+libmifluz_la_LIBADD = ../db/libdb.la ../clib/libclib.la $(LIBICONV)
include_HEADERS = \
mifluz.h

View File

@ -1,11 +0,0 @@
--- mifluz/WordCursorOne.cc.orig 2007-11-22 11:41:12.000000000 +0100
+++ mifluz/WordCursorOne.cc 2007-11-22 11:41:27.000000000 +0100
@@ -44,7 +44,7 @@
}
// *****************************************************************************
-WordCursorOne::WordCursorOne(WordList *words, const WordKey &searchKey, int action = HTDIG_WORDLIST_WALKER) :
+WordCursorOne::WordCursorOne(WordList *words, const WordKey &searchKey, int action) :
WordCursor(words->GetContext()),
prefixKey(words->GetContext())
{

View File

@ -1,11 +0,0 @@
--- search/WordKeySemantic.cc.orig 2007-11-22 11:42:09.000000000 +0100
+++ search/WordKeySemantic.cc 2007-11-22 11:42:58.000000000 +0100
@@ -134,7 +134,7 @@
}
}
-int WordKeySemantic::LocationCompare(const WordKey& expected, const WordKey& actual, int proximity = 0)
+int WordKeySemantic::LocationCompare(const WordKey& expected, const WordKey& actual, int proximity)
{
int ret = 1;

View File

@ -1,6 +1,7 @@
bin/htdb_dump
bin/htdb_load
bin/htdb_stat
bin/mifluz-config
bin/mifluzdict
bin/mifluzdump
bin/mifluzload
@ -58,6 +59,7 @@ include/mifluz/db_upgrade.h
include/mifluz/db_verify.h
include/mifluz/debug.h
include/mifluz/env_ext.h
include/mifluz/example1.h
include/mifluz/hash.h
include/mifluz/hash_auto.h
include/mifluz/hash_ext.h