o New port fpc version 1.0.4: Free Pascal beta compiler with Turbo,

Delphi and other extensions
o Borrows install scripting tricks from halflifeserver port

PR:		32385
Submitted by:	John Merryweather Cooper <jmcoopr@webmail.bmi.net>
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2001-12-09 02:28:27 +00:00
parent 04186cfdb0
commit 36da4a1c41
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51265
23 changed files with 5195 additions and 0 deletions

View File

@ -38,6 +38,7 @@
SUBDIR += ferite
SUBDIR += fesi
SUBDIR += forth
SUBDIR += fpc
SUBDIR += gawk
SUBDIR += gcc-devel
SUBDIR += gcc27

149
lang/fpc-devel/Makefile Normal file
View File

@ -0,0 +1,149 @@
# New ports collection makefile for: Free Pascal Compiler
# Date created: 28 November 2001
# Whom: John Merryweather Cooper et al
#
# $FreeBSD$
#
PORTNAME= fpc
PORTVERSION= 1.0.4
CATEGORIES= lang
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/Freebsd/ \
ftp://ftp.epix.net/pub/languages/pascal/dist/Freebsd/ \
http://gd.tuwien.ac.at/languages/pascal/dist/Freebsd/ \
http://www.zeus.rug.ac.be/freepascal/files/dist/Freebsd/ \
ftp://ftp.darklands.cx/pub/fpc/dist/Freebsd/ \
ftp://ftp.jp.freepascal.org/mirror/fpc/dist/Freebsd/ \
ftp://deadlock.et.tudelft.nl/pub/fpc/dist/Freebsd/ \
ftp://ftp.no.freepascal.org/pub/fpc/dist/Freebsd/
DISTNAME= ${PORTNAME}-${PORTVERSION}.freebsd4
EXTRACT_SUFX= .tar
MAINTAINER= jmcoopr@webmail.bmi.net
BUILD_DEPENDS= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
RUN_DEPENDS= ${LOCALBASE}/bin/nasm:${PORTSDIR}/devel/nasm
.if !defined(NOPORTDOCS)
RUN_DEPENDS+= ${LOCALBASE}/bin/acroread4:${PORTSDIR}/print/acroread4
.endif
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
NO_BUILD= yes
PKGDEINSTALL= ${PKGINSTALL}
MAN1= delp.1 fpc.1 fpcmake.1 h2pas.1 plex.1 ppc386.1 ppdep.1 \
ppudump.1 ppufiles.1 ppumove.1 ptop.1 pyacc.1 rstconv.1
MAN5= fpcmake.5 ppc386.cfg.5 ptop.cfg.5
# programs
SORT?= /usr/bin/sort
TAR= ${LOCALBASE}/bin/gtar
# macro for creating directory with DATA perms
INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0755
.include <bsd.port.pre.mk>
LIBDIR= ${PREFIX}/lib/fpc/${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/fpc-${PORTVERSION}
TEMP_PREFIX= ${WRKSRC}/temp
TEMP_DOCSDIR= ${TEMP_PREFIX}/share/doc/fpc-${PORTVERSION}
TEMP_LIBDIR= ${TEMP_PREFIX}/lib/fpc/${PORTVERSION}
TEMP_EXMPDIR= ${TEMP_PREFIX}/share/examples
PLIST_SUB= LIBDIR=${LIBDIR}
# install staging area
pre-install:
@${TAR} xf ${WRKSRC}/binary.tar --directory ${WRKSRC}
@${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}
@${MKDIR} ${TEMP_PREFIX}
#unpack base system
@${TAR} zxf ${WRKSRC}/basefreebsd.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist \
--directory ${TEMP_PREFIX}
@${MKDIR} ${TEMP_DOCSDIR}
@${TAR} zxf ${WRKSRC}/basefreebsd.tar.gz \
--files-from ${FILESDIR}/tar-xlist \
--directory ${TEMP_PREFIX}/share
@${RM} -f ${TEMP_EXECDIR}/ppc386
#unpack units
@${TAR} zxf ${WRKSRC}/utilfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsfclfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsapifreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsbasefreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsnetfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsdbfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsgfxfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsmiscfreebsd.tar.gz --directory ${TEMP_PREFIX}
.ifndef(NOPORTDOCS)
#unpack documentation, examples, and sources
@${TAR} zxf ${WRKSRC}/basesrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/compilersrc.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist2 \
--directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/rtlsrc.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist3 \
--directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/fclsrc.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist4 \
--directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/apisrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/packagessrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/utilsrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/docs.tar.gz --directory ${TEMP_PREFIX}/share
@${MKDIR} ${TEMP_EXMPDIR}
@${TAR} zxf ${WRKSRC}/demo.tar.gz --directory ${TEMP_EXMPDIR}
@${MV} ${TEMP_EXMPDIR}/src/fpc-${PORTVERSION} \
${TEMP_PREFIX}/share/examples
@${RM} -rfd ${TEMP_EXMPDIR}/src
.endif
#unpack and patch sample (working) configuration file
@${PATCH} --dir ${TEMP_LIBDIR} < ${FILESDIR}/fix-samplecfg
do-install: install-parse-plist install-run-scripts run-pkg-install-script
# Contributed by <lioux@FreeBSD.org>
install-parse-plist: generate-plist
@${PERL} -e 'open(FHANDLER,"${TMPPLIST}");' \
-e 'open(FDIR,">${WRKDIR}/dirs.sh.tmp");' \
-e 'open(FFILES,">${WRKDIR}/files.sh");' \
-e 'while (!eof(FHANDLER)) {' \
-e 'chop($$file = <FHANDLER>);' \
-e '$$dir = $$file_partial = $$file;' \
-e '$$file_partial =~ s!^${HLDSDIR:S!^/!!}!!;' \
-e 'if ($$dir =~ s!(^\@dirrm\s+)!!) {' \
-e 'print FDIR "${INSTALL_DATA_DIR}", \
" ", "\"${PREFIX}/$$dir\"", \
"\n";' \
-e '} elsif ($$file !~ m!^\@!) {' \
-e 'if ($$dir =~ m!^bin!) {' \
-e 'print FFILES "${INSTALL_PROGRAM}";' \
-e '} elsif ($$dir =~ m!^(lib|share)!) {' \
-e 'print FFILES "${INSTALL_DATA}";' \
-e '} elsif ($$dir =~ m!^man!) {' \
-e 'print FFILES "${INSTALL_MAN}";' \
-e '($$file_partial =~ s!${MANEXT}$$!!);' \
-e '($$file =~ s!${MANEXT}$$!!);' \
-e '}' \
-e 'print FFILES " ", "\"${TEMP_PREFIX}/$$file_partial\"", \
" ", "\"${PREFIX}/$$file\"", \
"\n";' \
-e '}' \
-e '}' \
-e 'close(FFILES);' \
-e 'close(FDIR);' \
-e 'close(FHANDLER);'
@${SORT} ${WRKDIR}/dirs.sh.tmp > ${WRKDIR}/dirs.sh
install-run-scripts:
.for script in dirs files
@${SH} ${WRKDIR}/${script}.sh
.endfor
run-pkg-install-script:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>

1
lang/fpc-devel/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (fpc-1.0.4.freebsd4.tar) = 6dffb15c998283d45fa86a052852a9db

View File

@ -0,0 +1,30 @@
--- samplecfg Sat Dec 23 15:02:40 2000
+++ samplecfg.new Thu Nov 29 07:44:20 2001
@@ -4,7 +4,7 @@
#
# Generate Sample Free Pascal configuration file
#
-if [ $# == 0 ]; then
+if [ $# -eq 0 ]; then
echo 'Usage :'
echo 'samplecfg fpcdir confdir'
echo 'fpcdir = Path where FPC is installed'
@@ -38,9 +38,15 @@
fi
# Find path to libgcc.a
-GCCSPEC=`(gcc -v 2>&1)| head -n 1| awk '{ print $4 } '`
-GCCDIR=`dirname $GCCSPEC`
-echo Found libgcc.a in $GCCDIR
+#GCCSPEC=`(gcc -v 2>&1)| head -n 1| awk '{ print $4 } '`
+#GCCDIR=`dirname $GCCSPEC`
+GCCDIR=/usr/lib
+if [ -f $GCCDIR/libgcc.a ]; then
+ echo Found libgcc.a in $GCCDIR
+else
+ echo FreeBSD libgcc.a could not be found. Bailing out...
+ exit
+fi
# Write the file
echo Writing sample configuration file to $thefile

View File

@ -0,0 +1,9 @@
doc/fpc-1.0.4/faq.txt
doc/fpc-1.0.4/faq.htm
doc/fpc-1.0.4/copying.fpc
doc/fpc-1.0.4/copying.dj
doc/fpc-1.0.4/copying
doc/fpc-1.0.4/whatsnew.txt
doc/fpc-1.0.4/readme.txt
doc/fpc-1.0.4
doc

View File

@ -0,0 +1,4 @@
src/fpc-1.0.4/compiler/.#Makefile.1.1.2.15
src/fpc-1.0.4/compiler/.#Makefile.1.1.2.13
src/fpc-1.0.4/compiler/.#msgidx.inc.1.1.2.7
src/fpc-1.0.4/compiler/.#msgtxt.inc.1.1.2.7

View File

@ -0,0 +1,2 @@
src/fpc-1.0.4/rtl/unix/.#linsysca.inc.1.1.2.2
src/fpc-1.0.4/rtl/unix/.#linux.pp.1.1.2.1

View File

@ -0,0 +1 @@
src/fpc-1.0.4/fcl/inc/.#idea.pp.1.1

View File

@ -0,0 +1 @@
Free Pascal beta compiler with Turbo, Delphi and other extensions

9
lang/fpc-devel/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
Originally named FPK-Pascal, the Free Pascal compiler is a 32 bit
Turbo Pascal compatible Pascal compiler for DOS, Linux, Win32, OS/2
and (based on an older version) the AmigaOS. FreeBSD/ELF is a beta
release. A BeOS version is in development.
WWW: http://www.freepascal.org/
--
John Merryweather Cooper <jmcoopr@webmail.bmi.net>

View File

@ -0,0 +1,31 @@
#!/bin/sh
# $FreeBSD$
[ $# != 2 ] && exit 1
PKGNAME=$1
ACTION=$2
LIBDIR=${PKG_PREFIX}/lib/fpc/${PKGNAME##fpc-}
LN=/bin/ln
SH=/bin/sh
case "$ACTION" in
POST-INSTALL)
@${LN} -sf ${LIBDIR}/ppc386 ${PKG_PREFIX}/bin/ppc386
@${SH} ${LIBDIR}/samplecfg ${LIBDIR} ${PKG_PREFIX}/etc
;;
DEINSTALL)
;;
PRE-INSTALL|POST-DEINSTALL)
;;
*)
exit 1
;;
esac
exit

2360
lang/fpc-devel/pkg-plist Normal file

File diff suppressed because it is too large Load Diff

149
lang/fpc/Makefile Normal file
View File

@ -0,0 +1,149 @@
# New ports collection makefile for: Free Pascal Compiler
# Date created: 28 November 2001
# Whom: John Merryweather Cooper et al
#
# $FreeBSD$
#
PORTNAME= fpc
PORTVERSION= 1.0.4
CATEGORIES= lang
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/Freebsd/ \
ftp://ftp.epix.net/pub/languages/pascal/dist/Freebsd/ \
http://gd.tuwien.ac.at/languages/pascal/dist/Freebsd/ \
http://www.zeus.rug.ac.be/freepascal/files/dist/Freebsd/ \
ftp://ftp.darklands.cx/pub/fpc/dist/Freebsd/ \
ftp://ftp.jp.freepascal.org/mirror/fpc/dist/Freebsd/ \
ftp://deadlock.et.tudelft.nl/pub/fpc/dist/Freebsd/ \
ftp://ftp.no.freepascal.org/pub/fpc/dist/Freebsd/
DISTNAME= ${PORTNAME}-${PORTVERSION}.freebsd4
EXTRACT_SUFX= .tar
MAINTAINER= jmcoopr@webmail.bmi.net
BUILD_DEPENDS= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
RUN_DEPENDS= ${LOCALBASE}/bin/nasm:${PORTSDIR}/devel/nasm
.if !defined(NOPORTDOCS)
RUN_DEPENDS+= ${LOCALBASE}/bin/acroread4:${PORTSDIR}/print/acroread4
.endif
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
NO_BUILD= yes
PKGDEINSTALL= ${PKGINSTALL}
MAN1= delp.1 fpc.1 fpcmake.1 h2pas.1 plex.1 ppc386.1 ppdep.1 \
ppudump.1 ppufiles.1 ppumove.1 ptop.1 pyacc.1 rstconv.1
MAN5= fpcmake.5 ppc386.cfg.5 ptop.cfg.5
# programs
SORT?= /usr/bin/sort
TAR= ${LOCALBASE}/bin/gtar
# macro for creating directory with DATA perms
INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0755
.include <bsd.port.pre.mk>
LIBDIR= ${PREFIX}/lib/fpc/${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/fpc-${PORTVERSION}
TEMP_PREFIX= ${WRKSRC}/temp
TEMP_DOCSDIR= ${TEMP_PREFIX}/share/doc/fpc-${PORTVERSION}
TEMP_LIBDIR= ${TEMP_PREFIX}/lib/fpc/${PORTVERSION}
TEMP_EXMPDIR= ${TEMP_PREFIX}/share/examples
PLIST_SUB= LIBDIR=${LIBDIR}
# install staging area
pre-install:
@${TAR} xf ${WRKSRC}/binary.tar --directory ${WRKSRC}
@${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}
@${MKDIR} ${TEMP_PREFIX}
#unpack base system
@${TAR} zxf ${WRKSRC}/basefreebsd.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist \
--directory ${TEMP_PREFIX}
@${MKDIR} ${TEMP_DOCSDIR}
@${TAR} zxf ${WRKSRC}/basefreebsd.tar.gz \
--files-from ${FILESDIR}/tar-xlist \
--directory ${TEMP_PREFIX}/share
@${RM} -f ${TEMP_EXECDIR}/ppc386
#unpack units
@${TAR} zxf ${WRKSRC}/utilfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsfclfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsapifreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsbasefreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsnetfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsdbfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsgfxfreebsd.tar.gz --directory ${TEMP_PREFIX}
@${TAR} zxf ${WRKSRC}/unitsmiscfreebsd.tar.gz --directory ${TEMP_PREFIX}
.ifndef(NOPORTDOCS)
#unpack documentation, examples, and sources
@${TAR} zxf ${WRKSRC}/basesrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/compilersrc.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist2 \
--directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/rtlsrc.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist3 \
--directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/fclsrc.tar.gz \
--exclude-from ${FILESDIR}/tar-xlist4 \
--directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/apisrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/packagessrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/utilsrc.tar.gz --directory ${TEMP_PREFIX}/share
@${TAR} zxf ${WRKSRC}/docs.tar.gz --directory ${TEMP_PREFIX}/share
@${MKDIR} ${TEMP_EXMPDIR}
@${TAR} zxf ${WRKSRC}/demo.tar.gz --directory ${TEMP_EXMPDIR}
@${MV} ${TEMP_EXMPDIR}/src/fpc-${PORTVERSION} \
${TEMP_PREFIX}/share/examples
@${RM} -rfd ${TEMP_EXMPDIR}/src
.endif
#unpack and patch sample (working) configuration file
@${PATCH} --dir ${TEMP_LIBDIR} < ${FILESDIR}/fix-samplecfg
do-install: install-parse-plist install-run-scripts run-pkg-install-script
# Contributed by <lioux@FreeBSD.org>
install-parse-plist: generate-plist
@${PERL} -e 'open(FHANDLER,"${TMPPLIST}");' \
-e 'open(FDIR,">${WRKDIR}/dirs.sh.tmp");' \
-e 'open(FFILES,">${WRKDIR}/files.sh");' \
-e 'while (!eof(FHANDLER)) {' \
-e 'chop($$file = <FHANDLER>);' \
-e '$$dir = $$file_partial = $$file;' \
-e '$$file_partial =~ s!^${HLDSDIR:S!^/!!}!!;' \
-e 'if ($$dir =~ s!(^\@dirrm\s+)!!) {' \
-e 'print FDIR "${INSTALL_DATA_DIR}", \
" ", "\"${PREFIX}/$$dir\"", \
"\n";' \
-e '} elsif ($$file !~ m!^\@!) {' \
-e 'if ($$dir =~ m!^bin!) {' \
-e 'print FFILES "${INSTALL_PROGRAM}";' \
-e '} elsif ($$dir =~ m!^(lib|share)!) {' \
-e 'print FFILES "${INSTALL_DATA}";' \
-e '} elsif ($$dir =~ m!^man!) {' \
-e 'print FFILES "${INSTALL_MAN}";' \
-e '($$file_partial =~ s!${MANEXT}$$!!);' \
-e '($$file =~ s!${MANEXT}$$!!);' \
-e '}' \
-e 'print FFILES " ", "\"${TEMP_PREFIX}/$$file_partial\"", \
" ", "\"${PREFIX}/$$file\"", \
"\n";' \
-e '}' \
-e '}' \
-e 'close(FFILES);' \
-e 'close(FDIR);' \
-e 'close(FHANDLER);'
@${SORT} ${WRKDIR}/dirs.sh.tmp > ${WRKDIR}/dirs.sh
install-run-scripts:
.for script in dirs files
@${SH} ${WRKDIR}/${script}.sh
.endfor
run-pkg-install-script:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>

1
lang/fpc/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (fpc-1.0.4.freebsd4.tar) = 6dffb15c998283d45fa86a052852a9db

View File

@ -0,0 +1,30 @@
--- samplecfg Sat Dec 23 15:02:40 2000
+++ samplecfg.new Thu Nov 29 07:44:20 2001
@@ -4,7 +4,7 @@
#
# Generate Sample Free Pascal configuration file
#
-if [ $# == 0 ]; then
+if [ $# -eq 0 ]; then
echo 'Usage :'
echo 'samplecfg fpcdir confdir'
echo 'fpcdir = Path where FPC is installed'
@@ -38,9 +38,15 @@
fi
# Find path to libgcc.a
-GCCSPEC=`(gcc -v 2>&1)| head -n 1| awk '{ print $4 } '`
-GCCDIR=`dirname $GCCSPEC`
-echo Found libgcc.a in $GCCDIR
+#GCCSPEC=`(gcc -v 2>&1)| head -n 1| awk '{ print $4 } '`
+#GCCDIR=`dirname $GCCSPEC`
+GCCDIR=/usr/lib
+if [ -f $GCCDIR/libgcc.a ]; then
+ echo Found libgcc.a in $GCCDIR
+else
+ echo FreeBSD libgcc.a could not be found. Bailing out...
+ exit
+fi
# Write the file
echo Writing sample configuration file to $thefile

9
lang/fpc/files/tar-xlist Normal file
View File

@ -0,0 +1,9 @@
doc/fpc-1.0.4/faq.txt
doc/fpc-1.0.4/faq.htm
doc/fpc-1.0.4/copying.fpc
doc/fpc-1.0.4/copying.dj
doc/fpc-1.0.4/copying
doc/fpc-1.0.4/whatsnew.txt
doc/fpc-1.0.4/readme.txt
doc/fpc-1.0.4
doc

View File

@ -0,0 +1,4 @@
src/fpc-1.0.4/compiler/.#Makefile.1.1.2.15
src/fpc-1.0.4/compiler/.#Makefile.1.1.2.13
src/fpc-1.0.4/compiler/.#msgidx.inc.1.1.2.7
src/fpc-1.0.4/compiler/.#msgtxt.inc.1.1.2.7

View File

@ -0,0 +1,2 @@
src/fpc-1.0.4/rtl/unix/.#linsysca.inc.1.1.2.2
src/fpc-1.0.4/rtl/unix/.#linux.pp.1.1.2.1

View File

@ -0,0 +1 @@
src/fpc-1.0.4/fcl/inc/.#idea.pp.1.1

1
lang/fpc/pkg-comment Normal file
View File

@ -0,0 +1 @@
Free Pascal beta compiler with Turbo, Delphi and other extensions

9
lang/fpc/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
Originally named FPK-Pascal, the Free Pascal compiler is a 32 bit
Turbo Pascal compatible Pascal compiler for DOS, Linux, Win32, OS/2
and (based on an older version) the AmigaOS. FreeBSD/ELF is a beta
release. A BeOS version is in development.
WWW: http://www.freepascal.org/
--
John Merryweather Cooper <jmcoopr@webmail.bmi.net>

31
lang/fpc/pkg-install Normal file
View File

@ -0,0 +1,31 @@
#!/bin/sh
# $FreeBSD$
[ $# != 2 ] && exit 1
PKGNAME=$1
ACTION=$2
LIBDIR=${PKG_PREFIX}/lib/fpc/${PKGNAME##fpc-}
LN=/bin/ln
SH=/bin/sh
case "$ACTION" in
POST-INSTALL)
@${LN} -sf ${LIBDIR}/ppc386 ${PKG_PREFIX}/bin/ppc386
@${SH} ${LIBDIR}/samplecfg ${LIBDIR} ${PKG_PREFIX}/etc
;;
DEINSTALL)
;;
PRE-INSTALL|POST-DEINSTALL)
;;
*)
exit 1
;;
esac
exit

2360
lang/fpc/pkg-plist Normal file

File diff suppressed because it is too large Load Diff