Update to 9.04.

This commit is contained in:
Hiroki Sato 2012-01-15 08:02:26 +00:00
parent e360f3613c
commit 36c6b82601
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=289253
10 changed files with 74 additions and 97 deletions

View File

@ -6,10 +6,9 @@
#
PORTNAME= ghostscript9
PORTVERSION= 9.02
PORTREVISION= 4
PORTVERSION= 9.04
CATEGORIES= print
MASTER_SITES= http://ghostscript.com/releases/:gs_srcs \
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/files/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs${PORTVERSION:S/.//}/:gs_srcs \
http://www.humblesoft.com/pub/:epag

View File

@ -1,4 +1,4 @@
SHA256 (ghostscript/ghostscript-9.02.tar.bz2) = 03ea2cad13a36f8f9160912012b79619a826e7148fada6d3531feb25409ee05a
SIZE (ghostscript/ghostscript-9.02.tar.bz2) = 23748868
SHA256 (ghostscript/ghostscript-9.04.tar.bz2) = f82c20b44ad3c204e2b78afbcd03a32dd523d26f5e18bf4508f3dfcbbfd30bc4
SIZE (ghostscript/ghostscript-9.04.tar.bz2) = 29869900
SHA256 (ghostscript/epag-3.09.tar.gz) = ad10eca44c781a5851d5a8993dcd95b2e2b99392cbf2c8372a5a658f3b991b3b
SIZE (ghostscript/epag-3.09.tar.gz) = 12858

View File

@ -1,10 +0,0 @@
--- base/errors.h.orig 2007-06-06 07:23:38.000000000 +0900
+++ base/errors.h 2009-03-29 03:53:40.000000000 +0900
@@ -21,6 +21,6 @@
*/
/* We include that file here to backward compatibility */
-#include "ierrors.h"
+#include "../psi/ierrors.h"
#endif /* errors_INCLUDED */

View File

@ -1,11 +1,11 @@
--- base/gdevperm.c.orig Tue Sep 25 22:31:24 2007
+++ base/gdevperm.c Sat Nov 24 15:11:12 2007
@@ -286,7 +286,7 @@
(strncmp((const char *)name, (const char *)str, name_size) == 0))
--- base/gdevperm.c.orig 2011-12-06 15:37:48.000000000 +0900
+++ base/gdevperm.c 2011-12-06 15:45:20.000000000 +0900
@@ -285,7 +285,7 @@
(strncmp((const char *)name, (const char *)str, name_size) == 0))
static int
-perm_get_color_comp_index(const gx_device *pdev, const char *pname,
+perm_get_color_comp_index(gx_device *pdev, const char *pname,
int name_size, int component_type)
int name_size, int component_type)
{
const gx_device_perm_t * const dev = (const gx_device_perm_t *)pdev;

View File

@ -1,17 +1,10 @@
--- base/gsicc_create.c.orig 2011-05-23 13:33:34.000000000 +0900
+++ base/gsicc_create.c 2011-05-23 13:33:52.000000000 +0900
@@ -116,6 +116,7 @@
--- base/gsicc_create.c.orig 2011-08-05 20:12:20.000000000 +0900
+++ base/gsicc_create.c 2011-12-06 15:23:14.000000000 +0900
@@ -113,6 +113,7 @@
*/
+#include <sys/types.h>
#include "icc34.h" /* Note this header is needed even if lcms is not
#include "icc34.h" /* Note this header is needed even if lcms is not
compiled as default CMS */
#include "string_.h"
@@ -2350,4 +2351,4 @@
icHeader *header = &(iccprofile.header);
setheader_common(header);
-}
\ No newline at end of file
+}

View File

@ -1,11 +0,0 @@
--- base/lib.mak.orig 2011-06-10 13:41:36.000000000 +0900
+++ base/lib.mak 2011-06-10 13:42:59.000000000 +0900
@@ -25,7 +25,7 @@
GLI_=$(GLGENDIR) $(II)$(GLSRCDIR)
GLF_=
GLCCFLAGS=$(I_)$(GLI_)$(_I) $(GLF_)
-GLCC=$(CC_) $(GLCCFLAGS)
+GLCC=$(GLCCSHARED)
GLJCC=$(CC_) $(I_)$(GLI_) $(II)$(JI_)$(_I) $(JCF_) $(GLF_)
GLZCC=$(CC_) $(I_)$(GLI_) $(II)$(ZI_)$(_I) $(ZCF_) $(GLF_)
GLJBIG2CC=$(CC_) $(I_)$(GLI_) $(II)$(JB2I_)$(_I) $(JB2CF_) $(GLF_)

View File

@ -1,33 +1,33 @@
--- base/unix-gcc.mak.orig 2011-03-04 05:23:43.000000000 +0900
+++ base/unix-gcc.mak 2011-05-23 14:31:00.000000000 +0900
@@ -21,15 +21,18 @@
--- base/unix-gcc.mak.orig 2011-08-05 20:12:20.000000000 +0900
+++ base/unix-gcc.mak 2011-12-06 15:26:48.000000000 +0900
@@ -21,16 +21,17 @@
# source, generated intermediate file, and object directories
# for the graphics library (GL) and the PostScript/PDF interpreter (PS).
+.CURDIR?=.
BINDIR=./bin
-BINDIR=./$(BUILDDIRPREFIX)bin
-GLSRCDIR=./base
-GLGENDIR=./obj
-GLOBJDIR=./obj
-GLGENDIR=./$(BUILDDIRPREFIX)obj
-GLOBJDIR=./$(BUILDDIRPREFIX)obj
+.CURDIR?=.
+BINDIR=${.CURDIR}/$(BUILDDIRPREFIX)bin
+GLSRCDIR=${.CURDIR}/base
+GLGENDIR=${.CURDIR}/$(BUILDDIRPREFIX)obj
+GLOBJDIR=${.CURDIR}/$(BUILDDIRPREFIX)obj
AUXDIR=$(GLGENDIR)/aux
-PSSRCDIR=./psi
-PSLIBDIR=./lib
-PSRESDIR=./Resource
-PSGENDIR=./obj
-PSOBJDIR=./obj
+BINDIR=${.CURDIR}/bin
+GLSRCDIR=${.CURDIR}/base
+GLGENDIR=${.CURDIR}/obj
+GLOBJDIR=${.CURDIR}/obj
-PSGENDIR=./$(BUILDDIRPREFIX)obj
-PSOBJDIR=./$(BUILDDIRPREFIX)obj
+PSSRCDIR=${.CURDIR}/psi
+PSLIBDIR=${.CURDIR}/lib
+PSRESDIR=${.CURDIR}/Resource
+PSGENDIR=${.CURDIR}/obj
+PSOBJDIR=${.CURDIR}/obj
+CONTRIBDIR=${.CURDIR}/contrib
+PSGENDIR=${.CURDIR}/$(BUILDDIRPREFIX)obj
+PSOBJDIR=${.CURDIR}/$(BUILDDIRPREFIX)obj
# Do not edit the next group of lines.
@@ -48,11 +51,10 @@
@@ -49,11 +50,10 @@
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
@ -42,16 +42,16 @@
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
scriptdir = $(bindir)
@@ -104,7 +106,7 @@
# -DHAVE_HYPOT
# use the system hypot() call
@@ -103,7 +103,7 @@
# This uses the more secure temporary file creation call
# Enable this if it is available on your platform.
-CAPOPT= -DHAVE_MKSTEMP
+CAPOPT= -DHAVE_MKSTEMP -DHAVE_HYPOT
# Define the name of the executable file.
@@ -138,7 +140,7 @@
@@ -137,7 +137,7 @@
# some older JPEG streams that violate the standard. If the JPEG
# library built from local sources, the patch will be applied.
@ -60,7 +60,7 @@
JPEG_NAME=jpeg
# Define the directory where the PNG library sources are stored,
@@ -152,13 +154,13 @@
@@ -151,13 +151,13 @@
# what its name is.
# See gs.mak and Make.htm for more information.
@ -76,7 +76,7 @@
TIFFSRCDIR=tiff
TIFFPLATFORM=unix
TIFFCONFIG_SUFFIX=.unix
@@ -173,15 +175,23 @@
@@ -172,15 +172,23 @@
# what its name is (usually libz, but sometimes libgz).
# See gs.mak and Make.htm for more information.
@ -102,7 +102,7 @@
# Define the directory where the icclib source are stored.
# See icclib.mak for more information
ICCSRCDIR=icclib
@@ -217,7 +227,7 @@
@@ -226,7 +234,7 @@
# Define the name of the C compiler.
@ -111,7 +111,7 @@
# Define the name of the linker for the final link step.
# Normally this is the same as the C compiler.
@@ -234,7 +244,7 @@
@@ -243,7 +251,7 @@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
@ -120,7 +120,7 @@
CFLAGS_DEBUG=-g -O0
CFLAGS_PROFILE=-pg -O2
CFLAGS_SO=-fPIC
@@ -250,7 +260,8 @@
@@ -259,7 +267,8 @@
# We don't include -ansi, because this gets in the way of the platform-
# specific stuff that <math.h> typically needs; nevertheless, we expect
# gcc to accept ANSI-style function prototypes and function definitions.
@ -130,7 +130,7 @@
CFLAGS=$(CFLAGS_STANDARD) $(GCFLAGS) $(XCFLAGS)
@@ -261,7 +272,7 @@
@@ -270,7 +279,7 @@
# -R /usr/local/xxx/lib:/usr/local/lib
# giving the full path names of the shared library directories.
# XLDFLAGS can be set from the command line.
@ -139,7 +139,7 @@
LDFLAGS=$(XLDFLAGS)
@@ -272,7 +283,7 @@
@@ -281,7 +290,7 @@
# Solaris may need -lnsl -lsocket -lposix4.
# (Libraries required by individual drivers are handled automatically.)
@ -148,7 +148,7 @@
# Define the standard libraries to search at the end of linking.
# Most platforms require -lpthread for the POSIX threads library;
@@ -294,7 +305,7 @@
@@ -303,7 +312,7 @@
# Note that x_.h expects to find the header files in $(XINCLUDE)/X11,
# not in $(XINCLUDE).
@ -157,7 +157,7 @@
# Define the directory/ies and library names for the X11 library files.
# XLIBDIRS is for ld and should include -L; XLIBDIR is for LD_RUN_PATH
@@ -309,26 +320,26 @@
@@ -318,26 +327,26 @@
#XLIBS=Xt SM ICE Xext X11
#XLIBDIRS=-L/usr/local/X/lib
@ -189,7 +189,7 @@
#FEATURE_DEVS=$(PSD)psl3.dev $(PSD)pdf.dev
# The following is strictly for testing.
FEATURE_DEVS_ALL=$(PSD)psl3.dev $(PSD)pdf.dev $(PSD)dpsnext.dev $(PSD)ttfont.dev $(PSD)rasterop.dev $(PSD)double.dev $(PSD)trapping.dev $(PSD)stocht.dev $(GLD)pipe.dev
@@ -460,6 +471,9 @@
@@ -476,6 +485,9 @@
include $(GLSRCDIR)/png.mak
include $(GLSRCDIR)/tiff.mak
include $(GLSRCDIR)/jbig2.mak
@ -199,7 +199,7 @@
include $(GLSRCDIR)/icclib.mak
include $(GLSRCDIR)/lcms.mak
include $(GLSRCDIR)/ijs.mak
@@ -470,6 +484,7 @@
@@ -486,6 +498,7 @@
include $(GLSRCDIR)/unix-dll.mak
include $(GLSRCDIR)/unix-end.mak
include $(GLSRCDIR)/unixinst.mak

View File

@ -1,5 +1,14 @@
--- contrib/japanese/gdevdmpr.c.orig Thu Apr 26 01:27:24 2007
+++ contrib/japanese/gdevdmpr.c Tue May 15 01:44:09 2007
--- contrib/japanese/gdevdmpr.c.orig 2011-08-05 20:12:20.000000000 +0900
+++ contrib/japanese/gdevdmpr.c 2011-12-06 15:36:10.000000000 +0900
@@ -32,7 +32,7 @@
#include "gdevprn.h"
#include "gp.h"
-#include "errors.h"
+#include "psi/ierrors.h"
#include "gsparam.h"
#include "gsstate.h"
#include "math_.h"
@@ -41,8 +41,6 @@
/* include library header. */
#include "dviprlib.h"
@ -9,25 +18,25 @@
#define LOCAL_DEBUG 0
#define DEVICE_NAME "dmprt"
@@ -405,8 +403,6 @@
@@ -402,8 +400,6 @@
if (pddev->dmprt.max_height>0 && pddev->dmprt.max_height<pddev->height)
pddev->height = pddev->dmprt.max_height;
- dviprt_setmessagestream(pddev->dmprt.debug_f ? stderr : NULL);
-
-
return code;
}
@@ -425,8 +421,6 @@
@@ -422,8 +418,6 @@
if (code < 0) return code;
if (code == 0) pddev->dmprt.debug_f = vbool;
- dviprt_setmessagestream(pddev->dmprt.debug_f ? stderr : NULL);
-
-
code = param_read_bool(plist, "Verbose", &vbool);
if (code < 0) return code;
pddev->dmprt.verbose_f = vbool;
@@ -841,13 +835,12 @@
@@ -846,13 +840,12 @@
char *env;
strcpy(fname,fnamebase);

View File

@ -1,18 +1,18 @@
--- contrib/lips4/gdevlips.c.orig Thu Nov 2 12:09:18 2000
+++ contrib/lips4/gdevlips.c Tue Jan 13 01:23:47 2004
--- contrib/lips4/gdevlips.c.orig 2011-08-05 20:12:20.000000000 +0900
+++ contrib/lips4/gdevlips.c 2011-12-06 15:31:38.000000000 +0900
@@ -62,7 +62,15 @@
height = tmp;
height = tmp;
}
for (pt = lips_paper_table; pt->num_unit < 80; pt++)
+/* add by shige 11/06 2003 */
+#ifdef USE_LIPS_SIZE_ERROR
+ if(pt->width+LIPS_SIZE_ERROR_VALUE>=width
+ && pt->width-LIPS_SIZE_ERROR_VALUE<=width
+ && pt->height+LIPS_SIZE_ERROR_VALUE>=height
+ && pt->height-LIPS_SIZE_ERROR_VALUE<=height)
+ && pt->width-LIPS_SIZE_ERROR_VALUE<=width
+ && pt->height+LIPS_SIZE_ERROR_VALUE>=height
+ && pt->height-LIPS_SIZE_ERROR_VALUE<=height)
+#else
if (pt->width == width && pt->height == height)
if (pt->width == width && pt->height == height)
+#endif
break;
break;
return pt->num_unit + landscape;

View File

@ -1,10 +1,8 @@
@comment $FreeBSD: /tmp/pcvs/ports/print/ghostscript9/pkg-plist,v 1.3 2011-06-10 09:10:52 hrs Exp $
bin/bdftops
@comment $FreeBSD: /tmp/pcvs/ports/print/ghostscript9/pkg-plist,v 1.4 2012-01-15 08:02:25 hrs Exp $
bin/dumphint
bin/dvipdf
bin/eps2eps
%%GS_dmprt%%bin/ert
bin/fixmswrd.pl
bin/font2c
bin/gs
bin/gsbj
@ -33,7 +31,6 @@ bin/ps2pdf14
bin/ps2pdfwr
bin/ps2ps
bin/ps2ps2
bin/pv.sh
bin/unix-lpr.sh
bin/wftopfa
include/ghostscript/gdevdsp.h
@ -341,6 +338,7 @@ lib/libgs.so.%%GS_VERSION%%
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/default_gray.icc
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/default_rgb.icc
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/lab.icc
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/gray_to_k.icc
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/ps_cmyk.icc
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/ps_gray.icc
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/ps_rgb.icc
@ -490,7 +488,6 @@ lib/libgs.so.%%GS_VERSION%%
%%DATADIR%%/%%GS_VERSION%%/lib/acctest.ps
%%DATADIR%%/%%GS_VERSION%%/lib/addxchar.ps
%%DATADIR%%/%%GS_VERSION%%/lib/align.ps
%%DATADIR%%/%%GS_VERSION%%/lib/bdftops.ps
%%DATADIR%%/%%GS_VERSION%%/lib/caption.ps
%%DATADIR%%/%%GS_VERSION%%/lib/cid2code.ps
%%DATADIR%%/%%GS_VERSION%%/lib/decrypt.ps