Add scummvm-tools.
This is a collection of various tools that may be useful to use in conjunction with ScummVM. It includes tools that will allow you to decompile and extract SCUMM scripts from various games, as well as graphics and sound. Of special note is the extract utility, which uses libmp3lame to compress a monster.sou file to about 25% its original size.
This commit is contained in:
parent
f211a290fd
commit
36bdeacda1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81962
@ -298,6 +298,7 @@
|
||||
SUBDIR += scid
|
||||
SUBDIR += scorched3d-devel
|
||||
SUBDIR += scummvm
|
||||
SUBDIR += scummvm-tools
|
||||
SUBDIR += sdlroids
|
||||
SUBDIR += seabattle
|
||||
SUBDIR += seahaven
|
||||
|
37
games/scummvm-tools/Makefile
Normal file
37
games/scummvm-tools/Makefile
Normal file
@ -0,0 +1,37 @@
|
||||
# New ports collection makefile for: scummvm-tools
|
||||
# Date created: 28 May 2003
|
||||
# Whom: Adam Weinberger <adamw@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= scummvm-tools
|
||||
PORTVERSION= 0.4.1
|
||||
CATEGORIES= games emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= scummvm
|
||||
|
||||
MAINTAINER= flynn@energyhq.es.eu.org
|
||||
COMMENT= Tools for use with the SCUMMVM game emulator
|
||||
|
||||
RUN_DEPENDS= scummvm:${PORTSDIR}/games/scummvm
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
pre-patch:
|
||||
@${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
.for i in extract rescumm descumm descumm6 simon1decr simon2mp3
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
|
||||
.endfor
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/scummvm-tools/distinfo
Normal file
1
games/scummvm-tools/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (scummvm-tools-0.4.1.tar.bz2) = d7415eb6e55a78061964930563f78308
|
19
games/scummvm-tools/files/patch-simon1descr.c
Normal file
19
games/scummvm-tools/files/patch-simon1descr.c
Normal file
@ -0,0 +1,19 @@
|
||||
--- simon1decr.c.orig Tue May 27 16:34:14 2003
|
||||
+++ simon1decr.c Tue May 27 16:34:34 2003
|
||||
@@ -26,14 +26,9 @@
|
||||
|
||||
#define EndGetM32(a) ((((a)[0])<<24)|(((a)[1])<<16)|(((a)[2])<<8)|((a)[3]))
|
||||
|
||||
-#define SD_GETBIT(var) do { \
|
||||
- if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } \
|
||||
- (var) = bb & 1; bb >>= 1; \
|
||||
-} while (0)
|
||||
+#define SD_GETBIT(var) do { if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } (var) = bb & 1; bb >>= 1; } while (0)
|
||||
|
||||
-#define SD_GETBITS(var, nbits) do { \
|
||||
- bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } \
|
||||
-} while (0)
|
||||
+#define SD_GETBITS(var, nbits) do { bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } } while (0)
|
||||
|
||||
#define SD_TYPE_LITERAL (0)
|
||||
#define SD_TYPE_MATCH (1)
|
10
games/scummvm-tools/pkg-descr
Normal file
10
games/scummvm-tools/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
This is a collection of various tools that may be useful to use in
|
||||
conjunction with ScummVM. It includes tools that will allow you to
|
||||
decompile and extract SCUMM scripts from various games, as well as
|
||||
graphics and sound. Of special note is the extract utility, which
|
||||
uses libmp3lame to compress a monster.sou file to about 25% its
|
||||
original size.
|
||||
|
||||
WWW: http://scummvm.sourceforge.net/
|
||||
|
||||
-Miguel Mendez <flynn@energyhq.es.eu.org>
|
8
games/scummvm-tools/pkg-plist
Normal file
8
games/scummvm-tools/pkg-plist
Normal file
@ -0,0 +1,8 @@
|
||||
bin/extract
|
||||
bin/rescumm
|
||||
bin/descumm
|
||||
bin/descumm6
|
||||
bin/simon1decr
|
||||
bin/simon2mp3
|
||||
%%PORTDOCS%%share/doc/scummvm-tools/README
|
||||
%%PORTDOCS%%@dirrm share/doc/scummvm-tools
|
Loading…
Reference in New Issue
Block a user