Update to version 1.0.3.
PR: 28135 Submitted by: maintainer
This commit is contained in:
parent
401f2a77d8
commit
369fa2ec94
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44120
@ -6,10 +6,9 @@
|
||||
#
|
||||
|
||||
PORTNAME= gliv
|
||||
PORTVERSION= 1.0b7
|
||||
PORTVERSION= 1.0.3
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://gliv.tuxfamily.org/
|
||||
DISTNAME= GLiv-1.0beta7
|
||||
|
||||
MAINTAINER= ishmael27@home.com
|
||||
|
||||
@ -21,9 +20,10 @@ USE_GMAKE= yes
|
||||
USE_MESA= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X_PREFIX= yes
|
||||
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lgnugetopt" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include"
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-lm" \
|
||||
LIBS="-L${LOCALBASE}/lib -lgnugetopt"
|
||||
|
||||
MAN1= GLiv.1
|
||||
MAN1= gliv.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (GLiv-1.0beta7.tar.bz2) = 3ec72e4c3a517d79c4511a7c3791a5dc
|
||||
MD5 (gliv-1.0.3.tar.bz2) = 52cb042fa6453304a616fa9737aaa61f
|
||||
|
45
graphics/gliv/files/patch-cmdline.c
Normal file
45
graphics/gliv/files/patch-cmdline.c
Normal file
@ -0,0 +1,45 @@
|
||||
--- cmdline.c.orig Fri Jun 8 10:59:27 2001
|
||||
+++ cmdline.c Wed Jun 13 19:41:21 2001
|
||||
@@ -44,7 +44,6 @@
|
||||
-s --shuffle Show images in random order (default=off)\n\
|
||||
-l --load-requested Load only when requested (default=off)\n\
|
||||
-v --verbose Verbose mode (default=off)\n\
|
||||
- -R --recursive Process directories recursively (default=off)\n\
|
||||
-i --info Show infos about displayed image (default=off)\n\
|
||||
-m --maximize Maximize image to fit screen (default=off)\n\
|
||||
-dINT --delay=INT Delay before hiding the cursor\n\
|
||||
@@ -80,7 +79,6 @@
|
||||
args_info->shuffle_given = 0 ;
|
||||
args_info->load_requested_given = 0 ;
|
||||
args_info->verbose_given = 0 ;
|
||||
- args_info->recursive_given = 0 ;
|
||||
args_info->info_given = 0 ;
|
||||
args_info->maximize_given = 0 ;
|
||||
args_info->delay_given = 0 ;
|
||||
@@ -89,7 +87,6 @@
|
||||
args_info->shuffle_flag = 0;\
|
||||
args_info->load_requested_flag = 0;\
|
||||
args_info->verbose_flag = 0;\
|
||||
- args_info->recursive_flag = 0;\
|
||||
args_info->info_flag = 0;\
|
||||
args_info->maximize_flag = 0;\
|
||||
}
|
||||
@@ -109,7 +106,6 @@
|
||||
{ "shuffle", 0, NULL, 's' },
|
||||
{ "load-requested", 0, NULL, 'l' },
|
||||
{ "verbose", 0, NULL, 'v' },
|
||||
- { "recursive", 0, NULL, 'R' },
|
||||
{ "info", 0, NULL, 'i' },
|
||||
{ "maximize", 0, NULL, 'm' },
|
||||
{ "delay", 1, NULL, 'd' },
|
||||
@@ -146,10 +142,6 @@
|
||||
|
||||
case 'v': /* Verbose mode. */
|
||||
args_info->verbose_flag = !(args_info->verbose_flag);
|
||||
- break;
|
||||
-
|
||||
- case 'R': /* Process directories recursively. */
|
||||
- args_info->recursive_flag = !(args_info->recursive_flag);
|
||||
break;
|
||||
|
||||
case 'i': /* Show infos about displayed image. */
|
18
graphics/gliv/files/patch-cmdline.h
Normal file
18
graphics/gliv/files/patch-cmdline.h
Normal file
@ -0,0 +1,18 @@
|
||||
--- cmdline.h.orig Fri Jun 8 10:59:27 2001
|
||||
+++ cmdline.h Wed Jun 13 19:53:13 2001
|
||||
@@ -24,7 +24,6 @@
|
||||
int shuffle_flag; /* Show images in random order (default=off). */
|
||||
int load_requested_flag; /* Load only when requested (default=off). */
|
||||
int verbose_flag; /* Verbose mode (default=off). */
|
||||
- int recursive_flag; /* Process directories recursively (default=off). */
|
||||
int info_flag; /* Show infos about displayed image (default=off). */
|
||||
int maximize_flag; /* Maximize image to fit screen (default=off). */
|
||||
int delay_arg; /* Delay before hiding the cursor. */
|
||||
@@ -35,7 +34,6 @@
|
||||
int shuffle_given ; /* Whether shuffle was given. */
|
||||
int load_requested_given ; /* Whether load-requested was given. */
|
||||
int verbose_given ; /* Whether verbose was given. */
|
||||
- int recursive_given ; /* Whether recursive was given. */
|
||||
int info_given ; /* Whether info was given. */
|
||||
int maximize_given ; /* Whether maximize was given. */
|
||||
int delay_given ; /* Whether delay was given. */
|
12
graphics/gliv/files/patch-gliv.1
Normal file
12
graphics/gliv/files/patch-gliv.1
Normal file
@ -0,0 +1,12 @@
|
||||
--- gliv.1.orig Fri Jun 8 17:17:03 2001
|
||||
+++ gliv.1 Wed Jun 13 19:45:13 2001
|
||||
@@ -29,9 +29,6 @@
|
||||
\fB\-v, \-\-verbose\fR
|
||||
Print some information (default=off). Use it to know more about your hardware and to see \fIgliv\fR loading and unloading images.
|
||||
.TP
|
||||
-\fB\-R, \-\-recursive\fR
|
||||
-Processe directories recursively (default=off). If you specify a directory in the command line \fIgliv\fR will open every image in this directory and its subdirectories.
|
||||
-.TP
|
||||
\fB\-i, \-\-info\fR
|
||||
Show infos about displayed image (default=off). With this option, \fIgliv\fR will by default print the info lines you can obtain by typing 'i'.
|
||||
.TP
|
54
graphics/gliv/files/patch-gliv.c
Normal file
54
graphics/gliv/files/patch-gliv.c
Normal file
@ -0,0 +1,54 @@
|
||||
--- gliv.c.orig Tue Jun 12 14:40:17 2001
|
||||
+++ gliv.c Wed Jun 13 19:42:54 2001
|
||||
@@ -120,37 +120,6 @@
|
||||
}
|
||||
|
||||
/***************************************
|
||||
- * Adds a filename to the list. This *
|
||||
- *function is only used by ftw when the*
|
||||
- * -R flag is given. *
|
||||
- ***************************************/
|
||||
-static int add_to_list(const char *file, const struct stat *st, int flag)
|
||||
-{
|
||||
- if (flag == FTW_F) {
|
||||
- /* It is not a directory, we don't care if it is an image or not. */
|
||||
- total++;
|
||||
- names = realloc(names, total * sizeof(char *));
|
||||
- names[total - 1] = strdup(file);
|
||||
- }
|
||||
- return 0;
|
||||
-}
|
||||
-
|
||||
-/***************************************
|
||||
- * Recursively adds all files to the *
|
||||
- * list by descending directories. The *
|
||||
- * image list is the variable 'names'. *
|
||||
- ***************************************/
|
||||
-static void build_image_list(char **array, unsigned int nb)
|
||||
-{
|
||||
- unsigned int i;
|
||||
-
|
||||
- for (i = 0; i < nb; i++) {
|
||||
- ftw(array[i], add_to_list, 8);
|
||||
- free(array[i]);
|
||||
- }
|
||||
-}
|
||||
-
|
||||
-/***************************************
|
||||
* Sets global variables according *
|
||||
* to command-line arguments. *
|
||||
***************************************/
|
||||
@@ -166,13 +135,8 @@
|
||||
rt.info = args->info_flag;
|
||||
rt.maximize = args->maximize_flag;
|
||||
|
||||
- if (args->recursive_flag) {
|
||||
- build_image_list(args->inputs, args->inputs_num);
|
||||
- free(args->inputs);
|
||||
- } else {
|
||||
total = args->inputs_num;
|
||||
names = args->inputs;
|
||||
- }
|
||||
|
||||
if (total < 2)
|
||||
/* Don't use a thread for only one image. */
|
10
graphics/gliv/files/patch-gliv.ggo
Normal file
10
graphics/gliv/files/patch-gliv.ggo
Normal file
@ -0,0 +1,10 @@
|
||||
--- gliv.ggo.orig Fri Jun 8 10:59:27 2001
|
||||
+++ gliv.ggo Wed Jun 13 19:46:09 2001
|
||||
@@ -2,7 +2,6 @@
|
||||
option "shuffle" s "Show images in random order" flag off
|
||||
option "load-requested" l "Load only when requested" flag off
|
||||
option "verbose" v "Verbose mode" flag off
|
||||
-option "recursive" R "Process directories recursively" flag off
|
||||
option "info" i "Show infos about displayed image" flag off
|
||||
option "maximize" m "Maximize image to fit screen" flag off
|
||||
option "delay" d "Delay before hiding the cursor" int no
|
10
graphics/gliv/files/patch-gliv.h
Normal file
10
graphics/gliv/files/patch-gliv.h
Normal file
@ -0,0 +1,10 @@
|
||||
--- gliv.h.orig Sun Jun 10 13:46:58 2001
|
||||
+++ gliv.h Wed Jun 13 19:42:26 2001
|
||||
@@ -11,7 +11,6 @@
|
||||
#include <unistd.h>
|
||||
#include <pthread.h>
|
||||
#include <signal.h>
|
||||
-#include <ftw.h>
|
||||
#include "cmdline.h"
|
||||
|
||||
/***************************************
|
@ -1 +1 @@
|
||||
bin/GLiv
|
||||
bin/gliv
|
||||
|
Loading…
Reference in New Issue
Block a user